Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 6 respuestas, has 2 mensajes.

Last updated by Andrés hace 12 meses.

Assigned support staff: Andrés.

Autor Publicaciones
octubre 17, 2018 a las 5:24 am

rafaelF-11

Estoy tratando de: colocar el selector de idioma en el menu superior (menu principal), con las banderas en horizontal.

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: El selector de idioma en español e inglés en el menú

En vez de eso, obtuve: la página totalmente en blanco. Solo funciona el selector de idioma en la parte inferior de la página

octubre 17, 2018 a las 7:01 am #2823381

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Tu tema Conrad no se encuentra en nuestra lista de compatibilidad. Sin embargo esto no significa necesariamente que no lo sea, simplemente nuestro equipo no lo ha probado hasta el momento.
https://wpml.org/documentation/theme-compatibility/

Acabo de ingresar a tu sitio y puedo ver la pantalla en blanco. Sin embargo, como las credenciales FTP no funcionan, no pude activar la información de depuración para ver el error PHP que se produce.

Por otra parte, al utilizar un tema por defecto de WordPress, el selector funciona correctamente (captura de pantalla), lo cual indica que el problema viene de tu tema. ¿Podrías revisar si existe algún error PHP?

Sería genial si me puedes suministrar la información del debug.log de WordPress (No la confundas con la información de depuración de WPML).

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).

Un saludo,
Andrés

octubre 18, 2018 a las 5:51 am #2826667

rafaelF-11

Hola Andrés,
Gracias por la respuesta. He cambiado las lineas pero no encuentro el archivo debug.log.
Después el cambio de esas líneas la página tambien se queda en blanco.
Desde el panel de control de mi web si puedo entrar a los archivos. Te puedo envíar la forma en un privado.

Por otra parte , WPML me ha funcionado anteriormente perfectamente. Ha empezado a funcionar mal desde que renové la licencia.

octubre 18, 2018 a las 6:35 am #2826762

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

octubre 19, 2018 a las 7:07 am
octubre 19, 2018 a las 8:07 am #2830960

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Lamento que estés pasando esos inconvenientes con tu hosting. En ese caso tal vez sea mejor aislar el problema al tema y comprobar si se trata de una incompatibilidad.

Para eso, he creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tu tema y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

Saludos,
Andrés

octubre 20, 2018 a las 4:54 pm #2834395
rafaelF-11

Hola Andrés, Gracias por tu asistencia.
Ahora no solo no carga la pagina web, si no que tampoco puedo acceder a la pagina de adminnistración de WP. hidden link y hidden link están en blanco. En el panel de control de mi site intento restaurar backups de fechas anteriores del desastre pero tampoco funciona.No obstante he sido capaz de acceder mediante filezilla a la cuenta de ftp de la pagina. Al menos esto funciona.
Podría pasarte las credenciales para que pudieras acceder. ¿Cómo lo hago de forma privada?
Un Saludo

Los hilos nuevos creados por Andrés y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/dividir-problemas-con-el-language-switcher-en-menu-superior/

octubre 20, 2018 a las 5:35 pm #2834435

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Como esta situación es diferente a la inicial he abierto un nuevo ticket. Mientras tanto, no dudes en seguir las instrucciones para que evaluemos lo que sucede con tu menu:
https://wpml.org/es/forums/topic/problemas-con-el-language-switcher-en-menu-superior/#post-2830960

Saludos