Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 11 respuestas, has 2 mensajes.

Last updated by Andrés hace 3 meses, 1 semana.

Assigned support staff: Andrés.

Autor Mensajes
junio 21, 2019 a las 6:25 pm #4068889

Gustavo Naccachian

Estoy tratando de: acceder a la misma pagina traducida en diferentes subdominos con el mismo enlace pero la pagina solo se ve en el idioma base (ingles) y en los demas(ruso, chino, japones) no carga como deberia.

Yo esperaba ver:
Lo mismo que se ve en ingles.

En vez de eso, obtuve:
Paginas vacias con el template roto.

junio 24, 2019 a las 5:29 am #4074617

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

1. ¿Podrías actualizar todo tu paquete WPML a la última versión y verificar si el problema persiste?

2. Si es así, ¿me podrías indicar una manera detallada para reproducirlo?

Un saludo,
Andrés

junio 26, 2019 a las 9:01 pm #4095163

Gustavo Naccachian

¡Hola!

Hemos intentado actualizando WPML a la ultima version pero no soluciono el problema.

A continuación te detallo como reproducir el error.

1) Crea un nuevo post en ingles como idioma base y luego crea su version en otros
idiomas con sus permalink tal como ej:

* base.sitio.com/enlace1 (Ingles)
* traduccion.base.sitio.com/enlace1 (Idioma 1)
* traduction.base.sitio.com/enlace1 (Idioma 2)

En los demas idiomas que tienen la misma direccion al final del enlace deberia dar error el template de la pagina.

¡Saludos!

junio 27, 2019 a las 5:36 am #4096767

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Gracias por las instrucciones pero aún me queda una duda:
En el primer mensaje dices que cuando el slug de la página es el mismo, las traducciones no se ven. En cambio tu última respuesta pasado lo contrario, si el slug es el mismo, si muestra los contenidos. ¿Me podrías aclarar esta parte?

Por otra parte, en tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Saludos

junio 27, 2019 a las 3:04 pm #4101141

Gustavo Naccachian

Hola, aclaro...

- Cuando el slug de la pagina es el mismo en diferentes idiomas no se ve nada en el tema.
- Utilizamos el plugin https://wordpress.org/plugins/permalink-manager/ para los permalinks del sitio
- Utilizamos un tema por defecto modificado.

Pero estos no son el problema, el problema es que esta pagina nueva nos esta arrojando una respuesta 404 Not Found en la consola.

junio 27, 2019 a las 4:17 pm #4101551

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración, ahora entiendo mejor la situación. ¿Podrías compartir los resultados de la prueba anterior para poder continuar?

Saludos

junio 27, 2019 a las 8:34 pm #4102937

Gustavo Naccachian

Excelente, aun se presenta el problema.

junio 28, 2019 a las 5:10 am #4104417

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

junio 28, 2019 a las 3:48 pm #4109285

Gustavo Naccachian

Perfecto,

Podrias enviarnos por privado tu IP publica para habilitarte el acceso al sitio de pruebas?

julio 2, 2019 a las 3:09 pm #4128263

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus credenciales, pero:
1. ¿Me podrías indicar paso a paso cómo reproducir el problema?
2. ¿Podrías agregar las credenciales FTP?
3. ¿Me podrías decir por que tu sitio termina en .asp?

julio 2, 2019 a las 3:37 pm #4128481

Gustavo Naccachian

Claro, no hay problema:

1. Cuando creas una pagina en ingles y le agregas un permalink mas un template de preferencia (tt) funciona, pero... si creas las versiones en los idiomas (Ruso, chino y japones) con el mismo permalink cuando se accede a las mismas solo en esos idiomas, no funcionan y arrojan un 404.

2. No posemos un ftp configurado por los momentos.

3. Asi configuramos nuestras URLs.

julio 3, 2019 a las 6:10 am #4131945

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

He accedido a tu sitio y seguido tus pasos con una página de prueba "AAA WPML". Sin embargo, todo funciona correctamente.

Por otra parte, el hecho de que manejes tu tema y template (tt) personalizado, limita nuestra investigación ya que por normas de soporte el código personalizado no está dentro del alcance del soporte. Por esta razón, en una prueba anterior te solicitamos que desactivaras otros plugins y que utilizaras un tema por defecto.

Por ejemplo, la misma página original "AAA WPML" se muestra en blanco si no seleccionas el template tt. Si desactivas WPML la situación no cambia con lo cual, es un problema que viene desde tu tema.

Quedo atento a tus instrucciones.