Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Los métodos de envío definidos por clases de envío no aparecen en el idioma secundario.

Solution: Vuelve a salvar las zonas y métodos de envío.

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Our next available supporter will start replying to tickets in about 1.00 hours from now. Thank you for your understanding.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by ivanG-19 hace 4 años, 10 meses.

Assigned support staff: Otto.

Autor Mensajes
agosto 2, 2016 a las 3:11 pm #986671

ivanG-19

En el idioma español que es el idioma de la página aparecen las clases de envío perfectamente en el carrito de la compra tal y como lo he preparado, pero en la versión en inglés no aparecen, parece no estar funcionando. ¿a que puede ser debido?

URL of (my) website where problem appears: hidden link

Captura de pantalla 2016-08-02 a las 16.34.19.png
Captura de pantalla 2016-08-02 a las 16.34.09.png
agosto 2, 2016 a las 5:49 pm #986978

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias por contactarte con el foro de soporte!

Por favor, revisa si has traducido las clases de envio en WPML > WooCommerce Multilingual > Shipping classes (tab)

Luego de hacerlo, si el problema persiste, te sugiero que vuelvas a salvar tanto las clases de envío como algún producto y pruebes si el problema desaparece.

Si persiste, haz la siguiente prueba por favor:
-Haz un back up completo de tu sitio
-Desactiva todos los plugins no relacionados con WPML, deja también WooCommerce y WooCommerce Multilingual
-Cambia por un momento a un tema por defecto de WordPress (Twenty-Fourteen por ejemplo)
-Si el problema desaparece, activa uno por uno para comprobar con cuál es el problema de compatibilidad

Muchas gracias por tu cooperación.

Quedo a la espera de tus resultados.

Por otro lado, podrías incrementar la memoria de tu sitio, sobre todo la WP Memory Limit a 256M.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Tienes configurado 40M y el mínimo requerido es 128M.
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te remiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Un saludo cordial,

Otto

agosto 4, 2016 a las 9:14 am #989419

ivanG-19

Hola Otto:

He probado con todo lo que me comentas pero sigue sin funcionar. Cuando he probado con otro tema ha funcionado, recargo la página y deja de funcionar, vuelvo a recargar dos veces y ya no funciona, no consigo encontrar una lógica.

He conseguido ver una cosa que puede ser útil para descubrir el error. Al colocar el costo no la clase de envío si aparece la cantidad (en este caso el ejemplo 100) En español aplica el costo y la clase, pero en ingles solo aplica el costo.

Si aprieto el link que aparece en envío:

"Estos costes se pueden añadir opcionalmente en base a la clase de envío" me dice que no tengo permisos para gestionar estos elementos.

¿Que más podemos hacer?

Gracias por tu ayuda.

Captura de pantalla 2016-08-04 a las 11.08.02.png
Captura de pantalla 2016-08-04 a las 11.08.16.png
Captura de pantalla 2016-08-04 a las 11.10.45.png
Captura de pantalla 2016-08-04 a las 9.34.33.png
Captura de pantalla 2016-08-04 a las 9.35.03.png
agosto 4, 2016 a las 12:16 pm #990026

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias por la información.

Por lo que puedo ver en las capturas de pantalla que adjuntas, no tienes activados los addnos plugins: String Translation, Translation Management ni WPML Media. Esto implica que WooCommerce Multilingual, si bien está activo, no funciona.

Podrías por favor activarlos y comprobar si el problema persiste?

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

agosto 4, 2016 a las 1:47 pm #990227

ivanG-19

Hola Otto:

He activado los addons que me comentas y sigue sin funcionar. Ocurre lo mismo en español funciona pero en ingles no.

Espero tus indicaciones.

agosto 4, 2016 a las 2:52 pm #990327

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

Para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

agosto 4, 2016 a las 3:08 pm #990352

ivanG-19

Hola Otto,

¿Has recibido los datos de acceso?

agosto 4, 2016 a las 5:29 pm #990609

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Si, muchas gracias.

He salvado nuevmanete la zona y el método de envío y el problema parece solucionado. Fíjate para envios a EEUU. He agregado varios items en el carrito y en ambos idiomas aparece el mismo método y precio para el envio.

Por favor revísalo y haz lo mismo para las otras zonas y métodos por favor.

Dime si esto resuelve el problema.

Un saludo cordial,

Otto

agosto 4, 2016 a las 7:49 pm #990827

ivanG-19

Otto eres un Crack!!

Con esto si ha funcionado todo normal. He guardado de nuevo las zonas de envÍo y ahora todo vuelve a la normalidad.

Un saludo y muchas gracias por tu ayuda.