Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 0.70 hours from now. Thank you for your understanding.

This topic contains 7 respuestas, has 2 mensajes.

Last updated by Andrés hace 5 meses, 3 semanas.

Assigned support staff: Andrés.

Autor Publicaciones
abril 23, 2019 a las 6:18 am

borjaS-3

Buenos días,

El problema que tengo es que cuando marco los productos en ingles (idioma traducido) como destacados, no me aparecen como tal en la sección que tengo puesto el shortcode. Lo curioso es que aparecen algunos de los que he marcado sólo. Sin embargo con los productos en español(idioma original) aparecen todos.

He visto que en la parte de "solucionador de problemas" de wpml se me quedan varios elementos por sincronizar y no hay manera de sincronizarlos. Dejo pantallazo por si tiene que ver.

abril 23, 2019 a las 7:24 am #3660101

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

1. ¿Podrías actualizar tu paquete WPML y WooCommerce a sus últimas versiones?

2. Si después de la actualización el problema persiste, ¿me podrías decir que shortcode usas?

Un saludo,
Andrés

abril 29, 2019 a las 9:11 am #3701455

borjaS-3

Ya he actualizado y me sigue pasando. El problema es que cuando voy a marcarlos o desmarcarlos como destacados, con los productos en ingles no me hace caso.

El shortcode que uso es el de "productos desatacados" de woocommerce, concretamente:

[featured_products per_page="12" columns="4" orderby="rand" order="DESC"]

abril 29, 2019 a las 9:33 am #3701621

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

He tratado de replicar esta situación en mi sitio de prueba sin suerte. ¿Me puedes indicar paso a paso cómo reproducir esta situación?

abril 29, 2019 a las 9:43 am #3701739

borjaS-3

Lo que he hecho es activar en la página de productos el simbolo de "estrella" para marcarlos como destacados. Después he editado la página principal introduciendo el shortcode de productos destacados de woocommerce. El problema es que haciendo esto no se muestran en dicha sección. No se si te refieres a esto.

abril 29, 2019 a las 9:48 am #3701765

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Lo que quiero decir es que si voy a tu tienda en inglés, los productos que están marcados como productos destacados se muestran correctamente.
Me puedes decir:
- En qué página se ve el producto.
- Qué productos has marcado como destacado.
- Qué esperas ver.
- En su lugar qué ves.

abril 29, 2019 a las 10:00 am #3701937

borjaS-3

No me refiero a la tienda en sí. En la home es donde tengo puesto el shortcode al final antes del footer. Se deberían ver todos los productos marcados como destacado, que son 7. Si vas a la home en ingles verás como esa sección de productos destacados se ve en blanco.

abril 29, 2019 a las 10:12 am #3702015

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus indicaciones, finalmente puedo reproducir esta situación en tu sitio de prueba. Sin embargo, el problema parece ligado a tu sitio ya que todo funciona correctamente aquí:
hidden link

En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML y WooCommerce están activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.