Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 11 respuestas, has 2 mensajes.

Last updated by lauraR-14 hace 2 meses, 1 semana.

Assigned support staff: Andrés.

Autor Publicaciones
agosto 1, 2019 a las 7:39 pm #4324947

lauraR-14

Hola
De repente, al querer hacer cambios de contenido en la portada (customizing-theme options-homepage featured content) se ha cambiado el idioma. Lo tenía todo en español y se ha colocado todo en inglés.
He ido al string translations para intentar solucionarlo, y entonces todo se ha mezclado, partes están en inglés, partes en español.
No sé cómo solucionarlo, pueden ayudarme?
Gracias

agosto 2, 2019 a las 5:26 am #4326889

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Para cambiar el idioma de unas cadenas específicas:
- Ve a WPML > Traducción de cadenas.
- Selecciona las cadenas de interés.
- Da click en el nuevo botón ‘Cambia el idioma de las cadenas seleccionadas’ (Change language of selected strings).
- Selecciona el nuevo idioma de origen.

Si esto no ayuda con tu problema, ¿podrías hacer un backup completo de tu sitio y actualizar todo tu paquete WPML a su última versión?

Documentación :
https://wpml.org/es/2015/10/wpml-makes-it-easy-to-run-sites-without-english/

Un saludo,
Andrés

agosto 2, 2019 a las 10:48 am #4329143

lauraR-14

Gracias Andrés, no ha funcionado. Se lía con los idiomas. En el lugar original de edición de textos (customizing-theme options-homepage featured content) lo quiero en español, lo cambio, y al actualizar y volver a entrar, me lo vuelve a poner en inglés. Las dos páginas están en inglés ahora.
He intentado ir a buscar el CMS Beta Package (según pone en las instrucciones) para descargarlo e instalarlo, pero no lo encuentro. Sólo aparece CMS Navigation o WPML Multilingual CMS.
Cómo puedo arreglarlo?
Tampoco sé hacer un backup de mi web (la última vez que lo hice no respetó todo, cambió algunas cosas)
Gracias

agosto 2, 2019 a las 1:22 pm #4330235

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tu confirmación. ¿Me podrías confirmar que has hecho la actualización a WPML 4.2.7.1? En este momento no tenemos una versión pública de desarrollo, pero estás usando una versión muy vieja 4.0.8.

En cuanto a lo del backup, puedes utilizar un plugin como Duplicator o contactar a tu servicio de hosting para realizar una.

Espero tu confirmación para continuar.
Saludos

agosto 2, 2019 a las 8:34 pm #4332531

lauraR-14

Gracias Andres
Ya está actualizado a WPML 4.2.7.1 y hecho el backup
Gracias

agosto 5, 2019 a las 5:43 am #4338013

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tu confirmación. 🙂

Ahora que estás utilizando una versión actualizada de WPML intentémoslo de nuevo. Te sugiero que borres las cadenas que están dando problemas en WPML > String Translations (selecciónalas y al final de la tabla verás un botón para hacerlo)

Luego escanea el tema nuevamente:
- Ve a "WPML -> Localización de temas y plugins".
- Asegúrate que "Traducir temas y plugines únicamente usando la Traducción de cadenas de WPML (no cargar archivos .mo)" esté activa.
- En la misma página, en "Cadenas de tema" y selecciona “Analizar el tema para buscar cadenas".
Finalmente vuelve a traducir las cadenas.

Saludos

agosto 6, 2019 a las 12:24 pm #4347309

lauraR-14

Hola Andrés

Gracias. He hecho todo lo que me has dicho.
- He borrado todas las cadenas.
- Desde "Theme and plugins localization" he confirmado la opción "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" y desde "Strings in the themes" he marcado "Catch Kathmandu Pro" (que, por cierto, está dos veces... he marcado las dos... no sé si eso puede influir en el error) para marcar "Scan selected themes for strings"
- He ido a "customize-theme options-homepage featured content options" para poner todos los textos en español y después traducirlos a inglés desde String Translation
- He traducido todos los strings
A priori me salía todo correcto! Bien! Menos una palabra (testimonios). Lo he ido a corregir, y entonces todo se ha vuelto a cambiar: En "customize-theme options-homepage featured content options" ya no está más en español, se ha vuelto a poner todo en inglés. Y ambas páginas (español e inglés) salen en inglés. O sea, que he vuelto al principio. Una hora perdida. ¿Qué pasa? Antes funcionaba bien, y de repente todo se descompone.
Gracias por ayudar
Laura

agosto 6, 2019 a las 2:37 pm #4348573

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por comentarnos tus resultados, Laura.

Por una parte, veo que ya has tenido algunas dificultades anteriormente con la traducción de las cadenas del Customizer. Sin embargo, nuestro Equipo de compatibilidad probó tu tema recientement.

¿Podrías actualizarlo a su última versión +4.9.6? Luego de ello intenta traducir tus cadenas de nuevo.
https://wpml.org/theme/catch-kathmandu-pro/

Saludos

agosto 7, 2019 a las 10:09 am #4353441

lauraR-14

Hola Andrés
No puedo actualizar el tema si no pago 49,90 dólares
No entiendo por qué, de repente, ha dejado de funcionar todo, cuando hasta ahora funcionaba bien.... los problemas que iba teniendo era que cada vez que actualizaba la información de la home page me tocaba actualizar a mano todas las cadenas, me llevaba un tiempo pero lo conseguía, no se me quedaba todo en inglés como ahora...
¿Qué más puedo hacer?

agosto 7, 2019 a las 12:50 pm #4355227

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Entiendo tu situación, sin embargo como el tema solo fue revisado a partir de esa versión, muy probablemente el problema que atraviesas ya ha sido solucionado.

En este momento puedo acceder a tu sitio y revisar si encuentro algo, pero es muy probable que esté limitado y deba solicitarte que actualices.

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

agosto 8, 2019 a las 11:21 am #4362203

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus credenciales. He hecho varias pruebas pero el problema persiste, por ejemplo, he agregado esto en el archivo wpml-config.xml:

<key name="homepage_headline" />

Y aunque la cadena se muestr en inglés en el customizer, su traducción se ve correctamente. En ese caso necesitamos que actualices tu tema para poder continuar.

Otra posibilidad que puedes intentar es agregar las cadenas en inglés y traducirlas al español.

Saludos

agosto 8, 2019 a las 6:35 pm #4365409

lauraR-14

Gracias, ya está resuelto. Finalmente lo he tenido que poner todo en inglés para después traducirlo al español