Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 14 respuestas, has 3 mensajes.

Last updated by carolinaF-6 hace 1 semana, 3 días.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
septiembre 29, 2019 a las 9:49 am

carolinaF-6

Estoy tratando de: instalar los plugins de WPML. Y me los he instalado según vuestra guía.

URL de (mi) sitio web donde aparece el problema: pero entonces voy a mi web, y me da error, no aparece.

Yo esperaba ver: mi web con la pestañita para seleccionar idioma y luego empezar a hacer que traduzca todo (me hubiera mirado los pasos a seguir)

En vez de eso, obtuve: que la web desaparece. Y si desinstalo el WPML vuelve a aparecer.

septiembre 30, 2019 a las 5:31 am #4662375

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

Muchas gracias por tus credenciales, en efecto, puedo ver esta situación. Sin embargo, no has agregado las de tu FTP y no me gustaría revisar si existe algún error PHP.

Sería genial si me puedes suministrar la información del debug.log de WordPress (No la confundas con la información de depuración de WPML).

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).
https://wpml.org/documentation/support/debugging-wpml/

Un saludo,
Andrés

septiembre 30, 2019 a las 10:42 am #4663781

carolinaF-6

Hola Andrés,

Primero que todo muchas gracias por la rapidez.

Y en segundo lugar, decirte que no soy muy buena con la tencología y es la primera vez que me estoy haciendo una web... y no me aclaro mucho. Por lo que, tras un buen rato buscando en Word Press lo que me solicitas, he decidido escribirte para decirte que no lo encuentro...

Podrías indicarme con más detalle donde puedo abrir eso de wp-config.php?

Muchas gracias de nuevo!

septiembre 30, 2019 a las 11:42 am #4664221

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Te entiendo perfectamente. 🙂

el archivo wp-config.php se encuentra en la raíz de tu directorio WordPress. Es allí donde declaras el nombre de tu base de datos y otros detalles importantes. Tal vez el siguiente artículo sea de ayuda:
hidden link

No dudes en contactar a tu servicio de hosting, ellos deberían proveerte de credenciales FTP. De esta manera, podrás encontrar fácil y rápidamente dicho archivo. Por otra parte, también pueden darte indicios de los errores que pueden estar apareciendo ya que deberían tener acceso al error.log.

Saludos

octubre 1, 2019 a las 4:35 pm #4674017

carolinaF-6

Hola de nuevo Andrés,

A ver... vas a pensar que soy una torpe, pero me está costando mucho llegar donde me dices... y mira que me esfuerzo...

He comentado lo que me ocurre con el profe de Gestión y Marketing (yo soy terapeuta, y he hecho este curso para saber cómo gestionar clientes y saber de marketing para lanzar publi y crearme una web y etc, pero ni idea de tecnología ni de programación) -donde me han iniciado con la creación de la web y entre varios plugins me comentaron este para el tema traducción- y me ha sugerido que te comentara si yo te doy acceso a Word Press y a FTP, podrías ya verlo y gestionarlo tú directamente? Sería posible?

Cuando puedas me dices, y así seguimos según veas.

Gracias.

Saludos,

octubre 2, 2019 a las 6:10 am #4677251

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Mi nombre es Carlos y voy a continuar con este ticket pues mi colega Andrés está de vacaciones hoy.

He revisado el sitio y la causa del problema estaba en que el idioma Español estaba oculto. He activado la opción para que su usuario pueda ver los idiomas ocultos y ya el sitio funciona correctamente.

Puede confirmar que el problema desapareció?

Saludos cordiales,
Carlos

octubre 2, 2019 a las 7:51 am #4677571

carolinaF-6

Buenos días Carlos,

No, el problema no desapareció...

El problema es que, con el plugin WPML instalado, cuando voy a google para ver mi web, esta no se encuentra, da error. Y, si desinstalo el plugin, la web aparece de nuevo. Por lo que debe haber algún error interno que desconozco, y de ahí mi consulta.

Si has leído la conversación, verás lo que él me indicaba de hacer que yo no soy capaz por desconocimiento, y le planteaba que entrara él y lo revisara. Sería eso posible?

Me mantengo a la espera de tus noticias.

Gracias.

Saludos,

octubre 2, 2019 a las 9:36 am #4678589

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Si, he leído la conversación y active el modo de depuración en el sitio, sin embargo hay solo un mensaje de advertencia que al parecer no está relacionado con el problema.

De todas formas, para comprender mejor el problema, me gustaría pedirle que explique que quiere decir con: "cuando voy a google para ver mi web, esta no se encuentra, da error". Puede añadir algunas capturas de pantalla donde se muestre el error?

Nota: Recuerde que el idioma Español está oculto en el sitio, por lo que será imposible verlo desde el modo incógnito o sin autenticarse en el sitio.

Saludos cordiales,
Carlos

octubre 2, 2019 a las 11:48 am #4679883

carolinaF-6

Hola de nuevo,

Te adjunto la imagen que me sale cada vez que voy a google a ver la web.

La cosa es la que te comento: empecé con la creación de la web en junio y siempre he ido instalando plugins y he ido cambiando cosas mediante Word Pres y luego iba a google a buscar la web para mirar cómo iban quedando dichos cambios. Pero, la semana pasada me instalé el vuestro y, tras haberlo instalado, fui a comprobar cómo quedaba y mi sorpresa fue que la web no me aparece y me sale lo que te adjunto en la foto. Probé de desinstalármelo, y la web apareció de nuevo. Los volvía a instalar, y de nuevo desaparece...

Espero tus noticias.

Gracias!

octubre 2, 2019 a las 3:09 pm #4681775

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Me puedes decir si ahora aparece?

Saludos,
Carlos

octubre 3, 2019 a las 9:31 am #4686373

carolinaF-6

Buenos días,

Disculpa, estos días he tenido mucho trabajo y horarios complicados y no he podido contestarte antes.

Sí! Ahora aparece la web!!!! Gracias!

Lo que, pregunto:
Lo que no me sale es el menú para escoger el idioma todavía.
Por lo que; ahora que lo tengo instalado, cuál sería el siguiente paso?

Y otra cuestión:
Mi web, lo poco que está hecho de momento, está escrito en castellano. Yo lo quiero traducir todo al catalán. PERO, quiero que el idioma principal sea el catalán, que sea la primera opción y si luego alguien cambia al castellano que le sea la opción. Por lo que; en idioma predeterminado tendré que poner catalán? Y de ser así, entonces cómo se traduce si todo está en castellano? O lo voy traduciendo yo?

Gracias de antemano.

Esta tarde mi intención es ponerme con ello.

Gracias.

octubre 3, 2019 a las 12:30 pm #4687617

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Me alegra saber que el problema está resuelto 🙂

Para responder a sus otras preguntas lo mejor es leer nuestra Guía de Inicio: https://wpml.org/es/documentation-2/guia-de-inicio/ donde encontrará los pasos a seguir para traducir el contenido, cambiar el idioma por defecto del sitio y agregar el selector de idiomas al menú.

Saludos cordiales,
Carlos

octubre 3, 2019 a las 4:24 pm #4689803

carolinaF-6

Aha, vale, pues perfecto!!

Allí voy! A ver qué tal se me da.

Muchas gracias por todo!!

Saludos,

octubre 4, 2019 a las 10:22 am #4694759

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Ha sido un placer poder ayudarle.
Por favor no dude en contactarnos si necesita de nuestra ayuda en el futuro con WPML.

Saludos,
Carlos

octubre 7, 2019 a las 5:46 pm #4709769

carolinaF-6

My issue is resolved now. Thank you!