Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 4.29 hours from now. Thank you for your understanding.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by Andrés hace 1 año.

Assigned support staff: Andrés.

Autor Publicaciones
octubre 12, 2018 a las 3:33 pm

fernandoS-21

Estoy tratando de: traducir cadenas del thema y plugins pero no funciona

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: todo en español

En vez de eso, obtuve: cadenas en ingles y el plugin no me reconoce el thema y los plugin para poder traducir

octubre 15, 2018 a las 9:25 am #2816766

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

He intentado acceder a tu sitio, sin embargo las credenciales no son válidas. En ese caso, por favor sigue estas instrucciones:
- Haz un backup completo de tu sitio.
- Agrega el siguiente código en el functions.php de tu tema:

function wpmlsupp_1891_fix_missing_icl_tables() {
    if( function_exists( 'icl_sitepress_activate' ) )
        icl_sitepress_activate();
}
add_action( 'wp_footer', 'wpmlsupp_1891_fix_missing_icl_tables' );

- Visita el front-end una o dos veces hasta que el mensaje de error de la base de datos desaparezca.

¿Soluciona tu problema?

Un saludo,
Andrés

octubre 16, 2018 a las 5:28 pm #2821978

fernandoS-21

Agregue al función que me dijiste a functions.php de mi tema y no se resolvió el problema.

octubre 17, 2018 a las 6:18 am #2823196

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

octubre 17, 2018 a las 12:49 pm
octubre 17, 2018 a las 1:48 pm #2824774

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus credenciales, he podido acceder a tu sitio y veo la situación. Sin embargo, cuando activo la información de depuración tampoco veo ningún error relacionado con la base de datos.
Instalé además la extensión ARI Adminer y tu base de datos luce correcta.

He hecho entonces una copia de tu sitio para ver el comportamiento local y es el mismo, aunque sigo sin ver ningún error en tu base de datos.

Por otro lado, ¿acaso acabas de instalar tu WPML y aún no comienzas a traducir tu sitio? Si es así y ya que aún no comienzas tu traducción, ¿podrías contemplar la posibilidad de reiniciar tu WPML?
En el caso contrario, sigo con el proceso de depuración.

Espero tus comentarios.
Saludos

octubre 17, 2018 a las 1:58 pm #2824791

fernandoS-21

Si, reinicia el WPML, no hay problema. Gracias

octubre 17, 2018 a las 2:05 pm #2824812

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Perfecto, he hecho lo siguiente:
- WPML > Soporte.
- Solución de problemas.
- Reiniciar.
x Estoy a punto de restablecer todos los datos de traducción e idioma.
x Restablecer y desactivar WPML

El problema parece haber desaparecido, solo te resta registrar tu WPML.
¿Podrías verificarlo?

octubre 17, 2018 a las 2:11 pm #2824833

fernandoS-21

Perfecto!!!! muchas gracias!!!!

octubre 17, 2018 a las 2:13 pm #2824886

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Super! 🙂
No dudes en cerrar el ticket y abrir uno nuevo si necesitas más ayuda.
Saludos