Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 12 respuestas, has 2 mensajes.

Last updated by jordiM-21 hace 2 semanas, 6 días.

Assigned support staff: Andrés.

Autor Mensajes
septiembre 25, 2019 a las 11:40 am #4638347

jordiM-21

tenemos la web lightpaintingparadise.com que la tienda no carga idiomas.

el plugin CMS navegacion no deja activarlo.. es el error que nos da en el panel de WP, que falta acitvarlo, pero nos resulta imposible.

esta todo actualizado a última versión, pero como indico no puedo activarlo desde el panel de plugins.

septiembre 25, 2019 a las 1:27 pm #4639113

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

No estoy seguro de entender tu problema, ¿quieres decir que estás instalando WPML por primera vez y no puedes activarlo?

¿Podrías revisar si existe algún error PHP?

Sería genial si me puedes suministrar la información del debug.log de WordPress (No la confundas con la información de depuración de WPML).

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).
https://wpml.org/documentation/support/debugging-wpml/

Un saludo,
Andrés

septiembre 25, 2019 a las 1:43 pm #4639357

jordiM-21

hola.
tengo la web de hace 2 años ya con el plugin aproximadamente y actualmente, no sabemos porque, si es actualizaciones o a que es debido, desaparece el WPML del escritorio de WP y en plugins está pero al dar activar, no hace nada, es imposible activarlo y por lo tanto no puedo darte la información que os enviamos cuando hay algun problema desde vuestra area del plugin.

he realizado el cambio que indica en el config y subido al hidden link. pero no veo en ningun sitio el log dentro de cotent

si envien el privado, no es problema darles los dato de ftp y wp-admin

septiembre 25, 2019 a las 1:51 pm #4639441

jordiM-21

he visto ficheros log fuera de este wp-content... si quiere intento enviar este, pero no se como funciona pastebin... intento informarme de como se lo puedo enviar.

septiembre 25, 2019 a las 1:53 pm #4639479

jordiM-21

no me deja pastebin, porque indica que pesa mas de lo soportado para no ser PRO.

si quieren les paso los accesos, creo que será más rápido.

septiembre 25, 2019 a las 1:55 pm #4639563

jordiM-21

ahora si hay un debug.log donde me indican ustedes, pero pesa mas de lo que puedo enviar por pastebin.

septiembre 25, 2019 a las 2:22 pm #4639877

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Si el archivo es muy pesado, debe ser por que tiene información muy antigua. Por favor, agrega solo la correspondiente al día de hoy o relacionadas a un Fatal error,
la otra no es necesaria.

Saludos

septiembre 25, 2019 a las 5:51 pm #4641583

jordiM-21

Hola de nuevo...
siento molestar, pero ni idea de como hacer esto.. en todos los inicios me da que es fecha dia de hoy y se hace un texto muy largo. Y no veo ningun FATAL ERROR... pero en cada conjunto de texto al final aparece un error tabla,... cada párrafo tiene un error con código distinto.

Puedo enviar si quieren por e-mail el log o algun fichero adjunto si les puede servir

septiembre 26, 2019 a las 5:36 am #4643569

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

septiembre 26, 2019 a las 9:17 am #4645039

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus credenciales, he podido acceder y resolver el problema. Lo extraño del caso es que no está relacionado con WPML pero si nos afecta. Me explico:

El error que aparece cuando activas WPML es el siguiente:

[26-Sep-2019 09:02:14 UTC] Error Table 'xxx.xxx_wp_wc_tax_rate_classes' doesn't exist de la base de datos de WordPress para la consulta 
				SELECT * FROM xxx_wp_wc_tax_rate_classes ORDER BY name;
				 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/bridge/woocommerce.php'), get_header, locate_template, load_template, require_once('/themes/bridge/header.php'), wp_head, do_action('wp_head'), WP_Hook->do_action, WP_Hook->apply_filters, wp_enqueue_scripts, do_action('wp_enqueue_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, bridge_qode_google_fonts_styles, wp_reset_postdata, WP_Query->reset_postdata, WP_Query->setup_postdata, do_action_ref_array('the_post'), WP_Hook->do_action, WP_Hook->apply_filters, wc_setup_product_data, wc_get_product, WC_Product_Factory->get_product, WC_Product_Simple->__construct, WC_Product->__construct, WC_Data_Store->read, WC_Product_Data_Store_CPT->read, WC_Product_Data_Store_CPT->read_product_data, WC_Data->set_props, WC_Product->set_tax_class, WC_Product->get_valid_tax_classes, WC_Tax::get_tax_class_slugs, WC_Tax::get_tax_rate_classes

Este error indica que no existe la tabla _wp_wc_tax_rate_classes de WooCommerce. Sin embargo, cuando vas a activar nuestro plugin, este hace un chequeo, y al ver el error no lo permite activar. Para solucionarlo he desactivado temporalmente WooCommerce y luego reactivé todo tu WPML. Luego de ello reactivé WooCommerce y todo funcionó correctamente.

Ahora bien, te recomiendo que contactes con el soporte de WooCommerce y crees la tabla que te falte para evitar futuros problemas.

Saludos

septiembre 26, 2019 a las 9:21 am #4645047

jordiM-21

Pues le estoy increiblemente agradecido ya que este error nos supera debido a que no tenemos ni idea de esto..

han sido muy amables por su parte al ayduarnos.

un saludo y vamos a contactar con woocommerce para ver que nos indican.

muchas gracias de nuevo.

septiembre 26, 2019 a las 9:30 am #4645091

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Perfecto! 🙂
No dudes en cerrar este ticket y abrir uno nuevo si necesitas ayuda de nuevo.
Saludos

septiembre 26, 2019 a las 9:33 am #4645201

jordiM-21

My issue is resolved now. Thank you!