Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 12 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 2 meses.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
septiembre 16, 2019 a las 11:48 am #4579879

ireneC-6

Estoy tratando de traducir la página web del catalán al español, he traducido el menú y las páginas. Después he pasado a traducir las cadenas.
Ahora mi web aparece con los menús en catalán, los encabezados de las secciones en castellano, algún contenido de las secciones en castellano y otros en catalán... parece que todas las cadenas de traducción que he cambiado se han quedado en español y el resto en catalán. ¿A que se puede deber? Muchas gracias

septiembre 16, 2019 a las 3:14 pm #4581905

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

1.- Por favor adjunte algunas capturas de pantalla donde se aparezcan las cadenas sin traducir, de esta manera podré comprender mejor el problema.

2.- Me gustaría solicitar acceso temporal al sitio (wp-admin y FTP) con el objetivo de ver el problema más de cerca. Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Aunque no realizaré ningún cambio en el sitio siempre es recomendable crear una copia de seguridad del sitio completo antes de compartir las credenciales de acceso.

Saludos cordiales,
Carlos

septiembre 17, 2019 a las 10:28 am #4587679

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Irene,
Muchas gracias por la información suministrada.

He intentado acceder al sitio pero me aparece un cartel diciendo que está bajo mantenimiento.

Saludos,
Carlos

septiembre 17, 2019 a las 10:30 am #4587687

ireneC-6

Hola Carlos,
Perdona, ya está desactivado el modo mantenimiento. Gracias

septiembre 17, 2019 a las 12:16 pm #4588385

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su mensaje.

He aplicado varios pasos de troubleshooting pero el problema persiste. Me gustaría pedirle que a modo de prueba cree una página de inicio nueva y la traduzca.

Me puede decir si el problema persiste en esta página de inicio nueva?

Saludos,
Carlos

septiembre 17, 2019 a las 1:28 pm #4588821

ireneC-6

Hola Carlos, cuando dices crear una página de inicio nueva a qué te refieres? soy novata en este tema.

septiembre 17, 2019 a las 4:06 pm #4589999

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Irene,

Me refiero a ir a Páginas -> Añadir nueva -> En la columna derecha, dentro de la sección 'Atributos de página' seleccionar la plantilla 'Portada' -> Guardar los cambios -> Traducir la página.

El problema persiste en ésta nueva página?

Saludos,
Carlos

septiembre 17, 2019 a las 7:45 pm #4590833

ireneC-6

Hola Carlos, gracias por tu ayuda, he creado la página de inicio nueva pero el problema persiste.

septiembre 18, 2019 a las 10:41 am #4595211

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Irene,
Gracias por su mensaje.

He tenido que borrar una a una las cadenas en String Translation y he vuelto a traducirlas. Le pido que revise si queda alguna cadena sin traducir y realice los siguientes pasos:
- Busca la cadena en WPML -> String Translation -> Borra la cadena si pertenece al dominio 'admin_texts_theme_mods_onepress' -> Refresca la búsqueda y volverá a aparecer porque WPML la vuelve a escanear -> Traduce la cadena -> Guarda los cambios.

Puede confirmar que el problema está resuelto?

Saludos cordiales,
Carlos

septiembre 18, 2019 a las 11:19 am #4595547

ireneC-6

Hola Carlos! Eres un crack! Gracias! He borrado las que faltaban y las he vuelto a traducir y se ha solucionado el problema. Qué bien! Muchísimas gracias!!! 🙂
Una última cosa, cuando le doy al botón "bucle magnético" adjunto captura, cambia al idioma catalán no al español, y no sé porqué...

septiembre 18, 2019 a las 12:03 pm #4596155

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Irene,

He traducido el enlace del botón en WPML -> String Translation.

Puede confirmar que el problema está resuelto?
Saludos,
Carlos

septiembre 18, 2019 a las 12:49 pm #4596845

ireneC-6

My issue is resolved now. Thank you!

septiembre 18, 2019 a las 2:24 pm #4597539

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola Irene,
Me alegra saber que el problema está resuelto 🙂

Por favor no dude en contactarnos si necesita de nuestra ayuda en el futuro con WPML.
Saludos cordiales,
Carlos