Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Etiquetado: 

This topic contains 6 respuestas, has 2 mensajes.

Last updated by ramonJ-2 hace 3 meses, 1 semana.

Assigned support staff: Andreas W..

Autor Mensajes
agosto 19, 2021 a las 3:13 pm #9426453

ramonJ-2

Hola!

Tengo un site en 3 idiomas funcionando con generatepress y elementor y hay algunos enlaces que no me funcionan correctamente. En concreto son los que tienen asociados anclas con ID y si estoy en un idioma secundario en cualquier página que no sea la home, y pulso un enlace con ancla me dirige al ancla del idioma principal. Si por ejemplo, voy al inglés y entro en ABOUT US y desde allí le doy a SERVICES, en lugar de ir al ancla de SERVICES me va al ancla de SERVICIOS

agosto 20, 2021 a las 4:34 am #9429407

Andreas W.
Supporter

Languages: Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Vayas a WPML -> Idiomas y configure el "formato de URL del sitio" en "Idioma en directorios".

Después de eso, vayas a "Configuración -> Enlaces permanentes" y haga clic en "Guardar".

Esto debería resolver el problema. Si no es así, por favor avisame nuevamente.

Saludos cordiales
Andreas

agosto 20, 2021 a las 6:27 am #9429589

ramonJ-2

Gracias Andreas!

He seguido las instrucciones pero sigue igual. Te envío imagen de como lo tengo ya que en el primer paso donde dices de configurar "Idioma en directorios", hay más de una opción.

En el segundo paso, sólo tengo que ir a enlaces permanentes y guardar, o hay alguna configuración que tengo que hacer?

Gracias!

Captura de Pantalla 2021-08-20 a les 8.24.13.png
agosto 20, 2021 a las 10:15 pm #9432785

Andreas W.
Supporter

Languages: Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Ahora, parece que los enlaces simplemente no están traducidos correctamente.

Cuando en:
hidden link

Inspección del elemento del menú "SERVICIOS"
el enlace va a:
hidden link

mientras que debería traducirse a:

hidden link

Ahora, para eso, necesitaría traducir la ID, ya que la URL que funciona actualmente sería:

hidden link

En caso de que no pueda ajustar esas traducciones dentro del Editor de traducción de WPML al traducir la página, te sugiero que edite los ID en cada página manualmente.

Para los enlaces de menú, edítelos dentro de Apariencia -> Menús.

Si necesita ayuda con eso, por favor bríndeme acceso de administrador al sitio. El formulario de respuesta privada está habilitado.

Saludos cordiales
Andreas

agosto 24, 2021 a las 4:05 am #9446701

ramonJ-2

Hola!

Hace 24 horas te facilité el acceso WordPress para ayudarme con las traducciones y no he recibido ninguna respuesta.

Me podrías informar cómo va el tema?

Gracias!

agosto 24, 2021 a las 7:09 pm #9453109

Andreas W.
Supporter

Languages: Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Mis disculpas por el retraso, pero como trabajo de martes a sábado no estoy disponible los domingos y lunes.
https://wpml.org/es/forums/users/andreas-w/

Para solucionar el problema actual, simplemente edité los menús en cada idioma.

De forma predeterminada, todas las páginas utilizan los mismos ID para cada sección, lo que parece no ser traducible con el Editor de traducción de WPML.

Puedes intentar cambiar los ID en Elementor en la página de inicio en catalán e inglés, pero le recomendaría que haga una copia de seguridad primero, ya que no se recomiendan las ediciones manuales en las traducciones cuando se trabaja con el editor de traducción WPML y pueden provocar la pérdida del contenido editado. al traducir la página de nuevo.

Saludos cordiales
Andreas

agosto 25, 2021 a las 3:50 am #9454529

ramonJ-2

My issue is resolved now. Thank you!