Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Tab is not showing

Solution: The Tab attribute wasn´t showing because there wasn´t any attribute description for the term.

Relevant Documentation:

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by danielE-46 hace 1 año, 3 meses.

Assigned support staff: Paola Mendiburu.

Autor Mensajes
mayo 28, 2020 a las 3:49 pm #6241223

danielE-46

Hola haber cuando uno accede a un producto por ejemplo hidden link hay 4 tabs que son:
1 Detalles
2 Criterios (0)
3 Acerca de la marca
4 Envío y Entrega
pero cuando traduzco mi producto me muestra solo la 1, 2, 4 entonces cuando voy a la edición de la parte de marca me sale un candado les adjunto foto, entonces ese atributi se llama brand en mi sitio y ya le tengo dado los permisos para traducirlo en el wpml y aun asi cuando cambias de idioma no se muestra ese tabs
Por favor ayudneme con este problema, Gracias

Screenshot_2020-05-28 X-BORE2.png
Screenshot_2020-05-28 Configuración Vertimaq-Máquinas CNC verticales y Software de carpintería — WordPress.png
candado.png
junio 1, 2020 a las 10:26 am #6264619

Paola Mendiburu
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hola!

Muchas gracias por contactar al equipo de soporte de WPML.

Antes de nada, pruebe a actualizar WPML, WPML String Translation, WPML Translation Management y WooCommerce Multilingual a su última versión https://wpml.org/account/downloads/

Si el problema permanece después de la actualización pruebe lo siguiente:
(Recuerda hacer siempre un backup antes de proceder):
Ve a WPML → Soporte → Solución de problemas y en la sección de Limpiar haz click en lo siguiente:
- Borrar caché en WPML
- Quitar las entradas fantasma de las tablas de traducción
- Reparar la intercalación de element_type
- Determinar información de idioma
- Reparar asignaciones de tipo de entrada para las traducciones

Ya me dices si el problema persiste.

Un saludo,

Paola

junio 2, 2020 a las 1:32 pm #6274629

danielE-46

Hola, pues he hecho todos los cambios que me dijo y sigo teniendo el mismo problema

junio 2, 2020 a las 2:24 pm #6275189

Paola Mendiburu
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hola,

Muchas gracias por la colaboración.

Para investigar el problema, ¿puede darme acceso a su sitio, por favor?

Acabo de marcar las casillas necesarias para que pueda agregar las credenciales de forma segura y privada.

De esa forma solo nosotros dos podemos observarlos.

Le sugiero que cree un usuario temporal, para que pueda eliminarlo después de cerrar el ticket.

Saludos cordiales,

Paola

junio 3, 2020 a las 3:04 pm #6285137

Paola Mendiburu
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hola!

Parece que es un problema de compatibilidad con el plugin/tema que añade ese tab.

¿Podría instalar el tema/plugin en el siguiente sitio de prueba para ver si podemos recrear el problema aquí para que nuestro equipo de compatibilidad investigue más?

También podría intentar recrear la página donde encuentra el problema.

Acceso al sitio de prueba:
hidden link

Nombre de usuario: hello@wpml.org
Contraseña: F8RpKSFe8e

Déjame una breve notificación una vez que el sitio esté listo. También sería útil si pudieras intentar recrear los problemas y / o proporcionar algunos pasos detallados.

Saludos,

Paola

junio 3, 2020 a las 4:07 pm #6285549

danielE-46

Hola cuando quiero instalar el tema me da error en el sitio que me propusieron les explico un poco el asunto la tabs que falta es la que dice acerca de la marca en mi sitio eso hace referencia a un html_block les envio foto, tuve ese mismo problema con el footer que era un html_block igual que no se me traducia entonces uno de ustedes del soporte incrusto codigo en el xml del wmpl y asi pude traducir dicho html_block quizas por esa via logren solucionar el problema.
Me dicen si esto les ha servido de ayuda, y revien en mis ticket uno que dice traduccion html_block que asi fue como lo resolvieron

Screenshot_2020-06-03 Traducción de cadenas Vertimaq-Máquinas CNC verticales y Software de carpintería — WordPress.png
Screenshot_2020-06-03 Edición De Elementos Vertimaq-Máquinas CNC verticales y Software de carpintería — WordPress.png
Screenshot_2020-06-03 Los Bloques HTML Vertimaq-Máquinas CNC verticales y Software de carpintería — WordPress.png
junio 4, 2020 a las 9:50 am #6291957

Paola Mendiburu
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Muchas gracias por la información.

Voy a mirar el ticket de mi compañero.

Le aviso en cuanto tenga noticias.

Un saludo,

Paola

junio 4, 2020 a las 2:19 pm #6295219

Paola Mendiburu
Supporter

Languages: Inglés (English ) Español (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hola,

Me he dado cuenta de si vamos al no has añadido el shortcode del html block a la descripción del atributo.

Para hacer esto tienes que ir a Productos --> Atributos y en brand --> Configurar términos si vas a Vertimaq verás que no tiene nada en la traducción para la descripción, ahí tienes que añadir el shortcode del html block en inglés. (Lo he añadido yo para comprobar que funcionar)
hidden link

Ya me dices si tienes cualquier problema.

Un saludo,

Paola

junio 5, 2020 a las 2:39 pm #6306607

danielE-46

My issue is resolved now. Thank you!