Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Cuando trato de traducir el grupo de campos con sus campos correspondientes (idioma principal español y traducciones en ruso), me encuentro con que el interfaz de edición está parte en español y parte en ruso. Adjunto una captura de pantalla.

¿Cómo se hace para que esté el interfaz en el mismo idioma (español) manteniendo los contenidos de los campos traducidos?

Yo quiero traducir el contenido de los campos al ruso, pero NO quiero que el interfaz me aparezca en ruso porque no sé lo que pone. ¿Es posible?

Solution: Con respecto al problema de tener la interfaz en dos idiomas al mismo tiempo, es posible que la causa sea la falta de traducción de esta interfaz (que debe poder traducirse en WPML -> String Translation) o la falta de memoria. Su sitio tiene solo 40Mb de memoria y el mínimo requerido es de 128Mb: https://wpml.org/home/minimum-requirements/

Para incrementar el límite de memoria puede agregar el siguiente código al archivo wp-config.php:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Añádalo encima de la línea /* That's all, stop editing! Happy blogging. */

Relevant Documentation:

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

This topic contains 3 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 1 año, 5 meses.

Assigned support staff: Carlos Rojas.

Autor Mensajes
marzo 6, 2019 a las 12:08 pm #3278742

Aitor Méndez

Hola, estoy tratando de traducir los campos ACF asociados con la página "contacto" para que se vean en la traducción al ruso "контакт".

Hay varios problemas. Siguiendo las instrucciones: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

PROBLEMA 1) No encuentro la opción que indica al principio: "WPML Advanced Translation Editor" en configuración de WPML no aparece.

PROBLEMA 2) No encuentro la opción "custom field translation" en configuración. No aparece (ver captura adjunta de las indicaciones a las que me refiero aquí).

PROBLEMA 3) Cuando trato de traducir el grupo de campos con sus campos correspondientes (idioma principal español y traducciones en ruso), me encuentro con que el interfaz de edición está parte en español y parte en ruso. Adjunto una captura de pantalla.

¿Cómo se hace para que esté el interfaz en el mismo idioma (español) manteniendo los contenidos de los campos traducidos?

Yo quiero traducir el contenido de los campos al ruso, pero NO quiero que el interfaz me aparezca en ruso porque no sé lo que pone. ¿Es posible? (ver captura de pantalla adjunta).

PROBLEMA 4) Vincular un grupo de campos con una página y su traducción.

Lo ideal para mí sería que hubiera una forma de vincular el grupo de campos en el idioma principal (español) con ambas páginas (Contacto y контакт) pero sólo aparece la posibilidad de vincular el grupo de campos con una sola traducción de la página.

Es decir, sólo se puede vincular el grupo de campos en español con "Contacto" y el grupo de campos traducido al ruso con "контакт".

¿Es posible vincular un grupo de campos en español con una página y su traducción al ruso?

Muchas gracias.

Puedo proporcionar el acceso al editor de WP en línea.

marzo 7, 2019 a las 3:29 pm #3285337

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML. Haré todo lo posible por ayudarle a resolver este problema.

Por favor tenga en cuenta que las políticas del foro indican que se debe tener sólo un problema por ticket. Esto le brindará un mejor servicio de soporte y al mismo tiempo ayudará a futuros clientes a encontrar soluciones a problemas similares en el futuro.

1.- Para encontrar la opción de Advance Translation Editor (ATE) debe ir a WPML -> Settings -> How to translate page and posts.

2.- De acuerdo con su captura de pantalla, la opción Custom Field Translation se muestra correctamente. Es posible que necesite hacer click en el enlace 'Show system fields' para ver los campos que desea traducir.

3.- Con respecto al problema de tener la interfaz en dos idiomas al mismo tiempo, es posible que la causa sea la falta de traducción de esta interfaz (que debe poder traducirse en WPML -> String Translation) o la falta de memoria. Su sitio tiene solo 40Mb de memoria y el mínimo requerido es de 128Mb: https://wpml.org/home/minimum-requirements/

Para incrementar el límite de memoria puede agregar el siguiente código al archivo wp-config.php:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Añádalo encima de la línea /* That's all, stop editing! Happy blogging. */

4.- El comportamiento descrito es correcto y se ajusta al comportamiento esperado en este caso. Si desea crear un 'featured request' acerca de este comportamiento puede hacerlo creando un nuevo ticket de tipo 'featured request' en el foro y describiendo su propuesta/pedido.

Por favor hágame saber si necesita más asistencia de mi parte y estaré más que contento de seguir ayudándole.
Saludos cordiales,
Carlos

marzo 7, 2019 a las 8:14 pm #3286778

Aitor Méndez

Carlos, gracias por su ayuda. Ampliar el límite de memoria ha solucionado el problema de la mitad del interfaz en cada idioma. No obstante, el resto de problemas persiste.

Como parece que el asunto se complica y siguiendo su sugerencia, abriré un hilo para cada uno de elos.

marzo 7, 2019 a las 9:09 pm #3287020

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Me alegra saber que el problema de la interfaz está resuelto.

Si desea puede añadirme como especialista de soporte a los próximos hilos que abra y estaré más que contento de seguir ayudándole.
Saludos,
Carlos