Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This thread is resolved. Here is a description of the problem and solution.

Problem: Need to translate the portfolio slug: "proyectos"

Solution: - Go to WPML> Settings> Post Type Translation - On "Portfolio Items (portfolio)" click on "Set different slugs in different languages for Portfolio Items." - Set it as "projectes" in Catalan and save - Go to Settings > Permalinks, Set it as "Simple" and save - Set it with your permalink structure again and save

This topic contains 15 respuestas, has 2 mensajes.

Last updated by mariaC-6 hace 1 año.

Assigned support staff: Diego Pereira.

Autor Publicaciones
octubre 3, 2018 a las 10:21 pm #2785826

mariaC-6

Hola!

Necesito traducir el slug común para todos los elementos del portfolios, que en este caso es "proyectos" y tengo que traducirlo al catalán "projectes". Este slug se añade en las opciones del tema (adjunto capturas de pantalla).

Gracias de antemano,

María.

octubre 5, 2018 a las 1:31 pm #2790922

mariaC-6

Hola!

Aún no he recibido respuesta alguna a este hilo de soporte, alguien que me ayude con esto por favor?

Gracias,

María.

octubre 5, 2018 a las 3:54 pm #2791240

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola @mariac-6, ¡Bienvenido al foro de soporte de WPML!

Disculpa por la demora. Estamos con un gran volumen de solicitudes de soporte en este momento. Esto no es habitual en nuestro foro.

Por favor, consulte esta guía sobre cómo traducir slugs de taxonomías: https://wpml.org/faq/translate-taxonomy-slugs-wpml/

Por favor, hágamelo saber si funcionó.

Saludos,
Diego

octubre 6, 2018 a las 3:53 am #2792405

mariaC-6

Lo siento, no he podido encontrar la traducción de esa url en taxonomías. Por favor, cuando podáis me podéis echar una mano? Mil gracias 🙂

octubre 8, 2018 a las 1:28 pm #2796116

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Por favor, envíenos el acceso a su panel de WordPress (URL, login y contraseña). Voy a comprobar y hacer algunas pruebas. - Utilice el campo privado para enviar los datos confidenciales. No publique si no los ve.

Sería mejor si me diera un sitio de prueba en lugar del sitio en vivo.

IMPORTANTE Realice una copia de seguridad de los archivos del sitio y la base de datos antes.

Tal vez necesito replicar tu sitio. Por favor instale temporalmente los plugins "Duplicator" y "Cloudways WordPress Migration" en su sitio web. Esto me permitirá crear una copia de su sitio y su contenido. Una vez resuelto el problema eliminaré el sitio local. Por favor, hágame saber si esto está bien para usted.

Saludos,
Diego

octubre 9, 2018 a las 1:25 pm #2800148

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks for the credentials. I found the string under the "Translate texts in admin screen" page. The string is now registered under the admin_texts_thegem_theme_options textdomain (see screenshot). Please try the following:
- Go to WPML > String Translator and translate the string. Make sure to check the "Translation is complete" field
- Go to Settings > Permalinks and re-save the structure
- Test

Please let me know if it worked for you.

Regards,
Diego

octubre 9, 2018 a las 3:23 pm #2800786

mariaC-6

Hola Diego!

Muchas gracias por tu ayuda. He podido traducir el slug en catalán, he guardado las opciones de nuevo en permalinks, pero no se cambian los enlaces dentro de los elementos del portfolio (edición) en catalán, se mantienen en español y ahora cuando vas a acceder a un elemento del portfolio, aparece la página 404, no se encuentra. Te adjunto capturas de pantalla.

A ver si podemos solucionarlo...

Muchas gracias por tu ayuda 🙂

octubre 10, 2018 a las 12:06 pm #2804138

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

En este caso creo que es mejor duplicar el sitio web en nuestro servidor. Así podemos hacer algunas pruebas sin modificar el sitio web original.

Por favor instale estos plugins:
- Duplicator: https://wordpress.org/plugins/duplicator/
- Cloudways WordPress Migration: https://wordpress.org/plugins/bv-cloudways-automated-migration/

Necesito de ellos para duplicar el sitio web y hacer algunas pruebas en la nueva copia.

Saludos,
Diego

octubre 10, 2018 a las 1:34 pm #2804465

mariaC-6

Hola Diego, ya instalé los plugins.

Quedo a la espera de respuesta.

Un saludo, gracias y que tengas un buen día 🙂

octubre 10, 2018 a las 7:00 pm #2805507

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Gracias! Estoy duplicando el sitio web. Después de eso haré algunas pruebas y te envío un feedback en breve.

Saludos,
Diego

octubre 11, 2018 a las 2:53 pm #2808753

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

He podido resolver el problema en el sitio de prueba utilizando los pasos siguientes:
- Vaya a WPML> Settings> Post Type Translation
- En "Portfolio Items (portfolio)" click en "Establecer diferentes slugs en diferentes idiomas para Portfolio Items."
- Defina "projectes" en Catalan y guarde
- Vaya a Settings > Permalinks, defina como "Simple" y guarde
- Defina como "Mes y nombre" de nuevo y guarde

Usted puede ver en estos enlaces (será necesario iniciar sesión para visualizar):
- hidden link
- hidden link

Por favor, dígame si funcionó para usted.

Saludos,
Diego

octubre 16, 2018 a las 1:39 pm #2821137

mariaC-6

Hola Diego, disculpa que no te haya respondido, pero ahora no puedo hacer la prueba que me comentas, porque los del la plantilla me actualizaron un plugin que daba conflicto con los trabajos de un programador y ahora no se ven los elementos del portfolio...
-
En cuanto a los enlaces que me enviaste, no se ven, me sale este aviso de mantenimiento:
"Website Under Maintenance
Our Website is currently undergoing scheduled maintenance. Please check back soon."
-
Por otro lado, tenía un problema para guardar las opciones del tema que se solucionó al desactivar el plugin de traducción de cadenas (debe dar algún tipo de conflicto), así que tendré que activarlo y desactivarlo a conveniencia...
-
Te aviso en cuanto tenga esto solucionado y pueda hacer la prueba con tus instrucciones.

Un saludo, gracias y que tengas un buen día,
María.

octubre 16, 2018 a las 4:44 pm #2821858
mariaC-6

Hola de nuevo Diego, si que pude hacer las pruebas, pues los elementos del portfolio no se muestran en la página del listado, pero si puedo ver los elementos del portfolio en el escritorio de WordPress y también la página del proyecto simple. Es decir, no puedo ver los listados XD

1. No me han funcionado las instrucciones (no sé si habré hecho algo mal...). Lo que si te comento es que necesito que los enlaces se mantengan con la misma estructura que en la web actual del cliente (esto es vital para conservar el posicionamiento online)= Estructura personalizada: hidden link

Ejemplo de estructura actual del slug en catalan: hidden link

Cómo debería ser: hidden link

Cuando entro al proyecto en editor de wordpress, se ve el slug mal, con proyectos en vez de projectes (adjunto screenshot) y cuando le doy a ver el proyecto, aparece el slug correctamente, pero con error 404 (screenshot).

2. Como te he comentado, hay algún tipo de conflicto del plugin de "traducción de cadenas" (string translation) con las opciones del tema y velocidad en la web. En cuanto lo activo, no puedo guardar las opciones del tema y la web me va extremadamente lenta. Además, vuelven a aparecerme errores de traducción en las opciones del tema, que habían desaparecido al desactivarlo.

* Sería importante solucionar cuanto antes estos problemas, porque la verdad es que me dificultan mucho el trabajo... y voy atrasada con este proyecto... A ver si me puedes echar una mano, por favor...

Muchas gracias y quedo a la espera de tu respuesta,

María.

Los hilos nuevos creados por Diego Pereira y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/dividir-traductor-de-cadenas-no-permite-salvar-como-opciones-de-tema/

octubre 16, 2018 a las 6:22 pm #2822097

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

El sitio web de pruebas está en modo privado. Para verlo, debe iniciar sesión antes aquí: hidden link

He cambiado a la estructura de permalinks personalizada y ha seguido funcionando perfectamente:
- hidden link
- hidden link

Usted está seguro de que ha seguido todos los pasos? Pues en la prueba de sitio funcionó.

Yo crearé un nuevo ticket para el problema del String Tanslator. Podemos manejar un solo problema por ticket. Esto también ayudará a otros usuarios con problemas similares a encontrar soluciones al buscar en el foro.

Saludos,
Diego

octubre 16, 2018 a las 9:34 pm #2822455

mariaC-6

Mil gracias por tu ayuda Diego y por tu rápida respuesta. Efectivamente no había seguido bien las instrucciones, no vi el campo de "Establecer diferentes slugs en diferentes idiomas para Portfolio Items." y pensé que la opción ya estaba marcada. Ahora funciona perfectamente. Mil gracias de nuevo y que tengas un buen día 🙂

* P.D.: seguimos con el otro problema en el otro hilo ;-/