Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 5 respuestas, has 2 mensajes.

Last updated by Noman hace 5 meses, 3 semanas.

Assigned support staff: Noman.

Autor Publicaciones
abril 24, 2019 a las 2:22 pm #3673925

Dudu

Estoy tratando de: Traducir los textos administrativos

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: cadena de traducción de texto administrativo habilitada

En vez de eso, obtuve: cadena de traducción de texto administrativo NO habilitada

abril 24, 2019 a las 3:41 pm #3674851

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to reply this in English, if you still need Spanish support please let me know.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- In most cases a string is not fully enabled and this is due to too many options being saved at once on that page. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set this variable in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- After increasing max_input_vars value you need to tick all the required strings from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and click on “Apply” button.

Then please go to WPML >> String Translation and you will see newly enabled values at top of the page and ready for translation, add the translation for those strings and check Translation is complete checkbox and press Save button.

Thank you

abril 24, 2019 a las 4:49 pm #3675319

Dudu

It's strange because I followed the steps you suggest in two websites: one I created as a test platform and it worked! then I tried in the main website and made no change at all.

abril 24, 2019 a las 4:58 pm #3675411

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Are both sites hosted on one same server? You need to contact hosting support to make these changes properly.

After hosting support make these changes on the server, please also check in WPML >> Support >> Troubleshooting page to confirm the updated values.

abril 25, 2019 a las 8:27 am #3680077

Dudu

Both sites are hosted on the same server. I spoke to server support and confirmed that changes are made properly on both sites. The only difference between sites is that they have different plugins applied. Could a plugin be interfering?
Thanks

abril 25, 2019 a las 10:56 am #3681367

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

1. Could you please follow these steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see which one there is an interaction issue.

2. If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

El debate ‘[Cerrado] Traducir los textos de las pantallas de administración no guarda los ajustes’ está cerrado y no admite más respuestas.