Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 1 respuesta, has 2 mensajes.

Last updated by Noman hace 2 meses, 3 semanas.

Assigned support staff: Noman.

Autor Publicaciones
julio 25, 2019 a las 8:04 am #4280497



I have a theme wich includes different layouts for header and footer.

As I have choosed one of these layouts for footer in every pages, menu widgets and others in footer change automatically when you select Spanish or English. I have change titles of these menu widgets by using String Translation, and it works all right... Nevertheless, this system does not work on Woo Commerce pages (shop, products, checkout...) and the titles always appear in Spanish, both in English and Spanish version of the web
I don't know how to fix this issue, cause when I look fot these titles in string translations, they are already translated.
Thanks in advance

julio 25, 2019 a las 10:14 am #4281689


Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting WPML Support. I am going to reply this in English, if you still need Spanish support please let me know.

=== Please backup your database and website ===

1. Please upgrade your server’s PHP version to a higher level:

PHP is 5.6.40 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

2. You are using an older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.2.

3. I noticed you are using an older version of WPML plugins in your site, please go to WP Dashboard >> Plugins >> Add new >> Commercial tab >> and try to update plugins from there.

3.1 If still issue persists in updating plugins, please update manually every WPML plugin with the latest ones downloaded from your
account page. To do a manual update please follow these steps:

- Backup your database – see for example:

- Deactivate the existing WPML plugins and add-ons.

- Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder, NOT the database records.

- Download the updated plugins from our servers ( and upload them to the plugin directory.

- Activate the WPML plugin and add-ons.

4. Please delete all sort of caches on your site / server cache / plugin cache (WP Super Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Super Cache plugin temporary.

5. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

El debate ‘[Cerrado] Translation of footer widgets does not work in Woo Commerce pages’ está cerrado y no admite más respuestas.