Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 2 respuestas, has 2 mensajes.

Last updated by raimonM hace 3 semanas.

Autor Publicaciones
septiembre 25, 2019 a las 6:54 pm #4641783

raimonM

Estoy tratando de: Tras instalar el pluggin wpml (sitepress-multilingual-cms.4.2.9) y configurarlo todo correctamente estaba intentando acceder como normalmente hago al personalizador de temas del wp para seguir trabajando.

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: El personalizador del tema para seguir trabajando. Uso el tema DIVI Versión: 3.27.4.

En vez de eso, obtuve: Un mensaje del wordpress con toda la pantalla en blanco con un solo mensaje que me indica que "El sitio está experimentando dificultades técnicas. Por favor, revisa el buzón de correo electrónico del administrador de tu sitio para ver las instrucciones". Y no puedo acceder al personalizador, al resto de la web si puedo acceder, en principio. Solo es al intentar ir al personalizador del theme que me da ese mensaje y no me deja seguir trabajando. Por favor necesito resolver esto porque se supone que WPML es compatible con DIVI, lo miré antes de comprarlo y no entiendo porque falla. Gracias por su ayuda espero que puedan ayudarme. Otra cosa que he detectado que falla es la version en movil de la web que estoy realizando. En movil tampoco va hidden link. Desesperada estoy, please help me.

NOTA: Antes de enviar mis comentarios... sospecho que quizás podria ser que sea por el WP_MEMORY_LIMIT que lo tengo a 40? si es así ¿en que linea exacta del wp-config.php debo añadir lo de: define( 'WP_MAX_MEMORY_LIMIT', '256M' );?

septiembre 25, 2019 a las 9:22 pm #4642099

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola @raimonm, Bienvenido al foro de soporte de WPML.

Verifiqué la configuración de su servidor a través del registro de depuración y vi que algunos elementos necesitan atención:

Versión PHP
Actualice el PHP a la versión 7 o superior. Esta es una práctica recomendada por el website de WordPress.org: https://wordpress.org/about/requirements/

Aumentar la memoria WP
Aumente el límite de memoria PHP a 256 mb. Actualmente esta memoria está configurada en 40mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Actualmente su servidor está configurado con MaxInputVars = 1000, que es bajo y puede causar problemas. Por favor aumente esto a 10,000. Hay dos opciones para hacer esto:
== archivo php.ini
Abra el archivo php.ini e inserte / edite esta línea:

 max_input_vars = 10000 

hidden link

== archivo .htaccess

 php_value max_input_vars 10000 

Si el problema continúa, por favor habilite WP_Debug, WP_Debug_log y WP_Debug_Display en su sitio web. Esto mostrará más detalles sobre el error: https://wpml.org/documentation/support/debugging-wpml/ - por ejemplo

define ('WP_DEBUG', true);
define ('WP_DEBUG_LOG', true);
define ('WP_DEBUG_DISPLAY', true);

Por favor dígame si funcionó para usted.

Saludos,
Diego

septiembre 26, 2019 a las 11:29 am #4646287

raimonM

My issue is resolved now. Thank you! 🙂

Al final casi lo resolví por mi cuenta, aunque las aclaraciones dadas me han sido de muchísima utilidad y agradezco mucho la rapidez en contestar. Al final lo único que he hecho es aumentar el límite de memoria a 256MB y con eso parece que el problema se ha resuelto... No he tocado el php porque es mas complicado y de momento parece que todo va bien. Así que de momento doy por solucionado el problema. Espero que todo funcione bien a partir de ahora. Gracias de nuevo por la rápida ayuda Diego 🙂 .