Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 19 respuestas, has 2 mensajes.

Last updated by jaimeG-9 hace 1 mes, 2 semanas.

Assigned support staff: Yvette.

Autor Publicaciones
agosto 12, 2019 a las 6:57 am #4378639

jaimeG-9

Estoy tratando de: resolver problema anterior (el servicio de soporte del Tema utilizado no ha tomado una buena resolución. Esto es lo que han hecho: " What we did is we disabled WooCommerce multilingual plugin, which is not official one from WooCommerce, but from some 3rd party authors and it seems like it resolved the problem. Unless you logged in in the meantime to reset products.")

URL de (mi) sitio web donde aparece el problema: hidden link en los tres idiomas

Yo esperaba ver: el problema inicial (se puede ver en la anterior consulta) es que la tienda dejaba de funcionar en dos idiomas . Soporte del tema me ha deshabilitado el plugin multilingual con lo cual la tienda aparece pero no en sus monedas correspondientes y a veces con estilo distinto

En vez de eso, obtuve: desaparece el contenido en idioma francés e inglés

agosto 12, 2019 a las 8:49 am #4379361

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Si entiendo bien, existe un tipo de incompatibilidad entre tu tema y el uso de multi-monedas. As así?

Desafortunadamente, el tema no aparece en la lista de temas compatibles con WPML aún:
https://wpml.org/documentation/theme-compatibility/

Así que, para descartar que el problema sea con tu tema, por favor, súbelo a este sistema sandbox pre-configurado con WPML y WCML.
hidden link

Eres capaz de reproducir el error que encuentras con tu sistema?

Gracias por tu colaboración.

Estoy a la espera de tus noticias.

agosto 12, 2019 a las 9:30 am #4379683

jaimeG-9

Hola Yvette,

Gracias por tu respuesta, para entender lo que pasa puedes leer mi consulta anterior https://wpml.org/es/forums/topic/woocommerce-en-tres-idiomas-a-los-pocos-dias-dejan-de-funcionar-dos-de-ellos/ que ha sido cerrada porque han pasado varios días, ya que el soporte del tema no lograba ver el error.

La web funcionaba bien y ocasionalmente la página inicial de la tienda en francés e inglés desaparecía durante horas (incluso días y luego volvía aparecer), también aparecía si entraba en el backend y actualizaba, sin cambiar contenido,la página de la tienda.

Soporte del tema ha decidido desactivarme el plugin multilingual de woocomercce, cosa que no es solución porque ni mi cliente ni yo, estamos satisfechos.
Indícame, for favor, cómo subir el tema a sanbox. El problema se reproduce solo de vez en cuando (normalmente en un día da error).
Espero tus comentarios, saludos,

agosto 12, 2019 a las 10:32 am #4380075

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Has escrito:
".. ocasionalmente la página inicial de la tienda en francés e inglés desaparecía durante horas (incluso días y luego volvía aparecer), también aparecía si entraba en el backend y actualizaba, sin cambiar contenido,la página de la tienda..."

1. "...ocasionalmente.."
En casos cuando hay errores que no ocurre regularmente, se suele ser asociado con algún configuración del servidor. Es decir, si fuese un problema "logica" del plugin, sería presente siempre en condiciones determinados.

2. "..aparecía si entraba en el backend y actualizaba.."
En cambio, si puedes prococar el error haciendo algún acción determinada...esto sí se podría investigar.

3. Tema en el sandbox
"..cómo subir el tema a sanbox..:"
Ir a Appearance > Themes > Add new

Seleccionar el zip de tu tema.

agosto 12, 2019 a las 10:45 am #4380151

jaimeG-9

Hola Yvette,

Lo que dices en el punto 1 es totalmente lógico. No entiendo que los diseñadores del tema hayan optado por desactivar el plugin multilingual de woocommerce.

En el punto 2, me he equivocado al escribir, quise decir "desaparecía si entraba en el backend y actualizaba...", es decir vuelve a la normalidad, funcionado ok.

En cuanto al punto 3, subo el tema ¿pero luego tengo que subir todo el contenido y los plugins?

Gracias por tu atención, saludos cordiales

Jaime

agosto 12, 2019 a las 10:54 am #4380261

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ah....pensaba que había alguna manera como "provocar" el problema.

De todas maneras, subiendo el tema nos permite investigar nos permite investigar el problema sin influencia de otros plugins (no esenciales para el tema) o datos.

Pero, si no puedes provocar el problema....no sé si vale la pena. Has podido dectectar aglún tipo de patron antes que desaparece la página?
- Si activas el wordpress log, capturas algún notificación del sistema antes que desaparece la página?

Entrando en el dashboard y actualizando la página me hace pensar que está relacionado on los slugs/permalinks. Tienes algún tipo de caching activo?

Lo siento decir que sin más información de que puede estar ocurriendo justo antes del problema, es casi imposible empezar un investigación.

agosto 13, 2019 a las 5:50 am #4385125

jaimeG-9

Hola Yvette,

He subido el tema y he configurado una tienda en tres idiomas (lo he hecho rápidamente espero que esté bien), también he vuelto a activar WCML en el sitio de producción por si puedo observar algún patrón que provoque el error y quede registrado en debug.log.

No cuento con caché alguno y probé a ir desactivando los plugins uno a uno por si resolvía el problema.

Supongo que queda esperar a ver si se produce el error.

Gracias por tu atención, saludos cordiales,

Jaime

agosto 13, 2019 a las 10:38 am #4387095

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Has escrito: "Supongo que queda esperar a ver si se produce el error."

Sí - desafortunadamente, así es. Cuando produce el error, mira los logs del sistema y también del developers console del browser por cualquier tipo de información al respeto.

Quedamos a la espera de tus noticias.

agosto 17, 2019 a las 7:00 am #4409439

jaimeG-9

Hola Yvette,

Ahora son las 8:54 am en Madrid 17 de Agosto, y en la web se está produciendo el error (igual cuando lo veas está funcionando ok).

éstas son las líneas desde el día 16 del archivo debug.log:

[16-Aug-2019 14:37:14 UTC] PHP Warning: include(/home/clients/91fb7ab809b090c955804c5894b7a006/web/wp-content/plugins/ottar-core/post-types/portfolio/shortcodes/portfolio-list/templates/layout-collections/standard-shader.php): failed to open stream: No such file or directory in /home/clients/91fb7ab809b090c955804c5894b7a006/web/wp-content/plugins/ottar-core/lib/helpers-functions.php on line 47

¿Puedes sacar en claro algo de ésto?

Te adjunto dos imágenes la tienda en francés (que no se ve, la de español tampoco funciona) y la de inglés que funciona ok.

La plantilla en el sandbox de momento no muestra error.

Espero tus comentarios, saludos cordiales,

Jaime

agosto 19, 2019 a las 9:48 am #4414963

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Gracias por la información

Lo que detalle el log es un "warning" (no error) con el post type "portfolio" del tema. Así que es una anomlía (no necesariamente un error) relacionado con tu tema.

Lo que sí puedes hacer la próxima vez que ocurre, es sacar una copia de tu site con el error presente. Así podemos ver a primera mano que ocurre. Tienes razón...ahora mismo puedo visualizar la página inical de la tienda sin problemas en los tres idiomas.

Te parece bien seguir adelante así?

Aquí instrucciones de como sacar una copia de tu sistema:
https://wpml.org/es/faq/como-proporcionar-una-copia-del-sitio-al-personal-de-soporte/

Abro el area privada para que nos envia un enlace a un servicio de compartir archivos como WeTransfer donde has subido los ficheros de Duplicator.

agosto 19, 2019 a las 5:04 pm #4417533

jaimeG-9

Hola Yvette,

Gracias, en cuanto falle sigo tus instrucciones, saludos,

Jaime

agosto 20, 2019 a las 8:17 am #4421561

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Gracias - quedo a la espera de la copia de tu instalación

agosto 21, 2019 a las 6:13 am #4428177

jaimeG-9

Hola Yvette,

No puedo enviarte el enlace para que puedas descargar la copia del sitio, he probado a incluir el de wetransfer y a través de google drive, pero el sistema me dice que no es válido

Muchas gracias por tu atención, espero tus indicaciones, saludos,

Jaime

agosto 21, 2019 a las 8:01 am #4428759

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Abro el area privado - puedes includir el enlace allí.

agosto 23, 2019 a las 4:55 pm #4448897

Yvette
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Gracias - estoy instalando la copia de tu sitio en un servidor local.

Hay algun razón por que no actualizas la version de Woocommerce? Como regla general, siempre es aconsejable tener todo tus plugins a la version más actual.

Gracias