Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by Andrés hace 1 año, 5 meses.

Assigned support staff: Andrés.

Autor Publicaciones
mayo 12, 2018 a las 6:43 am

stefanoA-5

Hola.

tengo un estraño problema.. tengo un Woocommerce en 3 idiomas EN de base, ES y IT.
Todo traducido en los tres idiomas (las paginas, los productos, etc...).

Todo funciona correctamente pero la página de shop se queda vacía... y lo que es estraño es que ocurre solo a veces (me parece cuando modifico algun item).
Solo la pagina de shop se queda vacia de productos, como si no existieran los productos.
Como justo ahora: hidden link

Como vereis las traducciones (ES e IT) funcionan bien. Tambien los productos (en los 3 idiomas).

Pero si le doy a volver a guardar los permalinks, se soluciona. (y luego despues de X tiempo vuelve a ocurrir).

He leido que era un problema de una version del WPML (pero lo lei en unos post del 2015 y 2016) y tengo todo a la ultima version.

Pueden ayudarme?
Gracias de antemano.
Nota: si te conectas fuera de España o de paises de suramerica, dime desde donde asi te abro el firewall del servidor.

mayo 12, 2018 a las 8:05 am #2096620

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

En este momento tratando de hacer una copia de tu sitio. Sin embargo, hay algunas cosas que me llaman la atención.

1. Tu WPML no está al día, la versión actual es la 3.9.4.

2. Si desactivo WPML, tu tienda en el idioma por defecto no cambia y sigue vacía. Esto me hace pensar que el problema no esté ligado a nuestro plugin. ¿Me podrías decir dónde viste que esta situación era ocasionada por nuestro plugin?

3. Sin embargo, veo que esta situación también se produce en la tienda en italiano.

Regreso después de algunas pruebas en local.

Un saludo,
Andrés

mayo 12, 2018 a las 8:08 am #2096679

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

He tratado de reproducir esta situación en local sin ninguna suerte. Esto me lleva a pensar o que se puede tratar de un problema en tu entorno (para lo cual necesitaríamos un sitio de prueba o que nos autorices a probar en el sitio que nos has suministrado) o que desconozco los pasos necesarios para poderlo hacer.

Espero a tus comentarios sobre como seguir.

Saludos

mayo 12, 2018 a las 8:12 am #2096785

stefanoA-5

Hola Andres,

gracias para la respuesta tan rápida.
1.
Si es verdad, es que salió hace poco la 3.9.4 y no me ha dado tiempo actualziar y estoy en la 3.9.3

2.
Encontré el mismo problema en este post: https://wpml.org/forums/topic/product-shop-page-is-empty-no-products-in-default-language/
Y buscando en google "wpml shop page empty" salen varios.

3.
En la tienda en Italiano si no me equivoco no pasaba..

En este instante veo que tambien en el shop en ingles salen todos, no se si le has dado a guardar el permalink tu o al guardar algo (o vaciarse la cache?) ha vuelto a su estado normal.

Seguimos en contacto.
Espero tus news
Gracias

mayo 12, 2018 a las 8:29 am #2096970

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

En efecto, he guardado tus enlaces permanentes y también agregué una pequeña modificación temporal en uno de tus productos para tratar de replicar esta situación sin ninguna suerte.

1. ¿Me podrías decir cómo replicar este problema?

2. ¿Podrías actualizar tu WPML?

3. Gracias por compartir en enlace, sin embargo creo que no aplica para tu caso. Por una parte data de hace más de dos años, por otra parte, requería una configuración diferente a la tuya como es tener la tienda en la página de inicio.

Quedo atento a tus comentarios.

mayo 12, 2018 a las 6:35 pm #2101859

stefanoA-5

Hola andres,

por mi puedes trabajar directamente online.
Tengo una copia de seguridad por si a caso (tanto de files como de DB).
Lo único, ojo a no llegar al maximo del espacio del sitio (le faltan 400MB para llegar a los 2GB de espacio asignado en el servidor)

Me parece que el error ocurre cuando aplico una traducción a un producto, pero solo a veces... (esto es el gran misterio).

Ya he actualizado el Sitepress a la ultima version.

Espero tus noticias.
Gracias.
Stefano

mayo 13, 2018 a las 12:08 pm #2105270

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Stefano,

He tratado de replicar en varias ocasiones esta situación, sin embargo no me ha sido posible. De hecho, no se si está ligado a WPML o a tu plantilla, ya que en el día de ayer una de las pruebas que realicé fue desactivar WPML cuando no se visualizaban los productos y la situación no cambió.

Si encuentras una manera de replicarlo, no dudes en compartirlo para que podamos continuar.

Saludes,
Andrés