Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Our next available supporter will start replying to tickets in about 0.95 hours from now. Thank you for your understanding.

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Andreas W. hace 2 meses, 1 semana.

Assigned support staff: Andreas W..

Autor Mensajes
abril 8, 2021 a las 8:02 am

mariaE-3

Strings are imported correct but WP-Client is not shwoing up translated. Tested on Localhost in mininal setup. Other plugins are not affected.

abril 8, 2021 a las 10:42 am
abril 8, 2021 a las 11:24 am #8491079

mariaE-3

Plugins installed, now you can continue

abril 9, 2021 a las 1:45 pm #8502639

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

On the test-site I see a very odd behavior.

First, I installed WPML with default language Spanish.

The backend keeps showing up on the tabs in Spanish only, other strings are mixed up as the plugin seems not to be translated completely and the most odd thing is that it is not respecting the admin language and is showing different language then the selected one.

I then tried to switch the WPML site default language to English, as this is also the default language of the plugin.

I actually realized a pattern in which when switching the language in the top admin bar always the prior selected language wil show up inside the plugin, like if it was delayed.

Example:
Switch language in admin bar to FR, then switch to DE, you will see FR displayed, then switch to EN, you will see DE displayed. Can you confirm this on your site as well?

Also, I can confirm that the correct backend string are loaded after refreshing the page and I can see that this issue does affect WP-Client and the WPML backend as well. Other sections are not affected.

You can see this here:
hidden link

Now, based on the .po-file the only string that I can see without registering the plugin that is included into the file is "System Status" and it shows up as translated.

String like "Licenses" among others are not picked up by String Translation and are also not part of the .po-files. The reason is most likely that the plugin author did not code them properly in order to be translatable.

Now, at this point I am escalating the issue towards our compatilbity team, as I can confirm an issue when switching the language in the backend, but I am not able to confirm issues with strings not showing up as translated, as I can not see those strings without having valid API keys on the site.

Take note, that the changes for making the plugin compatible with WPML might need to get included into the WP-Client plugin by the plugin author.
As far I can see on wordpress.org their support seems to be down for more than one year which for it might be the case that we might not achieve cooperation here.

https://wordpress.org/support/topic/wp-client-4/

Did you hear back from their support team lately?

Also, take note that you can cooperate in translating the default language files of the plugin here:
hidden link

As soon I received more feedback from our team after revising the issue I will be in contact.

Best regards
Andreas

abril 11, 2021 a las 1:19 am #8507993

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We found a workaround but we are not sure that it won't cause other issues. Because for some reason the plugin author is loading the text domain too early:

In wp-content/plugins/wp-client/wp-client.php line 100:

add_action( 'plugins_loaded', array( &$this, 'load_plugin_textdomain' ), -10 );

If we change -10 to 1 the issue is gone.

I have tested this on our test-site and it solved the issue with strings showing up in worng language on backend. Take note that this issue earlier disappeared after refreshing the page.

For single untranslated strings please reach out the WP-Client support, as they do have an amount WPML compatilbity code inside their plugin and should now how to implement necessary changes.

Also, the above provided fix will need to be reviewed and implemented by the WP-Client Devs.

Best regards
Andreas

abril 13, 2021 a las 12:43 pm #8525345

mariaE-3

Thanks. I will test it

abril 13, 2021 a las 12:54 pm #8525411

mariaE-3

Good afternoon.

I have applied the change of -10 by 1 in the line of php code that you tell me and it does not work.

You can access the web and review it please.

Anything you need, write to me and we will see it.

Thanks. All the best.

abril 13, 2021 a las 4:37 pm #8527771

mariaE-3

¡Hola!

Desde WordPress 5.2 hay una característica incorporada que detecta cuándo un plugin o un tema causa un error fatal en tu sitio y te avisa mediante este correo electrónico automático.

En este caso, WordPress ha detectado un error con uno de tus plugins, WPML Translation Management.

Primero, visita tu web (hidden link) y comprueba si hay algún problema visible. A continuación, visita la página donde ha sido detectado el error (hidden link) y comprueba si hay algún problema visible.

Por favor, ponte en contacto con tu alojamiento para que te ayude a investigar más a fondo este problema.

Si tu sitio parece roto y no puedes acceder a tu escritorio con normalidad, ahora WordPress tiene un «modo de recuperación» especial. Este te permite acceder de forma segura a tu escritorio e investigar más a fondo.

hidden link

Para mantener tu sitio seguro, este enlace caducará en 1 día. Sin embargo, no te preocupes por esto: recibirás por correo electrónico un nuevo enlace si el error ocurre de nuevo después de que caduque.

Cuando busques ayuda para este problema, es posible que se te pida la siguiente información:
WordPress versión 5.7
Tema actual: The7 (versión 7.6.1)
Plugin actual: WPML Translation Management (versión 2.10.6) PHP versión 7.4.16

Detalles del error
==================
Se ha producido un error del tipo E_ERROR en la línea 30 del archivo /home/fotonamobility/www/wp-content/plugins/wpml-translation-management/classes/words-count/processor/calculator/wpml-tm-word-calculator.php. Mensaje de error: Maximum execution time of 30 seconds exceeded

abril 14, 2021 a las 2:18 am #8530109

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have re-edited the code line, and this needs to be implemented by the WP-Client plugin author. There is sadly not more we can do from our side.

Then I enabled inside the WordPress User Profile the option:

Configuración de idioma de WPML -> Idioma de edición -> Establecer el idioma de administración como idioma de edición.

Now, when I go to Dashboard -> WP Client I can see the translations, based on the strings which are translated by default.

Then there are strings like "Client staff" that I simply can not locate, whihc might be further related to how WP-Client is coded.

The plugin has a lot of WPML compatibility code implemented, and the author should take a look at it and further test its plugin for compatilbity.

We can sadly not do much more from our side, specially without having access to the complete plugin.

If you reach the theme author or the support team, please invite them to join our Go-Global Program so that we will be able to provide our adivses and support to the author himself.

https://wpml.org/documentation/theme-compatibility/go-global-program/

Best regards
Andreas

abril 14, 2021 a las 8:03 am #8531701

mariaE-3

Hello!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site and alerts you via this automated email.

In this case, WordPress has detected an error with one of your plugins, WPML Translation Management.

First, visit your website (hidden link) and check if there are any visible problems. Next, visit the page where the error was detected (hidden link) and check if there are any visible problems.

Please contact your property to help you further investigate this issue.

If your site seems broken and you cannot access your desktop normally, WordPress now has a special "recovery mode". This allows you to safely access your desktop and investigate further.

hidden link

To keep your site safe, this link will expire in 1 day. However, don't worry about this: you will receive a new link by email if the error occurs again after it expires.

When looking for help with this problem, you may be asked for the following information:
WordPress version 5.7
Current topic: The7 (version 7.6.1)
Current plugin: WPML Translation Management (version 2.10.6) PHP version 7.4.16

Details of the error
==================
An error of type E_ERROR occurred on line 30 of the file / home / fotonamobility / www / wp-content / plugins / wpml-translation-management / classes / words-count / processor / calculator / wpml-tm-word-calculator .php. Error message: Maximum execution time of 30 seconds exceeded

PLEASE I NEED HELP WITH THIS

abril 15, 2021 a las 2:32 am #8540133

Andreas W.
Supporter

Languages: Inglés (English ) Español (Español ) Alemán (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The error refers to:

"Error message: Maximum execution time of 30 seconds exceeded"

You need ot change the value for max_execution_time inside the php.ini or the .htaccess file and from there we need to check if the issue persits, but form the first impression this looks as if the setting is simply not high enough in order to run the task.

You could add this to the bottom of the .htaccess file:

php_value max_execution_time 300

or

change the following line inside of the php.ini file on the server:

max_execution_time = 60

Take note that sometimes those settings are limited according to the hosting package used. If you ar ein doubt that the setting is applied or you need assistance please consult your hosting support who can assist you with the changes.

If you could receive even higher settings this would be great.

More details about the issue:
hidden link

Take note, that you also should be able to see the actuall PHP values at WPML -> Support.

I hope this can solve the issue. If the error keeps occuring after taking the changes, please reach out again for further investigation.

Also, take note that we made some changes inside WP-Client regarding the priority in whihc it loads its language files. I am not sure if the reported issue might be related to that, but please test if the error disappears once WP-Client is deactivated.

For further assistance about the issue with WP-Client please try to reach their support and invite them to join our Go-Global Program:
https://wpml.org/documentation/theme-compatibility/go-global-program/

Best regards
Andreas

El debate ‘[Cerrado] WP-Client imported .po files do not translate plugin on backend’ está cerrado y no admite más respuestas.