Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 4.17 hours from now. Thank you for your understanding.

Etiquetado: 

This topic contains 9 respuestas, has 2 mensajes.

Last updated by manoloB hace 12 meses.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
octubre 18, 2018 a las 9:59 am #2827524

manoloB

Buenos días! Acabo de crear un sitio web con el theme hidden link.

He configurado un par de aspectos de la web y acto seguido he instalado WPML. Al instalar el plugin muchos aspectos visuales de la web se han descuadrado totalmente, empezando por el Home, que ni si quiera se muestra.

Por ejemplo:

- La Home (hidden link) aparece como una pantalla en blanco (antes se veía bien).
- La página de "calidad" (hidden link) está compuesta por 3 tabs que muestran información según aprietas. Ahora mismo las cabeceras aparecen sin estilos y además, no funcionan pues aparece todo el contenido de golpe y junto.

Me gustaría que me dieran una solución a esto lo antes posible.

Gracias.

octubre 18, 2018 a las 5:31 pm #2829051

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.
Haré todo lo posible por ayudarlo a solucionar este problema.

El tema que está utilizando no aparece en nuestra lista de temas compatibles, puede verificarlo en este enlace: https://wpml.org/es/documentation-2/compatibilidad-del-tema/
Esto significa que nuestro equipo de compatibilidad no lo ha validado aún.
Muchas veces los temas muestran que son compatibles con nuestro plugin, pero si no aparece en nuestra lista de compatibilidad significa que no ha sido validado aún.

De todas maneras me gustaría señalar que al abrir el sitio se puede ver un error en la consola de Javascript del navegador que parece ser la causa del problema. Con el objetivo de validar que WPML y dicho tema tienen problemas de interacción me gustaría pedirle que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo antes de realizar cualquier cambio.
- Actualice cualquier plugin que pueda estar desactualizado.
- Borre cualquier memoria cache que pueda existir.
- Desactive todos los plugins excepto los de WPML.
- Ve a Ajustes -> Enlaces permanentes -> Guarda la configuración sin realizar ningún cambio.

Me puede decir si en estas circunstancias el problema persiste?

Quedo a la espera de su respuesta.
Saludos cordiales,
Carlos

octubre 19, 2018 a las 6:37 am #2830610

manoloB

Hola! He seguido los pasos que me ha indicado y el problema persiste.

Claro, yo cuando compré el tema, sí que se indicaba que era compatible con WPML...

Nose que debería hacer para que se solucionase este problema.

Gracias.

octubre 19, 2018 a las 4:35 pm #2832732

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

En este caso me gustaría solicitar acceso temporal al sitio con el objetivo de ver el problema más de cerca y en caso de ser necesario, realizar una copia para hacer más pruebas en un ambiente controlado sin que afecte al sitio en producción. Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Antes de suministrar las credenciales de acceso y a pesar de que no voy a realizar ningún cambio en el sitio, es recomendable crear una copia de seguridad del sitio completo.

Quedo a la espera de su respuesta.
Saludos cordiales,
Carlos

octubre 22, 2018 a las 5:25 pm #2839192

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por la información suministrada.

He visto el sitio mas detalladamente y sospecho que existe un problema de compatibilidad entre el tema y WPML. Para comprobar esto he creado un sitio de pruebas con una instalación de WordPress desde cero y he configurado WPML al igual que el sitio en producción.

Me gustaría pedirle que se autenticara en este nuevo sitio de pruebas utilizando el siguiente enlace: hidden link e instalara el tema y me dijera si el problema persiste.

Quedo a la espera de su respuesta.
Saludos cordiales,
Carlos

octubre 23, 2018 a las 9:44 am #2841725

manoloB

Vale perfecto, pues voy a probar a ver si persiste el problema.

GRACIAS!

octubre 23, 2018 a las 5:44 pm #2843704

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Quedo a la espera de su respuesta.

Saludos cordiales,
Carlos

octubre 24, 2018 a las 9:47 am #2845629

manoloB

Buenas! Acabo de instalar el tema y parece ser que todo funciona con normalidad. Viendo esto, que debería hacer? Realizar otra vez la instalación de wordpress, instalar WPML y luego el tema... o es necesario realizar alguna configuración especial para que funcione?

GRACIAS y un saludo!

octubre 24, 2018 a las 6:08 pm #2847521

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Si el problema desapareció en el sitio de pruebas entonces es posible que estén sucediendo uno de estos problemas:
1.- Hay algún problema de compatibilidad entre WPML y una funcionalidad de algún plugin.
2.- El ambiente de hosting no cumple con los requisitos mínimos: https://wpml.org/home/minimum-requirements/
3.- Existe algún tipo de memoria caché desactualiza que muestra el contenido de manera errónea.

Para la primera variante los pasos a seguir son los siguientes:
- Realice una copia de seguridad del sitio completo.
- Actualice todos los plugins y temas.
- Desactive todos los plugins excepto los de WPML.
- Si el problema desapareció comience activando los plugins uno por uno hasta que el problema vuelva a aparecer.

Para los puntos 2 y 3 le recomiendo que contacte a sus proveedores de hosting y les pida que revisen las características del hosting y que borren cualquier memoria cache que pueda existir del lado del servidor.

Saludos cordiales,
Carlos

octubre 25, 2018 a las 10:39 am #2849451

manoloB

My issue is resolved now. Thank you!