Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

Etiquetado: 

This topic contains 8 respuestas, has 2 mensajes.

Last updated by Diego Pereira hace 1 mes, 3 semanas.

Assigned support staff: Diego Pereira.

Autor Publicaciones
agosto 19, 2019 a las 10:17 am

taliaB

Estoy tratando de: Tenemos activado Divi y WPML multilingual y nos aparece como sitio no seguro cuando WPML está activado, además crea un bug en las páginas de producto y nos aparece un espacio inmenso en blanco entre el menú y la cabecera cuando hacemos scroll rápido varias veces en determinadas páginas.

URL de (mi) sitio web donde aparece el problema: hidden link y en las páginas de producto

Yo esperaba ver: La página normal pero nos crea un aviso de página no segura, tarda mucho en cargar y además nos crea un espacio en blando cuando haces scroll rápido varias veces que antes no teníamos.

En vez de eso, obtuve: Una página 'poco segura', y con un espacio en blanco inmenso que antes no estaba.

agosto 19, 2019 a las 12:37 pm #4415999

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola @taliab, Bienvenido al foro de soporte de WPML.

Al parecer, su sitio web tiene el error de "Mixed Content". Por favor, Instale este plugin y dígame si esto resuelve el problema: https://wordpress.org/plugins/ssl-insecure-content-fixer/

Saludos,
Diego

agosto 19, 2019 a las 2:56 pm #4416987

taliaB

Hola,

No resuelve el problema, tarda mil años en cargar y es más, nos aparece lo que puedes leer en la imagen adjunta (que ese plugin realiza las mismas tareas que el de sitground que tenemos instalado y que se duplican funcionalidades, que no nos recomiendan tenerlo activados ambos. El otro es el proporcionado por nuestro servidor y nunca nos ha dado problema). Lo único que hace que vuelva a salir el símbolo del candado verde, osea como que la web es segura es cuando desactivamos vuestro plugin.

Gracias

agosto 19, 2019 a las 5:41 pm #4418063

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Por favor, intente los siguientes pasos:
- Deshabilitar el complemento de reparación de contenido SSL
- Deshabilitar el plugin SG optimizer temporalmente
- Vaya a Configuración> General y verifique si la URL del sitio web está configurada correctamente (con https).
- Después de eso, vaya a Configuración> Enlaces permanentes y guarde la estructura de enlaces permanentes.
- Verifique que el error se haya resuelto. Recuerde borrar todos los cachés
- Active el plugin SG optimizer nuevamente

Por favor, dime si esto resuelve el problema. Si no, le enviaré algunas instrucciones para copiar el sitio web a nuestro servidor de prueba.

Saludos cordiales,
Diego

agosto 20, 2019 a las 10:25 am #4422737

taliaB

Hola,

Nada de eso ha funcionado. Sin embargo mirando el código de la web en la consola el contenido mixto que se carga y que está haciendo que se detecte como no segura son vuestras imágenes de las banderas (adjunto imagen). Desactivando que salgan las imágenes de banderas otra vez detecta que nuestra web es segura. Pero creemos que es poco intuitivo el selector de idioma sin mostrar las banderas. ¿Cómo lo podemos resolver? No entendemos qué pasa con vuestras imágenes.

Gracias

agosto 20, 2019 a las 12:28 pm
agosto 20, 2019 a las 12:28 pm #4423599

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Envié algunas instrucciones para replicar el sitio web a través de un mensaje privado (respuesta anterior).

Por favor déjame saber si funcionó para ti. Si es así, envíenos instrucciones claras sobre cómo ver / reproducir el problema.

Saludos cordiales,
Diego

agosto 27, 2019 a las 12:47 pm #4466787

taliaB

Ya ha empezado la migración te aviso cuando acabe. Además de lo del contenido mixto que generan vuestras imágenes de las banderas, nos está agregando el pluging como un espacio entre el menú y la cabecera cuando haces scroll rápido arriba y abajo, y ayer nos tocó restaurar a una copia de seguridad de la semana pasada porque no podíamos acceder a nuestra web. Nos contactaron del hosting porque teníamos la base de datos petada por WPML también y nos dijeron que probásemos de hacer esto: https://wpml.org/forums/topic/table-wp_icl_string_pages-is-too-big/

Lo que nos escribieron los de siteground fue esto:

SiteGround - ¡Hosting web creado para ti!Talia Bonmati
Hola, Talia Bonmati
Mis datos
Cerrar sesión
Inicio
Hosting
Soporte
Facturación
Recomiéndanos
Comprar
Extras
VER TICKET
Imprimir
Ticket InfoTicket 3236733 de la cuenta dinbeat.com
Publicado: 26 Aug, 2019 05:20 CDTEstado: Esperando tu respuesta
Asunto del ticket: Incidencias técnicas
-Contraer todos Mensajes de ticket:
Avatar
Usted
Publicado el 26 Aug, 2019 05:20 CDT
De parte del cliente: Hola,

Nos habéis enviado un mensaje como que hemos superado el uso de recursos de la base de datos de wordpress, pero tenemos una tienda online montada, pero no estamos actualmente vendiendo nada. Es decir, tiene que ser algún componente o algo que hayamos instalado en la web lo que está generando ese error o ese exceso de escrituras en la base de datos, porque la web es súper simple. Además no podemos acceder al administrador del panel de control, ¿nos podéis echar un cable para ver qué pasa? ¿Se puede saber qué plugin está generando eso? Nos han llegado un montón de emails que reportan tareas cron con error de woocommerce...

Gracias

Avatar
Yulian Kamenov
Support GuruEnviados: 1144Publicado el 26 Aug, 2019 05:36 CDT
Creado por
Mostrar original

He revisado tu caso y he notado que la tabla más grande de tu base de datos es:

Code:
Table name Size
-------------------------------------- --------
wpms_icl_string_pages 968.0 MB

Esta tabla está creada por un plugin llamado WPML (un plugin multilingüe de WordPress). He encontrado el siguiente tema en su foro que creo que sería de ayuda para usted:

https://wpml.org/forums/topic/database-table-icl_string_pages-too-big/

Los errores cron probablemente están relacionados con la limitación debido al tamaño de la base de datos. También puedes consultar con tu desarrollador web sobre el asunto.

Así que WPML nos está creando bastantes problemas y no entendemos por qué, usamos Divi en teoría súper compatible. A ver si nos podéis echar un ojo a la configuración, porque no entendemos qué pasa.

Te aviso cuando esté migrada.

Gracias

agosto 27, 2019 a las 1:43 pm #4467355

taliaB

Ya está migrada la web. Para ver el problema de contenido no seguro puedes activar la aparición de las banderas desde vuestro plugin. El resto de errores nos aparecen sin hacer nada, y desaparecen al desactivar vuestro plugin.

Gracias

agosto 27, 2019 a las 8:57 pm #4469637

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Gracias, la migración funcionó.

Lo que sucede es que cuando se habilita SSL, WordPress necesita un complemento para corregir las URL de las imagenes. Dado que el complemento optimizador SG ya tiene esta característica, evita que otros complementos similares hagan este trabajo. Tenga en cuenta en la screenshot que el mismo error también ocurre con otras imágenes (no solo las banderas del language switcher). Hay dos formas de resolver esto.

Usando el plugin SG optimizer
El plugin SG optimizer tiene una feature que funciona pero no está activa en su sitio web. Puede habilitar esta función en SG Optimizer> Configuración> Habilitar https (screenshot)

Esta opción no funcionó en nuestro servidor (el plugin es hecho para servidores siteground). Entonces usé la siguiente opción.

Deshabilite el complemento optimizador SG y use otros complementos
La otra opción (que funcionó en nuestro servidor) es deshabilitar el plugin SG optimizer y usar otro complemento para resolver este problema. En nuestro servidor utilizamos el complemento "Really simple SSL", eso resolvió el problema. Puedes descargarlo aquí: https://wordpress.org/plugins/really-simple-ssl/

Puede verificar el resultado aquí: hidden link - En nuestro servidor, el problema se ha resuelto.

Por favor dime si te funcionó.

Saludos cordiales,
Diego