Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

El problema: Mis páginas interiores no conducen correctamente a su traducción y no muestran el selector de idiomas.

La solución: Ve a Ajustes > Enlaces permanentes, y graba de nuevo tus ajustes.

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 15 respuestas, has 2 mensajes.

Last updated by Andrés hace 3 años, 7 meses.

Assigned support staff: Andrés.

Autor Mensajes
enero 4, 2017 a las 1:51 pm #1174341

angelR

I am trying to: Mostrar traducciones en páginas interiores

URL of (my) website where problem appears: hidden link (el segundo idioma está oculto)

I expected to see: traducciones en interiores

Instead, I got:

Steps to duplicate the issue:

enero 4, 2017 a las 3:57 pm #1174529

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido de nuevo!

Desafortunadamente como tu segundo idioma está oculto no puedo verificar este comportamiento, pero tal vez me puedas dar más detalles. ¿Lo que quieres decir es que la traducción de las páginas genera un error 404? Tal vez algunas capturas de pantalla me ayuden a entender mejor.

1. ¿Podrías actualizar tu versión de WordPress?

2. ¿Podrías revisar si existe algún error?

Sería genial si me puedes suministrar la información del debug.log de WordPress. Por favor, lee estas instrucciones:
https://wpml.org/documentation/support/debugging-wpml/

Por favor abre tu archivo wp-config.php y busca la línea que dice: define(‘WP_DEBUG’, false);. y cámbialo por:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Luego busca en la carpeta /wp-content/ y mira si existe algún archivo debug.log.

Si puedes agregar la información del debug.log en pastebin.com y proveerme el link sería aún mejor (Es la manera más limpia porque algunas veces los logs pueden ser muy largos y la conversación se puede volver desordenar mucho).

Un saludo,
Andrés

enero 5, 2017 a las 9:24 am #1175071

angelR

Hola de nuevo Andrés.

01. WP actualizado a la última versión
02. Debug aplicado. Puedes consultarlo en http://pastebin.com/fdsV58Qc

Adjunto pantallazos para que veas lo que sucede (por el nombre del archivo entenderás qué se muestra). El caso es que en esta web, como el ESP ya está online, no puedo activar públicamente el segundo idioma.

En las páginas interiores además estoy usando para los widgets interiores el componente vuestro MULTILINGUAL TEXT y no funciona bien (en la Home sí).

Con este mismo tema tengo un wordpress funcionando con WMPL en otro dominio...

Si te sirve de ayuda, puedo darte acceso al WP y así ves en directo el segundo idioma.

Ya me dices! Gracias!

enero 5, 2017 a las 9:48 am #1175105

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias, de la información de debug de WordPress todo parece en orden, o por lo menos no existe ningún error relacionado con WPML.

Si entiendo bien, el problema es que el selector de idiomas no aparece en las páginas interiores, ¿es este el caso?

Si es así:

1. ¿Podrías actualizar tu tema RT-Theme 18 a la versión v 1.9.7.1 ya que lleva casi 2 años sin actualizaciones?
hidden link

Si esto no funciona, me podrías decir si:

2. ¿Están tus página interiores traducidas?

3. ¿Cómo agregaste tu selector de idiomas? ¿Has intentado con una opción nativa de WPML en WPML > Idiomas?

4. Podrías revisar que esta situación se presenta cuando:
- Todos los plugins no relacionados con WPML están desactivados. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Saludos

enero 5, 2017 a las 9:55 am #1175113

angelR

Hola,

No es el selector, sino el menú. Si te fijas (cambia poco porque es Catalán y Castellano que se parecen) pero en la Home me muestra el menú (la franja de Empresa, Productos...) en el idioma que corresponde pero no en las páginas interiores.

Los plugins, desactivando todos me sucede igual.

Las páginas interiores están sin traducir pero he cambiado alguna palabra y no se modifica, me muestra ESP siempre.

El tema, no lo he actualizado pero es lo único que me queda por probar de lo que comentas.

enero 5, 2017 a las 10:18 am #1175142

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Creo que finalmente puedo ver lo que sucede.

1. Ve a WPML > Languages y mira que la siguiente opción esté marcada:
- Make themes work multilingual
x Adjust IDs for multilingual functionality

2. ¿Podrías por favor actualizar tu tema?

enero 5, 2017 a las 10:22 am #1175144

angelR

Hola Andrés.

Esta opción que comentas ha estado marcada siempre, sí.

El tema, estoy hablando con Themeforest porque no aparece en mi panel de descargas aunque la descargué tiempo atrás.

En cuanto tenga el tema actualizado, te digo.

enero 5, 2017 a las 10:37 am #1175160

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Ángel,

Si tienes algún problema con la actualización (aunque no es una buena práctica), trata de probar si el menú se visualiza correctamente con un tema por defecto de WordPress.

Saludos

enero 10, 2017 a las 6:28 am #1178083

angelR

Hola Andrés.

Actualicé el tema pero el problema persiste. De hecho, he vuelto a la versión anterior porque había modificado muchos CSS y no tenía así que volver a modificar.

Alguna idea? Quieres que te facilite acceso?

enero 10, 2017 a las 7:25 am #1178106

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Ángel,

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

enero 10, 2017 a las 9:31 am #1178251

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Desafortunadamente como no se trata de un sitio de prueba y como el plugin Duplicator no funciona correctamente, debo solicitarte una copia completa de tu sitio para continuar el trabajo localmente.

EL próximo mensaje será privado para que puedas agregar un enlace descargable.
Saludos

enero 10, 2017 a las 9:46 am #1178269

angelR

Me mandarás un link a un panel para pasarte el enlace Andrés?

enero 10, 2017 a las 10:14 am #1178301

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

No, la idea es que agregues el enlace en cualquiera de los mensajes privados anteriores o en el próximo si así lo deseas.

enero 10, 2017 a las 10:49 am #1178351

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Afortunadamente la solución fue simple. He ido a Settings > Permalinks y los he guardado de nuevo. Esta acción ha generado los enlaces que faltaban para tus páginas interiores.

¿Soluciona esto tu problema?

Saludos

enero 10, 2017 a las 11:57 am #1178425

angelR

Perfecto! Es tal cual eso lo que necesito. Muchísimas gracias por el soporte y un saludo.