Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 7 respuestas, has 2 mensajes.

Last updated by jaimeF-5 hace 3 semanas, 5 días.

Assigned support staff: Andrés.

Autor Mensajes
septiembre 16, 2019 a las 10:58 am

jaimeF-5

Al activar WPML, mi menú de BP no incluye shortcodes de usuario

Por ejemplo:
Sin WPML el enlace en un menú es

hidden link

(creado con hidden link)

con WPML el enlace es

hidden link

* WPML no incluye en el menu el shortcode de #userprofile y no termina mostrando la pagina correctamente.

*Incluyo screenshots de url sobre la misma página con WPML activado y desactivado.

septiembre 16, 2019 a las 2:33 pm #4581427

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

He estado revisando tu sitio y se puede tratar de un problema de compatibilidad con tu tema Kleo. Por esta razón he creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tu tema Kleo y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

Un saludo,
Andrés

septiembre 16, 2019 a las 2:49 pm #4581639

jaimeF-5

Hola Andrés.
Gracias por tu respuesta.

He instalado el tema y los plugins necesarios y creo que el problema se reproduce.
Por favor, comprueba el Menú y mira la página creada "Prueba perfil".
Tiene añadido el shortcode, pero al cargar la pagina, desaparece de la url.

septiembre 16, 2019 a las 3:21 pm #4581953

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tu ayuda, Jaime. Aquí mis resultados:

- Si entiendo bien, la idea es agregar esto dentro del menú personalizado

##profile_link##/prueba-perfil-con-shortcode/

- Con WPML cuando hago click en el enlace me manda aquí:
hidden link
- Sin WPML produce un error 404

Cuando hago hover sobre el enlace, veo un error, un doble // en la URL (captura de pantalla). ¿Me podrías ayudar a corregirlo ya que sucede tanto con WPML cono sin este?

Saludos

septiembre 16, 2019 a las 4:38 pm #4582675

jaimeF-5

Hola Andrés.
Sinceramente no sé cómo ayudarte a corregir esto.
Es el sistema que tiene Kleo y aunque es verdad que se ve una doble // el resultado es correcto.

Sobre el problema que comentas y para reproducir el problema completamente he instalado el plugin "Custom BP Menu Pro", que posibilita crear un menú específico dentro del Perfil de BP.

Una vez hecho esto, he creado:
- Una página con custom link a la página "Settings". -> De este modo, puedes ver que tanto "settings" como "Settings custom link" van al mismo lugar, sin problema.

- Una página estándar ("Prueba de perfil"), dentro del perfil de BP (esta página albergaría en mi web de producción la sección de "localizaciones").

A mi me funciona sin problema, tanto con WPML como sin él.
Espero tu feedback.
Gracias!

septiembre 17, 2019 a las 8:59 am #4586661

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

¡Muchas gracias por tu ayuda Jaime! 🙂
En el sitio de prueba funciona correctamente, así que tal vez existe alguna interferencia con otro plugin en tu sitio. ¿Nos podrías dar acceso a tu sitio de pruebas?

Saludos

septiembre 17, 2019 a las 9:17 am
septiembre 17, 2019 a las 3:35 pm #4589759

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias de nuevo, Jaime. He seguido revisando tu sitio de prueba:
- Desactivé todo lo que no interviene para evitar interferencias.
- Agregué un nuevo enlace "WPML link" al menú con la URL "##profile_link##/settings".
- Este enlace funciona correctamente.

Como puedes ver, no estoy muy familiarizado con la creación de estos enlaces permanentes que permite tu tema Kleo.

¿Me puedes decir cómo configuras la página "##profile_link##/mis-localizaciones/"? ¿Acaso debe existir algo previamente?

Saludos

septiembre 18, 2019 a las 3:29 pm #4598161

jaimeF-5

My issue is resolved now. Fucking BP!