Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 1.71 hours from now. Thank you for your understanding.

Etiquetado: 

This topic contains 5 respuestas, has 2 mensajes.

Last updated by Diego Pereira hace 5 meses, 2 semanas.

Assigned support staff: Diego Pereira.

Autor Publicaciones
abril 30, 2019 a las 3:42 pm

practicB

Estoy tratando de: Hacer que funcione mi sitio web con traducción al Catalán

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: hidden link
En vez de eso, obtuve: hidden link

No me funcionan los Enlaces permanentes con Nombre de Entrada. Si elijo esta opción todos los enlaces del menu me llevan a contenidos en catalán.

Tan solo si selecciono el Enlace Permanente "Simple" lleva a los contenidos adecuados tanto en castellano como en catalán.

mayo 1, 2019 a las 3:08 pm #3718711

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola @practicb, Bienvenido al foro de soporte de WPML!

Qué ocurre exactamente? Guardar los permalinks funciona, pero los enlaces apuntan a la página incorrecta?

Por favor, active WP_Debug, WP_Debug_log y WP_Debug_Display en su sitio web, mostrará más detalles sobre el error: https://wpml.org/documentation/support/debugging-wpml/ - e.g.

define ('WP_DEBUG', true);
define ('WP_DEBUG_LOG', verdadero);
define ('WP_DEBUG_DISPLAY', true);

Después de eso, intente guardar los permalinks de nuevo y ver si algún error se muestra en la pantalla o agregado a debug.log (que se generará en apsta wp-content). Si es así, por favor envíen un screenshot del error.

Si el error continúa, por favor instale estos plugins en su sitio web:
Duplicator: https://wordpress.org/plugins/duplicator/
File Manager: https://wordpress.org/plugins/wp-file-manager/
All-in-one WP Migration hidden link
Adminer: https://wordpress.org/plugins/ari-adminer/

Me permitirán crear una copia del sitio web si es necesario.

Saludos,
Diego

mayo 3, 2019 a las 8:49 am #3732331

practicB

Buenos días, gracias por su respuesta.

Es muy fácil reproducir el error.

Tan solo tienes que entrar en la Administración de WordPress. Ajustes / Enlaces Permanentes
seleccionar enlaces del tipo "Nombre de la Entrada" en vez de "Simple"
Posteriormente vas a comprobar desde la navegación por el Front como todas las páginas en Castellano dan error y la URL se muestra en catalán.
Te repito las claves de acceso a la administración para que puedas hacer comprobaciones insitu.
[content removed]

En las imágenes que adjunto se comprueba como pulsando en la opción Correos (Estando en la versión castellana) se intenta reproducir una url en catalán y produce error.

Espero que sea suficiente. De lo contrario tendremos que probar el Debug.

mayo 3, 2019 a las 5:16 pm
mayo 3, 2019 a las 5:19 pm #3737251

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Envié algunas instrucciones para replicar el sitio web a través de un mensaje privado (respuesta anterior).

Por favor dígame si funcionó.

Saludos cordiales,
Diego

mayo 4, 2019 a las 7:47 am #3739497

practicB

Buenos días,

Ya está realizada la copia del sitio en BlogVault.

hidden link

Y efectivamente el problema-error con los enlaces a las páginas del menú se reproduce como en la página original.

Si tenemos seleccionado Enlaces Permanentes en Nombre de entrada. La versión en Castellano no funcionará, las URL que muestra el Menu del sitio web cuando se pulsa cualquier opción aparecerá en catalán y el navegador dará error.
Pero si se elige la opción SIMPLE entonces funciona la web correctamente pero con enlaces del tipo practicbcn.com/?p=123

Espero que podáis observarlo y dar con la solución. Necesitamos resolverlo urgentemente ya que Google nos puede penalizar por encontrar en sus tablas URLs inexistentes.

Gracias

mayo 6, 2019 a las 5:07 pm #3751363

Diego Pereira
Supporter

Languages: Inglés (English ) Español (Español ) Portugués, Brasil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Desafortunadamente la migración parece no haber funcionado, al acceder al sitio web me dirigen a la pantalla de instalación de WordPress.

Hice login ahora ebsite utilizando s credenciales del primer post y he creado un paquete del duplicador. Con eso, conseguí crear una copia en mi servidor local para probar.

He hecho algunas pruebas y aparentemente el problema se debe a un problema de slug en la página de correos y también el conflicto entre YOAST y el "No category base para WPML" (los dos tienen una feature parecida, por lo que se recomienda utilizar sólo uno de ellos).

He resuelto en mi servidor local utilizando los pasos siguientes:
- Deshabilite el plugin "No Cateogry base para WPML"
- Vaya a WPML> Idiomas> Formato URL del idioma y seleccione Distinguidos idiomas en los directorios
- Vaya a Settings> Permalinks y re-guarde la estructura de Permalinks

Compruebe que el problema continúa. Si es así, pruebe el paso siguiente para solucionar el problema en la página "Correos":
- Ir a Pages> Todas las Páginas
- Edite la página (Correos) en el idioma original
- Modifique el slug de la página (en mi instalación utilicé el slug "academia-correos-barcelona-test")
- Salve
- Actualice la traducción
- Vaya a Settings> Permalinks y re-guarde la estructura de Permalinks

Después de eso los enlaces funcionaron normalmente en mi sitio de pruebas: hidden link

Por favor dígame si funcionó para usted.

Saludos cordiales,
Diego