Skip Navigation

1. Every website will benefit from updated software and simple cache. Start by reviewing our recommendations for avoiding performance issues.

2. If your site still feels slow, we recommend that you check what's the reason. Follow our tutorial on debugging performance issues.

3. After this debug, if you see that WPML is starring in the load report, please let us know so that we can troubleshoot and resolve it.

Status Topic
Supporter Voices Posts Freshness
Wpml Performance

Started by: Anna Pantelakaki in: English Support

2 2 1 week, 5 days ago

Mateus Getulio

Performance Issue

Started by: zolM in: English Support

2 14 1 week, 6 days ago

Mateus Getulio

Llamadas a admin-ajax de BuddyPress multilingual agotan recursos del servidor

Started by: sebastianT-2 in: Soporte en español

2 6 2 weeks, 1 day ago

Alejandro

Image duplication question

Started by: glassW in: English Support

2 3 3 weeks, 4 days ago

Mateus Getulio

Unable to load WPML, activate it gives error 500

Started by: Fernando in: English Support

2 14 2 months ago

Fernando

Site in CDN: WPML changing SITEURL load files from local host instead of CDN

Started by: plataformaE in: English Support

2 14 2 months, 1 week ago

Bruno Kos

Fatal error after WPML update 1 2 3

Started by: violaH-2 in: English Support

2 35 2 months, 2 weeks ago

Raja Mohammed

500 server error when using translation management

Started by: frodeH in: English Support

3 10 2 months, 2 weeks ago

Bigul

My Worpress site (backend + frontend) is loading very slow 1 2

Started by: thomasW-84 in: English Support

2 30 2 months, 2 weeks ago

Bigul

js URL not versionized

Started by: nielsM-2 in: English Support

2 7 2 months, 3 weeks ago

Lauren

Reply to my previous thread about WPML slowing down my website 1 2 3

Started by: ricardoA-9 in: English Support

2 41 2 months, 3 weeks ago

Lauren

I need help for how can optimize WPML tables on mysql DB

Started by: sandipK-2 in: English Support

2 2 2 months, 3 weeks ago

Mihai Apetrei

Elementor Maintenance mode not working when WPML Multilingual CMS is activated 1 2

Started by: marcL-35 in: English Support

9 17 3 months ago

Laura

Error in secondary language of the site

Started by: zajzonB-2 in: English Support

2 3 4 months, 1 week ago

Mateus Getulio

Site goes slow and takes a lot of CPU – What to do?

Started by: fredrikS-7 in: English Support

2 2 4 months, 4 weeks ago

Osama Mersal