This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by antonioN-12 3 months, 2 weeks ago.

Assigned support staff: Andrey.

Author Posts
July 1, 2019 at 2:13 pm #4120089

antonioN-12

I am trying to:
Андрей, здравствуйте!
Когда в русской и испанской версиях в строке поиска главной страницы выбираю пункт аренда и нажимаю поиск, место запрашиваемой информации по всем к примеру недвижимостям с категории аренды в языке, который выбран идет переход на английскую версию и отображается и аренда и продажа вместе(вместо запрашиваемой только аренды на нужном языке). Я так понимаю, что это опять проблема в переадресации по ссылкам, но где именно понять не могу, переводы проверила везде есть(перевод таксономии). Надеюсь на Вашу помощь, потому что поиск на русском и испанском вообще правильно не работает, даже если больше параметров добавить в фильтр
Link to a page where the issue can be seen:
меню поиска тут hidden link

I expected to see:
когда выбираю тип услуги - аренда - поиск идет переход на английский вместо русского со всеми объектами,которые в аренде
Спасибо!

July 2, 2019 at 9:27 am #4125325

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Здравствуйте,

Да, скорее всего это проблема в переадресации по ссылкам.

Первое, что Вам нужно попробовать это перейти Settings >> Permalinks и нажать кнопку "Save changes".

Если это решение Вам не поможет. Не могли бы Вы предоставить мне временный доступ (WP-администратора и FTP) на Ваш сайт - предпочтительно к тестовому сайту, где проблема была воспроизведена, если это возможно - для того, чтобы лучше помочь. Вы найдете необходимые поля ниже поля для комментариев, когда Вы войдете, чтобы оставить свой следующий ответ. Информацию, которую Вы ведете является частной, что означает только Вы и я могу видеть и иметь доступ к ней.

July 4, 2019 at 11:30 am #4142795

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Добрый день,

Я проверил Вашу проблему и нашел решение.

- Вам нужно войти в wp-admin и перейти в WPML >> Languages, затем перейдите к "Language URL format". Выбрать "Different languages in directories" и сохранить.

- Вам будет показана ссылка для «повторного сохранения постоянных ссылок сайта» (это ссылка на «Settings» >> «Permalinks»). Нажмите на эту ссылку, затем прокрутите вниз до нижней части страницы и нажмите «Сохранить изменения». Вам не нужно вносить какие-либо изменения, просто повторно сохраните.

- Вернитесь на свою домашнюю страницу, выберите Русский или Испанский язык и нажмите «Поиск».

Пожалуйста, дайте мне знать, помогло ли Вам это решение.

July 4, 2019 at 12:06 pm #4143019

antonioN-12

Спасибо огромное! Все работает, сделала, как Вы сказали и произошла "магия" ))), переходы по ссылкам заработали, очень рада и очень Вам благодарна!