This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Dennis 5 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
February 21, 2019 at 1:55 am #3224255

adrienL-12

I am trying to: Translate my French pages to English

Link to a page where the issue can be seen: hidden link

I expected to see: Gallery

Instead, I got: Galerie photo

This is just an example. But it happens all over the site. Some pages are not translated at all. Even though they are 100 complete. In the string translation it says the translation needs update.

February 21, 2019 at 8:19 am #3225610

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

#1

Please increase the PHP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:
https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define('WP_MAX_MEMORY_LIMIT', '256M');

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

#2
Could you please try the following steps and check if the issue still exists. Please make sure to make a complete backup of your site before proceeding.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

Please also clear all your caches (e.g. browser, server, plugin..etc.)

-edit the page having issues. edit it on the original language.
-make a small change on one of the button text. click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages completely. Save and close.

Does it help? Please let me know how it goes.

Kind regards,
Dennis

April 5, 2019 at 10:45 pm #3547277

adrienL-12

Hello Dennis,

thank you for your help.
The steps you provided didn't help.

There still must be a conflict somewhere.

Please see the image attached.

Look:
In the page translation it says the page is 100% complete.

BUT, when i go to String Translation (image attached), it says "Translation needs update". And when I click on the "translations" link, then the English translation appears but the checkbox "Translation is complete" is UNCHECKED.
There is clearly an incoherence. Because Page says 100% complete and String Translation says not complete.

If i then check the checkbox, then it finally works. But i can't go through all the pages and string manually like this. There is a problem with the plugin and i would like you to provide me with a global solution.

Best regards,
Adrien

April 8, 2019 at 3:00 am #3553697

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I noticed that your WPML plugin is quite outdated.

We have recently released new updates for WPML plugins. Please consider updating WPML plugins. You can update them at Plugins > Add new > Commercial Tab

Note: Please secure a complete backup of your site before updating WPML plugins.

If the issue still persists, I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

April 12, 2019 at 10:22 pm #3602343

adrienL-12

Hi there, ok I'll do this and will come back to you asap. Thanks

April 14, 2019 at 3:42 pm #3608347

adrienL-12

Hi Dennis,

Can you please send me again the "form" I have to fill with the access codes etc. ?

Thanks!

April 15, 2019 at 1:16 am #3608911

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I have re-enabled the access information box now.

Thanks.

Kind regards,
Dennis

April 16, 2019 at 8:50 am #3620071

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I have successfully built a duplicator package and I will download a copy and try deploy it on my local machine. Then I will continue debugging your site locally and will give you feedback when I got some results.

Kind regards,
Dennis

April 17, 2019 at 7:27 am #3627709

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Could you please try this steps to refresh translations?

-edit the page having issue, edit in default language.
-click 'Update'
-click 'Update English Translation' (refresh icon)
-translate completely.
-Save and close

I have attached an image for your reference.

Kind regards,
Dennis

April 17, 2019 at 11:18 am #3630073

adrienL-12

Hi,

what you're asking me to do is the same as you asked me in your reply #3225610.
As i answered you in my reply #3547277, these steps didn't work.
Anyway i tried again and of course it sill doesn't work.

Please see my hints in my reply #3547277. I had found a kind of way out of it. But it's bug of WPML and i can't do all the pages manually. I need this to be fixed.

Could you please find a solution ? I just bought your product for the first time and it's still not working. My business depends on it.

Kind regards,
Adrien

April 18, 2019 at 9:19 am #3637613

adrienL-12

Hi,

the migration is completed.

In the migration form there was no field to enter the DB password though.

Kind regards,

Adrien

April 22, 2019 at 2:33 am #3653471

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I have checked your site on our test server. However, on the test server I was able to resolved the issue by following the steps I have provided on my previous message. I have tried it for the the homepage and now it show the English translations.

hidden link

It seems that the issue could be related to server configuration. I will consult our 2nd tier support about this issue and will update you here as soon as I got feedback from them.

Kind regards,
Dennis

April 22, 2019 at 6:33 am #3654031

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your patience.

I got a feedback from our 2nd tier support team. They checked that you're using OVH hosting and they think that the issue could be related to server cache. We suggest as a possible workaround to either disable cache from your server or try to create a new page and test if the issue repeats itself that way.

Please let me know how it goes.

Kind regards,
Dennis

April 22, 2019 at 11:22 am #3655411

adrienL-12

Hi Dennis,

I contacted OVH hosting and there is no server cache on my hosting plan. So this is not the issue.

I created a new page as you suggested and the problem persists:
The new page is: hidden link
You will see that when you click on English in the language switcher, the English translation doesn't show. It's still in French.

Please provide me with a solution. I bought WPML because it was stated that is was compatible with Divi.

Please see my reply #3547277, maybe there is a hint for you guys where the problem comes from ?

In the page translation it says the page is 100% complete.
But in the String Translation it says "Translation needs update".

April 22, 2019 at 11:58 am #3655593

adrienL-12

After several back and forths the new page i mentioned above seems to be working now but the whole plugin still seems to be not working properly. I had to save, then reedit, then again save, several times until at some point it worked.

And all the other pages are still corrupted (translation wise).

Please prove a definitive solution i cannot go on like this.
I've already spent hours trying to make the translations work while it says 100% complete.