This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by erwinH-3 12 months ago.

Assigned support staff: Lauren.

Author Posts
October 11, 2018 at 9:25 pm #2809813

erwinH-3

Dear WPML support,

Back again and in need of your help on known problems in the support forum but without clear fix.

Situation:
1) This problem occurs on a production server: We have redesigned our theme and did some homepage content changes. On test environment no issues so ready for go-live. We are using a deployment so we pushed changes to production. Problem: homepage redirects to 404 page and unable to set / update the static homepage in under "reading". It doesnt matter what type of page we try to set as homepage (also once for which we have 100% translations in all languages) all fail and can't be saved. Error: "Your post doesn't exist or its translation is not published in EN, FR or NL". It also only happens when WPML is activated, if all WPML plugins are disable it works without issue.

2) After deactivating and activating the plugin we got the known error about invalid site-key back. Hence tried to register it again or renew subscription. But it fails over and over, even when updating wp_options tabel with the sitekey by removing it and retrying doesnt work. It simply repopulates the datafield.

So two issues:

1) Unable to properly register WPML with the sitekey from my account
2) Unable to set a fresh new static homepage under Settings --> Reading

Links to our previous forum posts and discussions with Lauren:
https://wpml.org/forums/topic/not-able-to-revalidate-license-or-unregister-to-add-new-site-key/page/2/
https://wpml.org/forums/topic/unable-to-revalidate-license-or-unregister-to-add-new-site-key/

Links to exactly similar problems around setting the static homepage:
https://wpml.org/forums/topic/settingsreadingstatic-home-page-cannot-save-to-other-page-it-resets/
https://wpml.org/forums/topic/i-could-not-change-frontpage-after-i-activate-wpml/
https://wpml.org/forums/topic/cannot-set-a-static-page-for-frontpage/

Actions we took for 1:
- Deleting site from WPML panel, adding a new one --> site-key the same
- Adding site-key via wp-config file --> error: "You are using an invalid site key defined as the constant OTGS_INSTALLER_SITE_KEY_WPML (most likely in wp-config.php). Please remove it or use the correct value in order to be able to register correctly.
- Updating plugins manually --> no change
- Removed sitekey from wp_options tabel and saved. No change and is NULL, after activating the plugin it auto populates the field again with the same hashed value (serialized).

Actions we took for 2:
- Trying to delete existing homepages and start from scratch with an empty homepage. Not able to set
- Trying to connect pages to other translations to ensure linkage --> not able to select as homepage
- Removed (untranslated) widgets to ensure all components are translated --> no luck
- Selecting a page with all translations available via pages (we can click the pencil as link to the translation and wordpress editor recognizes the translation) --> unable to select page to set homepage
- Basically we can't set any static homepage with WPML enabled.

Please help us out.

October 12, 2018 at 1:35 pm #2812184

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

For the site key registration, please try removing the wpml_notices from the wp_options field. Then, let me know if the message returns when you try to register it again. Be sure to make a full backup of your database before making any changes in the database.

Next, for the static page issue, please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

After this, are you able to set the homepage for your theme?

October 16, 2018 at 7:16 am #2819904

erwinH-3

Dear WPML Support,

Thank you for your feedback and we will perform the actions suggested. This is planned for end of this week as we are in the middle of a marketing blast and unable to perform the instructions now. Please keep the ticket open until next week.

Kind regards
Erwin

October 16, 2018 at 1:38 pm #2821135

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for the update. We will keep this ticket open, and you can update once you are able to run those steps.

October 24, 2018 at 10:31 pm #2847951

erwinH-3

Dear Lauren,

Getting back to you on this matter.

The second problem has been fixed by our developer team and we have been able to set the hompage back to the right version with the correct translations set while WPML is activated.

The issue with the sitekey unfortunately remains after your instructions. Exact same problem and no changes. We are unable to unregister nor revalidate our license in this installation. BTW other installations connected to our account have no issues updating and are also recognized in my dashboard with all installed add-ons.

Is the sitekey in my our account for this respective website all ok on your side?

Looking forward to your support.