Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Alejandro 2 years, 9 months ago.

Assigned support staff: Alejandro.

Author Posts
December 13, 2018 at 2:39 pm #2998271

cordulaB

Hi,

I have a little problem with redirects on the english footer. The links in the footer are sticky ones. The problem about the footer is that the links are pointing on other english sites but somehow there is a 301 redirect to the german site.

I did not do the redirects by myself.

Hope you understand my problem.

Best Regards

Jens

December 14, 2018 at 7:37 am #3000806

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

You said "The problem about the footer is that the links are pointing on other english sites but somehow there is a 301 redirect to the german site."

I have a few questions from this statement that will help me better understand this situation.

1) I suppose the problem is occurring in the English version of the footer, right?
2) Can you give me an example of one of the footer links that are not working correctly?
3) How are you adding this Footer
4) Are these links coming from a menu or did you add them manually?

I checked a few of your footer menus and some redirect to an English version of the German page and other instead redirect to German pages, but so far i haven't had any 301 redirects.

Please answer my questions, i'll know how to proceed from there.

Regards,
Alejandro.

December 14, 2018 at 2:26 pm #3002086

cordulaB

Hello Alejandro,

thanks for the fast reply.

1) yes only in the english version

2) For example if you click the english footer on the second footer item "Milling Cutters" theres a sticky link on it with "?page_id=48038" and that points to the german versions "/produkte/fraeswerkzeuge/" but we want to link in the english footer to a english page. In our particular case "/en/products/milling-cutters/".

3) we are working with a child theme. The footer is created with the divi page Builder. It is not a the common wordpress footer. In the footer.php we did an echo to give out the individual footer just on english pages.

4) we set the links manually in with ahref and they are converted into sticky ones somehow even if your plugin "sticky links" is not active.

PS: I was doing some PHP redirection to the correct pages. Those work but they dont in the htaccess. Maybe that additional information helps.

Best Regards

Jens

1.PNG
December 14, 2018 at 2:43 pm #3002160

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Yes, it definitely does.

Could you allow me access to the site and point me where you modified the footer and added the links? because it's definitely strange that they are becoming sticky if the plugin is not active, it means that something else is redirecting those links.

I activated the related fields for the credentials, they are private and accessible by only the two of us.

I'd also appreciate if you wrote down the steps needed for me to find and replicate the issue, it will certainly speed up the troubleshooting process.

Thanks in advance.

December 17, 2018 at 5:05 pm #3009604

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,
I tried accessing with those credentials but couldn't do so, would you ind checking if the password is correct or maybe change and send the passsword again.

Thanks in advance.

December 28, 2018 at 1:01 pm #3040095

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok i checked your site and i noted a few things:

1) String Translation and Translation Management are not installed/active on your site and they are required for DIVI o work correctly.

2) The ID of the footer page is 49163 and the code you added in the child theme suggests the footer is 49164 instead, which is pretty weird.

3) When i checked the English version of the footer, i get all the item names in English but its content (Divi Text module) is in German, so can i ask you how did you translate those items?

4) The sticky links will stay even if you disable the plugin, so if you created the sticky links before and then disabled the plugin, all the sticky links will stay in place so, could you tell me if you ever used the plugin?

I believe that for now, the best way to proceed in the footer is to remove the sticky links and change them to the original links in each Language, because we don't know what is creating those links and redirecting each link to the correct version (unless, Sticky Links plugin was active and was run on the site once in the past).

Regards,
Alejandro.

January 2, 2019 at 7:31 am #3048030
cordulaB

Hi Alejandro,

thank you for the help. I changed the the Links.

I think the problem was coming from 49163 / 49164. Footers but they havent been translated in WPML. They were just existing one in english and the other one in german.

I translated 49163 (the german footer )so there is an equivalent on the now for this. I have changed the links and it works.

Yes the problem with the 2 extensions is we are trying to save wait time in the server client communication and those 2 cause a lot. By disabling those "String Translation" and "translation management" we increased the page speed a lot.

Do you have me any suggestions for speeding up WPML extensions?

Best Regards

Jens

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/split-how-to-optimize-wpml/

January 2, 2019 at 7:38 am #3048036

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm glad to hear that was the problem.
I split your last answer to another ticket because we can only answer one question per ticket.

If you feel this problem has been resolved, I kindly ask you to close this ticket.

I'll check your site in the meantime to see what can be done to improve your site's performance and will answer in the other ticket i just created for you.

Regards,
Alejandro.