Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Itamar 3 years, 2 months ago.

Assigned support staff: Itamar.

Author Posts
May 10, 2017 at 4:13 pm #1273042

stfanF

I am trying to:
Setup WPML on a WordPress multisite.
The plugin worked fine locally or on our testing server.
But as soon as I activated the main WPML plugin (sitepress-multilingual-cms folder) none of our posts work.

The frontpage loads just fine but as soon as you click a post you get a 301 redirect loop from itself to itself.

I then went ahead and made a copy of the blogpage in the same multisite network (so same network environment, same server environment, same wordpress and plugin base and activated WPML in there and it works just fine.

URL of (my) website where problem appears:
hidden link

I expected to see:
The post loads just fine.

Instead, I got:
The post doesn't load and it gets stuck in a redirect loop. Uploaded an image of a copy paste from the chrome dev tools-network monitor with the plugin active.

Steps to duplicate the issue:
Activate WPML and problem is there, deactivate WPML and problem is gone.

May 11, 2017 at 10:28 am #1273687

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello, @stfanf.

Thank you for contacting the WPML support forum.

I think that something in the general setting is not set correctly.
Looking at the debug info, I can see that you have it set like this.

SiteURL hidden link
HomeURL hidden link

According to your installation does it look alright to you?

Also, I can see that you are using the Redirection plugin by John Godley.
Maybe some redirection is set on this plugin that causes that issue.
Can you check it, please?
What happens if you deactivate this plugin?
Does the problem persist?

Thanks,
Itamar.

May 18, 2017 at 11:30 am #1279110

stfanF

Hi Itamar,

this setup has it's own reasons with the different URLs which I won't explain in this semi public area for security purposes.

The redirection plugin has no rules that seem faulty. I also tried deactivating it and activating the WPML plugin which doesn't change anything about the redirects.

As soon as I deactivate WPML again it works without the redirects.

One thing I forgot to mention. We have deactivated subsites in the multisite setup that had the same slug as some of the languages we want to add.
for instance a site /de which was used for the german blog. We deactivated all those pages but could they be an issue? All those pages are deactivated so it shouldn't be a problem.

Also I have duplicated the main site entry (where the problem occurs) using the duplicator plugin.

On the duplicated subsite in the network I have activated the WPML plugin and there it works just fine.
Does this help you diagnosing the problem? Also can we move this to e-mail? I could probably share more details via mail.

Thanks,
Stefan

May 21, 2017 at 7:13 pm #1281104

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Stefan.

About deactivating the subsite which had the same slugs.
I think it might be the problem if those pages are cached.
Do you use any caching mechanism on your site or server?
Also, there might be something in the .htaccess file that might be causing it.

I'll enable private message for the next reply so you can share the details with me.
I'm sorry, but email correspondence is not possible.
If you want you can also share the access details for your site.
For this, please read and approve the following.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.
For this, I'll need to install the Duplicator plugin on your site.
https://wordpress.org/plugins/duplicator/

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Thanks,
Itamar.

May 23, 2017 at 5:27 pm #1282978

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Stefan.

I'm consulting our second tier supporter about your .htaccess file.
I'll let you know when I have an answer from him.

Meanwhile, I'm enabling private message for the next reply.

Thanks,
Itamar.

May 29, 2017 at 8:08 am #1286161

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi again, Stefan.

Our third tier says that the wp-config.php needs to be also checked, as well as any other redirection plugin or even maybe SEO plugins that have a built in redirection module.

I'm still waiting for your reply here.
Private message is enabled again.

Thanks,
Itamar.

July 2, 2017 at 6:19 pm #1310172

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

I'm sorry but I get the following when I try to access your site -> "Invalid username."
Could you please check this and correct it?
I'll enable private message again now.

July 2, 2017 at 6:24 pm #1310173

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

PM is enabled.

July 12, 2017 at 2:08 pm #1317863

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

OK, Stefan.
I think that a clean environment would be the best way to test this issue.
I'll wait for your reply.
I'm enabling private message again.

The topic ‘[Closed] 301 redirect loop on posts – ERR_TOO_MANY_REDIRECTS after activation’ is closed to new replies.