This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 30, 2018 at 7:15 am #2776257

neetuS

I was setting up wpml on my site foodyshoody.com. When i clicked on english language button it shows the below error :
403 - Forbidden Error
You are not allowed to access this address.
If the error persists, please contact the website webmaster.
If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

Common reasons for this error are:

Incorrect file/directory permissions: Below 644.
In order files to be read by the webserver, their permissions have to be equal or above 644. You can update file permissions with a FTP client or through cPanel's File Manager.

Restrictive Apache directives inside .htaccess file.
There are two Apache directives which can cause this error - 'Deny from' and 'Options -Indexes'.

I contacted the siteground support and they are saying this (this is the complete chat transcript :
Your Chat Transcript on 30/09/2018
Neetu Shukla: HI, I installed language translation plugin wpml.org on my site foodyshoody.com . I was just configuring this plugin. When i clicked on English language button on sidebar on my site it shows below error : 403 - Forbidden Error You are not allowed to access this address. If the error persists, please contact the website webmaster. If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there. Common reasons for this error are: Incorrect file/directory permissions:
Neetu Shukla: This question is related to account:foodyshoody.com
Alexander B.: Hello Neetu
Alexander B.: Welcome to SiteGround
Neetu Shukla: yes.
Alexander B.: I will gladly help you right away.
Neetu Shukla: this is the full error 403 - Forbidden Error You are not allowed to access this address. If the error persists, please contact the website webmaster. If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there. Common reasons for this error are: Incorrect file/directory permissions: Below 644. In order files to be read by the webserver, their permissions have to be equal or above 644. You can update file permissions with a FTP client or through cPanel's File Manager. Restrictive Apache directives inside .htaccess file. There are two Apache directives which can cause this error - 'Deny from' and 'Options -Indexes'.
Alexander B.: THank you very much. Appreciate it. I noticed the error when clicking on the language section as it immediately gave the 403 basically on the hidden link part
Alexander B.: Do allow me a moment on the matter to inspect all server side performances
Neetu Shukla: yes.
Neetu Shukla: ok...take your time
Alexander B.: Thank you for the wait time. As I inspected the error is usually generated when the file permissions are not set up correctly, or there are missing files in the given directory. The current folder/ files were set correctly being equal to 0755 and 0644 as permissions. However I noticed that the site is attempting to open a /en folder this folder as checked was created in the cPanel > File Manager > public_html where the website files are located. And the folder /en is set in there as a subdirectory which is empty which shows the given error.
Neetu Shukla: ok.
Neetu Shukla: can you tell me how to resolve this issue
Alexander B.: Well the main idea is to have the website to resolve with two languages, correct?
Neetu Shukla: My sites main language is hindi. Now i want to translate site into english language as well. thats why i am using wpml wordpress plugin for that
Alexander B.: Thank you. I can suggest to use a separate plugin for this performance, as the plugin itself might be causing the issue itself
Alexander B.: I have checked for some similar plugins for this performance
Alexander B.: and I haven't really used one, but here is what other users seem to be using
Alexander B.: url:hidden link
Neetu Shukla: its a paid plugin. I bought it today for this purpose.
Alexander B.: I understand, well another good option might be to upload in that case the files over at the /en folder as it is empty at the very moment. In order to resolve with a given installation. Or separately to contact the plugin developers as why the site is giving a 403 error when the plugin is enabled. On our end, I have lifted all the php variables/ and php versions for this exact purpose
Neetu Shukla: ok. i will get in touch with the developer.
Alexander B.: That is a good solution indeed
Alexander B.: If the plugin developer suggest that some server changes should be performed, please contact us back to help you with them.
Neetu Shukla: ok.thanks a lot
Alexander B.: You can as well mention to them this
Alexander B.: " The file permissions are set correctly to the right values being 0755 and 0644 "
Alexander B.: Thank you as well 🙂
System: Neetu Shukla has ended the chat

September 30, 2018 at 7:40 am #2776265

neetuS

I noticed some thing . When i change site default language from hindi to english .I click on hindi button then site showing in hindi language and this 403 - forbidden error is not showing.

October 2, 2018 at 3:35 am #2780285

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I will need to check your settings first before providing a better feedback. So, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

The topic ‘[Closed] 403 – Forbidden Error shows when i clicked on english language button’ is closed to new replies.