This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 5 voices.

Last updated by Andrey 4 years, 5 months ago.

Assigned support staff: Andrey.

Author Posts
April 10, 2015 at 11:32 am #597196

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

If you are getting a 404 error on all pages after updating to version 3.1.9.4 of WPML plugin, then most likely you have a WordPress database error like this one:

WordPress database error: [Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=']...

This happens because your WordPress and WPML database tables have different collations.

We are running relatively low level functionality on the database as some hosts like WP-Engine do.
In this case it means that strings where saved slightly differently in WPML’s tables than in the WordPress tables themselves.

We have a workaround and an automatic fix for this problem and it will be included in the next release.

How to apply a workaround:
hidden link

April 18, 2015 at 12:43 pm #601855

Danny

Very frustrating...

April 29, 2015 at 7:07 am #608436

Minna

This is really bad. How long it takes to get the next realease? It's not good that we have to go and change database to fix this.

The site I'm working on now doesn't make any menus either etc. Just 404 error.

April 29, 2015 at 11:02 am #608699

Minna

Hi! The problem seems to appear when the language is hidden even if I'm logged in. I took hidden languages off and now it works and doesn't show 404 error. Changing database had no effect in my case.
I'm using Jupiter theme and newest WP and WPML.

April 29, 2015 at 11:30 am #608723

Minna

Hidden languages work if I go and turn Display hidden languages ON at my profile settings.
But I still get 404 error when I'm trying to save Menus. I can create the menu, but I can't save it with links. This comes also when languages aren't hidden.

April 29, 2015 at 2:19 pm #608932

elianeK

Sort of the same issue here: every time I am trying to save or create a menu (even happens without me changing anything) I am getting a 404 error after clicking on Save. Hidden language or not, same error every time, cannot change or save any of my menus.

Additional info:
- WP version 4.2.1
- WPML version: latest versions
- WPML instal: all versions, Lifetime
- Theme: Divi
- Standard language: Dutch, second language: English
- I am not using a hidden language

Any idea how I can solve this? Do I need to follow the steps mentioned in the video you posted or do something else?

April 29, 2015 at 3:00 pm #608993

elianeK

Found a reply in a different post that fixes the menu issue:

Hello,

This is happening with the just released 4.2 version of WordPress.

Our developers worked this quick fix: https://wpml.org/errata/saving-menus-in-non-default-language-leads-to-404-error/

April 29, 2015 at 6:47 pm #609131

Minna

Thank you elianeK. I fixed the problem with that too.

May 2, 2015 at 3:11 pm #610569

Anne-Sophie

It fixed it for me too, thank you!

May 4, 2015 at 11:00 am #611124

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

The issue described in the initial post isn't related to the problem with saving menu.

As @elianek mentioned, you can find a workaround here :
https://wpml.org/errata/saving-menus-in-non-default-language-leads-to-404-error/

The fix will be included in the next release.

May 6, 2015 at 6:47 am #612793

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

It should be fine with a current version of WPML plugin.