Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 31 replies, has 5 voices.

Last updated by Martin Pavlicek 4 years ago.

Assigned support staff: Ankit.

Author Posts
August 19, 2016 at 5:53 pm #1011276

Martin Pavlicek

I'm trying to visit translated pages, while I'm using WPML in different domains. Instead, I get a 404 page. I tried updating Permalinks, change slug in String Translations, update pages...

The weird thing is, some pages are working and some not. The main domain works perfectly. All WPML are up to date.

Working:
hidden link

404 error:
hidden link

Thanks for the help.

August 20, 2016 at 12:17 pm #1011801

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,

Over the weekend we have a limited number of supporters, so the wait times are longer. It may be that we'll be able to help you resolve the issue on Monday morning (EU time).

Please know that we do handle the tickets in the order they are received in our system.

Thanks for your understanding and patience.

August 20, 2016 at 5:26 pm #1012033

Martin Pavlicek

Hello Yvette,

thank you for reply. I will wait.

August 22, 2016 at 3:46 am #1012709

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I am Shekhar from WPML support and I will help you further on this issue.

Since, some of the pages are working and some pages aren't as you described, I would like you to check first If this a compatibility issue or not, to do so please check if this issue appears when

#1
All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.

#2
Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.

I look forward to your reply.

Thanks

August 22, 2016 at 11:41 am #1013712

Martin Pavlicek

Hi Shekhar,

thanks for help.

1) All non-WPML plugin disabled - translated pages still not working.
What is important:
When the WPML Multilingual CMS plugin is disabled, translated pages work fine.

2) I changed theme to Twenty Fifteen - it didn't help.

What else I tried and it didn't help:
- WPML --> Support --> Troubleshooting --> "Remove ghost...", "Fix collation..." etc.
- WPML --> Support --> Troubleshooting --> "Reset"
- flush_rewrite_rules(false);

The translated pages stopped working suddenly last week, before it had worked fine.

August 22, 2016 at 5:13 pm #1014438

Martin Pavlicek

When I switch to "Different languages in directories", then the translated pages works as expected.

When I switch back to "A different domain per language", I can see 404 error again.

August 23, 2016 at 2:12 am #1015049

Martin Pavlicek

Hi Shekhar,

I was able to make some progress.

I found out that the problem with 404 error on translated pages is caused by Yoast SEO plugin. I deactivated the plugin and since then everything works.

Can you please look at this, why is this happening? There must be some compatibility issue.

I definitely want to use this plugin to generate sitemaps for every language and Title + Description for Pages.

Thanks.

Martin

August 23, 2016 at 3:45 am #1015091

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Would you mind providing me login details, so I can have a quick lookup? I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

I look forward to your reply.

Thanks

August 23, 2016 at 10:57 am #1015902

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Since the Yoast plugin is already deactivated would you mind activating it so I can test the issue, or would you mind if I create a duplicator file to clown the site on my localhost to test it?

I look forward to your reply.

Thanks

August 23, 2016 at 11:34 am #1016066

Martin Pavlicek

Please feel free to create a copy of the site on localhost.

Thanks!

August 23, 2016 at 3:29 pm #1016977

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

While I try to open your site, it shows the current error? could you please check it?

Parse error: syntax error, unexpected end of file in /home/enviro61/public_html/wp-config.php on line 57

I look forward to your reply.

Thanks

August 23, 2016 at 6:51 pm #1017777

Martin Pavlicek

Hi Shekhar,

sorry, it's OK now.

Please try it again.

August 23, 2016 at 6:55 pm #1017780

Martin Pavlicek

Please activate the private message window.
The test site is prepared, I will give you the credentials.

Thanks.

August 24, 2016 at 2:49 am #1018153

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

I have enabled the private reply for you again.

I look forward to your reply.

August 24, 2016 at 9:23 am #1018742

Martin Pavlicek

I can't see private reply.

Can you please check again?