This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am getting a 404 error for all hotel room pages in English when using the HotelBooking theme.

Solution: Make sure that the rooms text is not translated in the PO file. This seems to be breaking the rooms links.

This topic contains 21 replies, has 2 voices.

Last updated by pabloo-14 2 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
July 31, 2019 at 9:30 am

pabloo-14

I am trying to:

Link to a page where the issue can be seen: hidden link
hidden link

I expected to see: pages translated to English

Instead, I got:

1. On one of the pages I get a 404 error (Screen Shot 2019-07-31 at 11.23.01).

2. On another page the hotel content appears translated but the rest appears in original language (spanish). (Screen Shot 2019-07-31 at 11.22.15)

I suspect it may have something to do with strings, but have not been able to figure it out.

July 31, 2019 at 9:38 am #4313343

pabloo-14

UPDATE. Please disregard point 2. I am getting a 404 error for all hotel room pages in english. Thank you.

July 31, 2019 at 2:03 pm #4315091

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for reaching out the WPML support!

It's a bit strange that only the hotel rooms are the ones having this issue. Can you tell me if this way ever working, please? I'm just trying to see if there's any recent change you've made that caused this issue so I can think what we can do to get it back to normal.

As I can see, there are a couple hotel rooms added and translated so I'm thinking that maybe this was working in the first place. As I can see, these elements are made by the ND Booking plugin so I'm gonna see if there are other users that tried to use it with WPML.

Thanks,
Radu

July 31, 2019 at 2:11 pm #4315177

pabloo-14

Hello, thank you for your quick reply.

The spanish (original language) has always worked. We added the english translation afterwards and it has never worked. The ND Booking plugin works by creating rooms, which are assigned to "branches" of hotels. I have a) translated each room to eng b) translated the branch to eng c) assigned the eng hotel room translations to the eng branch. These are called by a widget on the "rooms" (eng) page which calls out all (eng) rooms associated to an assigned (eng) branch. Hope I made sense.

Thank you.

August 1, 2019 at 6:43 am #4319051

pabloo-14

Good morning, I am really pressed for time to resolve this issue.

Thank you for your assistance!

August 1, 2019 at 8:25 am #4319693

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for your explanation. Now I understand how the rooms and branches work. As I can see, the only hotel in English - hidden link - displays all the rooms under the Our Rooms section and these should be accessible by pressing the Book now button. Can you translate this branch to Spanish and tell me if the translation of the rooms are displayed well too, please?

As you can see here https://wpml.org/documentation/theme-compatibility, the theme that you're using is not a part of our WPML compatible themes list so there might be some issues. In this case, is there any chance that you could send me the theme archive so I can install it on my website and try to create some rooms and branches to see how things work? This way I can see if there's any "special change" that need to be done in order to have things work fine.

Thanks,
Radu

August 1, 2019 at 6:56 pm #4324853

pabloo-14

Hello Radu,

I tried as you advised. Translating the page you mention above and NO LUCK. Still a 404 when trying to access the rooms in eng. What service should I use to send you the theme .zip.

Thank you

August 1, 2019 at 9:09 pm #4325223

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

You can upload the theme to Google Drive or Dropbox and just send me the download link here. The links are not public visible so only you and I will be able to access it.

Thanks,
Radu

August 2, 2019 at 8:55 am #4328287

pabloo-14

Hello again. Here is the link.

hidden link

I look forward to hearing from you.

Thank you

Pablo

August 5, 2019 at 12:30 pm
August 6, 2019 at 11:10 am #4346691

pabloo-14

I am running into the same problem. I cannot view the new room. The template has been updated since we began this thread. I will contact the theme creators once again and get back. Thank you

August 6, 2019 at 11:29 am #4346771

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Pablo,

Thank you for reaching out the theme author. Please keep me updated about this.

Regards,
Radu

August 7, 2019 at 10:54 am #4354059

pabloo-14

Hello Radu,

I thought that I resolved the issue. Now the ENG works but the SPANISH (original language) does not. Very strange.

On the sandbox site, I reset the permalinks and all works well now.

Thank you once again.

Pablo

August 7, 2019 at 12:35 pm #4355049

pabloo-14

Upon reviewing, these are my current conclusions.

On my site, the URLS are as such:
ENG: hidden link
ESP: hidden link ERROR

Where as on the sandbox site:
ENG: hidden link
FR: hidden link

The difference is that the string "/rooms" is translated on my site (/habitaciones), but not on the sandbox site. This is where I think the problem is. Could this have to do with a setting? On both sites, the option "make rooms translatable" is selected.

August 8, 2019 at 1:47 pm #4363411

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Pablo,

Great finding about the /room/ part that's not translated on the sandbox. Can you tell me how did you translate this part of the URL on your website, please?

Thanks,
Radu