Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Tia 3 years, 7 months ago.

Assigned support staff: Tia.

Author Posts
March 25, 2016 at 3:37 pm #846151

mirko

I am trying to:the problem is that if i search, for example the word "ciao" from english version of site, instead of being redirected here hidden link
im redirected here hidden link

URL of (my) website where problem appears: hidden link

I expected to see:

Instead, I got:

Steps to duplicate the issue:

March 27, 2016 at 3:23 pm #846567

Tia

Hello. Thank you for contacting WPML Support. I am happy to help you with this.

It seems the search form needs an extra parameter.

Here is an explanation:
https://wpml.org/documentation/support/creating-multilingual-wordpress-themes/search-form/

To add, use wpml_add_language_form_field:
https://wpml.org/wpml-hook/wpml_add_language_form_field/

Example:

do_action( 'wpml_add_language_form_field' );

This will need to be added to the search form.

Please let me know if this resolves your issue or if you still need help.