Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 15, 2021 at 10:53 am #8543781

kristofD-6

404 on categories after a while

April 15, 2021 at 11:08 am #8543943

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

This is the ticket - let us know about your findings, whether the workaround works properly and the issue is not there no longer after using it.

Regards,
Bruno Kos

April 19, 2021 at 10:02 am #8570399

kristofD-6

Hi. Today I tried to implement a solution. The advised function related to .htaccess. But on our sites .htaccess never changed. Also, I try to add flush_rewrite_rules( false ) (for soft refreshing the rules only in the database) and see that it's broke the category permalinks. When I do it on the Dutch blog - this break permalinks on French and vice versa. I checked the plugins that we use. There is three places (WPML, YOAST, and Core of WordPress ) use the "flush_rewrite_rules" function.

April 20, 2021 at 7:31 am #8578051

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for the information. Unfortunately, at the moment we do not have enough information to go forward.

It might be related to one of the plugins or a server-related setting.

For the plugins I suggest that you follow the steps below:

- Create a backup of your website. You can use backup tools from WordPress: https://wordpress.org/plugins/tags/backup/
- Go to "WordPress Dashboard > Plugins" and deactivate all plugins except WPML and its add-ons.
- Check if you can still recreate the issue.
- If not, re-activate your plugins one by one and check the issue each time to find out the plugin that causes the problem.

If the problem persists, it might be a server-related issue and it can be tested by duplicating your website to our server and do the test there to see if the same 404 issue happens or not.

Kindly, get back to us with the result of the plugin conflict test and if you are interested in the website duplication for checking.

Thank you.

April 20, 2021 at 3:07 pm #8583209

kristofD-6

Hi there.
I made 4 tests.
1) I disabled all plugins and leave only WPML - all works correctly and after flush_rewrite_rules() works correctly both sites too( dutch and french language of blog);
2) I enabled all plugins exclude YOAST plugins - all links still work correctly. After run flush_rewrite_rules() too.
3) I enabled YOAST plugins and disable "REMOVE CATEGORY PREFIX" function, that remove category base from URL - all links still works correctly.. After run flush_rewrite_rules() too.
4) I enabled "REMOVE CATEGORY PREFIX" function. After resaving permalinks - all looks like good. But after flush_rewrite_rules() category links are broken.
That's not an option to put category back in URL for us. So i need your help to understand how fix this bug.

April 21, 2021 at 10:38 am #8589661

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for your detailed investigation. That rang a bell and I found this known issue:

https://wpml.org/errata/yoast-seo-stripping-category-base-not-working-when-the-taxonomy-slug-has-been-translated/

From the known issue and the internal report, this was fixed already and working with the latest version of Yoast.

Now, the fact that you use Yoast Pro might have something to do with the issue. Would you please kindly test that with the original Yoast plugin?

If the same issue happens there then it might be a regression of the issue and I will need to report this.

Waiting for your test with the latest version of the Yoast plugin (not Yoast Pro)

Thank you.

April 22, 2021 at 9:52 am #8599225

kristofD-6

Hi there.
I did the experiment again but with the Yoast plugin (v 16.1.1), not Yoast Pro. The results the same. Only when I enable "category base", all start works correctly.
I also try to remove the "category base" by the "No category base WPML" plugin, but I have the same effect.

April 25, 2021 at 10:42 am #8617547

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you very much for the information. To make sure that I can report this to the compatibility team we need to replicate the issue in a clean installation to see if this is an environment-related thing or the WPML codebase issue.

I created a clean installation of WordPress, WPML, and all necessary WPML add-ons.
You can access the WordPress dashboard using the link below:
hidden link

Kindly try to replicate the issue.

This will help us to report the probable issue to the compatibility team and solve the possible problem faster.

I setup WPML exactly like the language that you have on your installations and also installed the WPML SEO plugin which is the new glue plugin for the SEO related stuff. It is the same as the Yoast SEO Multilingual but it supports other plugins too.

Thank you.

April 25, 2021 at 4:21 pm #8618265

kristofD-6

Hi there.
I start to customize your WordPress installation. I added 3 categories and posts to this category. I have one issue with WPML . hidden link . On our sites switching between languages, this is switching between domains. I try to select this option in wpml but i can't because the addresses are not valid. Can you add this option and validate the domain names?

April 25, 2021 at 4:39 pm #8618305

kristofD-6

I reproduced the bug. Littlie instruction on how you can do it.
1) go to the permalinks: hidden link - you can see the the posts of this category.
2) Go to french translation of the category hidden link . Get parameter "clear_permalinks" run function "flush_rewrite_rules()" .
3) Go to again to Dutch hidden link and the content is disappeared.

4) Let's disabling the "remove category base" function hidden link
5) go to Permalinks settings for reloading the permalinks rules hidden link
6) Let's do again first three steps (but URL with category) and you will see that all works correctly
hidden link
hidden link
hidden link

April 26, 2021 at 1:58 pm #8625993

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you very much for the details. I asked the compatibility team to take a look into the issue and will get back to you if there is an update.

Thanks.

April 26, 2021 at 8:37 pm #8629263

kristofD-6

Thanks. I hope you will solve this bug. Waiting for new updates.

April 27, 2021 at 6:23 am #8630825

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Sure thing, if we have an update we will inform you. But at the time being, if there is a fix, it will be in the next releases of WPML and it will take time.

I do suggest that you disable that feature in Yoast SEO and try an alternative method such as the one below:

hidden link

Thank you.

July 30, 2021 at 7:44 am #9313547

kristofD-6

Hi gays. The problem is still. And it's too bad for us - get 404 errors on our pages. Last your advice brokes our permalinks structure so it's not helpful. When the plugin will be updated? How we can solve this problem?

August 2, 2021 at 2:03 pm #9328455

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Christopher is away for few days so I am taking care of this ticket. I hope that's okay.

The update with the fix is not released yet, I suggest you try the solution provided earlier by Christopher.

Thanks