This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by renauL 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 22, 2018 at 9:14 am

renauL

I am trying to: access the checkout page

Link to a page where the issue can be seen:
hidden link
hidden link
hidden link

I expected to see: the checkout

Instead, I got: a 404 page

May 22, 2018 at 9:22 am #2206421

renauL

Resaving the permalink, and refresh the page make the checkout page show up only if the seesion is still ok, and only for this session, if you try with a clean browser (brand new private navigation) the 404 error is still there.

May 23, 2018 at 1:50 am #2212428

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Note: Could you provide the credentials to access the site? I visited the URLs provided and there is a traffic restriction.

Kind regards,
Carlos

May 23, 2018 at 8:32 am #2213317

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

<em><u>hidden link</u></em>
<em><u>hidden link</u></em>
<em><u>hidden link</u></em>

Could you change the page slug to something else and let me know if that helps, for example, I can see that "boutique" is used as for two languages either change this or change the "paiement" slug. Does this help?

Also, since you mentioned that resaving the permalink helps for the session, this can occur if theme or plugins has used flush_rewrite_rules() and it's not implemented properly. So could you please disable all non-related WPML plugins, switch to one of the default themes, and let me know if the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

May 31, 2018 at 9:20 am #2255153

renauL

Got to specify each slug for each language, never a see a 404 with this setup.