Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by rabinG 2 weeks, 6 days ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
September 21, 2020 at 5:22 am #7055709

rabinG

404 on some thai products after all import

September 21, 2020 at 6:25 am #7055971

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Here is the ticket now, let us know how it goes with sandbox and if the issue is there as well.

Regards,
Bruno Kos

September 21, 2020 at 6:31 am #7055999

rabinG

No issue here, i did upload all those 299 products, i don't see 404 error for the product which had error on my site.

hidden link

what should be the next step now?

September 23, 2020 at 9:35 am #7078039

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back and taking time to test.

I have checked your website and could see the issue.

I see you are using and outdated SQL version. So in order to check if this is an issue specific to your server environment, can you please try and recreate same import process in sandbox site provided.

That way we can straight away see if the issue with the import process is happening on our server also. Also it is easier to debug it on a clean site.

Recomanded steps:
- Set up WPML languages as on your website
- Set up WP All Import and add needed addon plugins
- Import products to English
- Import products to Thai
- Check if the issue happens

Please let me know how it goes and when can I check.

Thanks,
Drazen

September 24, 2020 at 6:50 am #7086739

rabinG

Please set up the sandbox account, will create the products as per your recommended step.
The sandbox created, is not working anymore.

hidden link

September 24, 2020 at 9:36 am #7088931

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback.

The sandbox was working, I just deleted all products so we can start a new import from scratch.

To not cause any more confusion again, I am providing a new sandbox site.

Please go to the next link and run the same Import as you are doing it on your website.

Sandbox link: hidden link

That way we can see if the same issue is happening on sandbox, and I can easily check it on clean install if it does.

Let me know when can I check.

Thanks and kind regards,
Drazen

September 24, 2020 at 12:10 pm #7090933

rabinG

Hi I tried to create the products as i did for my live site. I don't see the wp all import option when i tried to import english version, please find attached screenshots for details.
Not sure if it has something to do with the plugin.

Please help, will create the products accordingly.

September 24, 2020 at 1:38 pm #7092101

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback, it seems WPML configuration was not finished.

I finished it for you, set up WCML, update WPML plugins to the latest versions, and added WP All Import Multilingual version 2.2.0 that was just released.

- https://wpml.org/download/wpml-all-import/?section=changelog

Please try now to recreate the issue on the sandbox, if it is working fine on sandbox I would suggest re-running import on your live website with the latest versions as they are on the sandbox.

Also, I see you are using the free version of WP All Import WooCommerce Add-On, while we note in our documentation WooCommerce Add-On Pro is needed, so not sure if it will work with free.

We can try checking it on the sandbox and then depending on the results we will know more.

Kind regards,
Drazen

September 24, 2020 at 3:37 pm #7093241

rabinG

Hello Drazen,

I did upload the products both version on sandbox and there aren't any 404 issues. However, i do see those products which had 404 on live site has weird unreadable url, but working, no 404 issues.

As a second step i did re run the import on live site, the 404 error still exists. t did not go away. i did check the plugins their version are same as sandbox plugins.

Please help.

Regards,
Rabin

September 25, 2020 at 8:02 am #7097389

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for taking the time, I think I found what is the issue and why is it happening only with some products.

URL slug is created from the Product title, but for some product, the Title is almost the same. So URL slugs can not be created and resaved, so they are left in Encoded URL (weird URL), and if reimport /resave they will return a 404/400 error depending on server settings.

If you manually re-translate the product, it will save the product slug normally and add a number, meaning that they are the same URL already existing. The product then opens the correct URL format and is working normally.

Nevertheless, I think the correct URL should be created as it does with other Thai products and without WPML, that is why I am escalating this case to our developers.

I will be marking this ticket as "Escalated to WPML developers team" and will update you when I have more news.

Kind regards,
Drazen

September 29, 2020 at 11:17 am #7123749

rabinG

Hi Drazen,

Haven't got any response so far form the developers.
"URL slug is created from the Product title, but for some product, the Title is almost the same." is there any way to upload the URL slug through WP all import? If possible I will rewrite each URL and bulk upload it. It's not convenient going into each product and manually translating it.

Please advise.

Regards,
Rabin