This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Bigul 2 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
July 15, 2019 at 6:49 pm #4214195

carolineF-7

Hy,

So we have update all plugins, WP Core and theme and ... we have still same error ...

July 15, 2019 at 6:51 pm #4214201

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Thank you for the updates. I am opening a new ticket for the issue. Because the previous one is automatically closed.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

July 16, 2019 at 5:19 pm #4222627

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. Somehow the translation relation is missing for the French menu. Please check the attached image.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

July 16, 2019 at 8:35 pm #4223823

carolineF-7

Hy,

So i do all this steps and i have still error and missing the translation relation for the french menu .. How to solve that ?

Thx

July 17, 2019 at 1:11 pm #4230367

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps after a backup and let me know your feedback.

1) Add a new menu item to the English menu or translate one of the menu items missing translations
2) Save the settings(English)
3) Click on *Synchronize menus between languages* link
4) Sync the menu to French

Please check the attached images for more details.

--
Thanks!

Bigul

July 17, 2019 at 8:39 pm #4233421

carolineF-7

Hy,

And bug is still here and we have another problem now because i add a new item into english menu, synchronise the menus, so this new item is into french menu. But it was just test your debug .. And now, i can't remove this item into the french menu ...

Please tell me what i have to do ... ! This bug is here since a lot of weeks now and it's very important for us !

Thx ...

July 18, 2019 at 9:01 am #4236273

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. This may be a compatibility issue. If possible, please switch for a moment to the Jupiter(parent theme) or default 2017 theme after a site backup and check the issue is existing or not.

Please remove the newly added menu item from English Menu and sync the menu to secondary language. This action will help you to remove the menu item from the French menu.

If the issue exists, please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 18, 2019 at 10:06 am #4237205

carolineF-7

Hy,

So i switch theme and there is still bug.
And when i want to sync the menus, there is no sync to do ...

So i add Duplicator plugin.

Thx !

July 18, 2019 at 12:41 pm #4238705

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and permission. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

July 19, 2019 at 12:42 pm #4246505

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please note, the issue is not happening on my local servers. It works as expected when all the plugins and your child theme is active. Therefore I have shared the details with our team for the expert opinion and waiting for the feedback now. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 30, 2019 at 12:47 pm #4307747

carolineF-7

Hy,

Thx to your response. Have you a feedback to your team ?

July 30, 2019 at 5:29 pm #4309863

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please check my previous reply(private message). I have a request from our team. Please deactivate WPML for a moment for testing after a site backup on your live site and check you can update both menus or not. Because we are not able to reproduce the bug on our local and external servers.

--
Thanks!

Bigul

August 12, 2019 at 8:26 am #4379145

carolineF-7

Hy,

It's ok when i deactivate WPML ...

August 13, 2019 at 6:09 am #4385165

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have shared the details with our team and waiting for the feedback now.

We will get back to you soon. Please wait.

--
Thanks!

Bigul

August 14, 2019 at 9:11 am #4393687

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We have the following requests for tracking the bug. Because it works in all our local and external servers.

1) Please check you are getting any error in the Server(Apache) Error Log file while having this error

2) Please turn off the Mod Security module of the server settings if it is on and check the issue is existing or not

3) Please create a staging site(clone copy) of the live site and check the bug is existing or not

--
Thanks!

Bigul

The topic ‘[Closed] 404 page when i try to save the menu’ is closed to new replies.