This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.56 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by emreG-3 1 month, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
September 3, 2019 at 7:17 pm #4507065

emreG-3

My experience is awful with the WPML since the day I bought it.
Whenever I add a new translation, I get a 404 not found error either in the source or target language. (I have tried permalink change, root change, flushing caches and the whatever I could find in the previous posts). Sometimes it is fixed, but it lasts until I post a new article.
The font size is different in the translations.
I have connected a page with another page as translation version, and now I cannot take it back.
I accidentally clicked "add translations" I cannot resign it from the work to connect that page with another page.

September 3, 2019 at 8:58 pm #4507263

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 768M (php.ini)
WP Memory Limit 40M (wp-config.php)
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

If the issues still occur, try to run the site in minimal setup to see if the issue persists.

Please disable any additional plugin but Elementor, Elementor PRO and WPML and its add-ons.

Does the issue persists?

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

September 3, 2019 at 9:17 pm #4507315

emreG-3

Hi Andreas,
Thank you so much for your assistance. I have increased the memory as you advised. The issues still persist. Also, I disabled/enabled the plugins and themes - still it persist. Regarding wp-debug future, I am not able to define that in wp-config.php.

Is there anything you can help? 404 errors damaged my website, otherwise, I will refund the tool.

September 3, 2019 at 11:25 pm #4507479

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 4, 2019 at 4:38 pm #4512901

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can see the WP Memory Limit is still unchanged. In case the following will not be successful please reach out to you host provider in order to let them apply the changes..

Before we take any further steps please chane the WP Memory Limit. I tried to apply the changes for you but the FTP access requieres a different/additional password.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 768M (php.ini)
WP Memory Limit 40M (wp-config.php)
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Let me know if the issue persists.

Kind regards
Andreas

September 5, 2019 at 5:58 pm #4521269

emreG-3

Hi again Andreas,

I've attached the screenshot i've received from siteground team. All of the issues are persisting. If you think that you cannot fix it, please refund WPML for me.

September 5, 2019 at 8:30 pm #4521989

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please have a look at the attached screenshot. Currently, WPML is not installed on your site and as you can see in the footer, the WP Memory Limit is 40M.

Further, the changes in wp-config.php in regards to the WP Memory Limit were commented out. Anyhow changing this does not update the WP Memory Limit on backend.

I have to appologize but I had to trz to check if the issue persists if all plugins are deactivated. The issue persisted.

Sadly, it is not mandatory to complete the MonsterInsights Setup Wizard again. My appologies for that.

If you are still thinking about a refund, please take note that you can request a refund within 30 days after purchase.

https://wpml.org/purchase/refunds-policy/

Kind regards
Andreas

September 5, 2019 at 8:53 pm #4522031

emreG-3

Yes, it is not installed because I have refunded it.

September 5, 2019 at 8:53 pm #4522033

emreG-3

refunded.