Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 9 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 20, 2019 at 1:13 pm #3221894

michaelZ-12

Hi,
There was a problem in the last WPML update. After the update, the translation in Spanish and Italian of a particular page were returning 404 error. After following the usual way of changing themes and deactivating plugins, I found that the problem is resolved when deactivated/deleted the “WPML Multilingual CMS” and uploaded/activated an older version and clicked the “Save Changes” button in Admin>Permalinks.
So what I’m asking is
1) to explain to your developers the issue so that they develop a new version asap
2) to inform me which is the ETA
Thank you,
Michael

February 20, 2019 at 9:56 pm #3223943

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Michael,

Thank you for contacting WPML Support. As we don't have further reports regarding it, I would like to perform some detailed investigation using a copy of your website and the most recent versions of our plugins, for that, plase consider: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

February 22, 2019 at 8:52 pm #3233970

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your continued patience while waiting for a solution. I am jumping here to let you know I am still working on your issue and I would need some extra time to provide you with a detailed and accurate reply. Thank you for your understanding and patience, have a nice day.

February 23, 2019 at 2:18 pm #3235331

michaelZ-12

Hi Marcos,

I understand that this problem is difficult to resolve.

As I wrote you in my previous private message, in the meanwhile I would like to restore an older version of “WPML Multilingual CMS” in the live site. Which is the correct process to do this so it won't cause any malfunction to the other WPML plugins which I have installed?
* Is it okay to deactivate and delete the last version of “WPML Multilingual CMS” and then upload and activate the older version - while the other WPML plugins will be active?
* Or should I deactivate/delete all WPML plugins and then upload/activate one by one the previous versions of all of them?
* Or is there a different approach that you will suggest me?

I attach a screenshot with the WPML versions installed before the problem appears.

Regards,

February 25, 2019 at 9:49 pm #3242188

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I couldn't replicate the mentioned issue on a clean install using the most recent versions of WPML, so it seems to be an isolated problem as we also don't have further reports of this issue.

Please, make sure to provide a complete duplicator package not just a database dump, make sure the provide package contains all the WordPress files, theme files and plugins, in other words please, provide a complete snapshot of your website so I can try the debug process using a copy of your website as it is not possible to replicate it on a clean install as I said before.

As regarding to restore an older vesion of WPML in your website, you can just replace the current files using a FTP sofware, no need to deactivate it before doing this process, you can try:

1 - Connect to your website using a FTP client software such as Filezilla.

2 - Replace the current plugin files in your host wp-content/plugins folder.

It is important to mention it is not something recommended, it is always a best practice to stay with the latest plugin updates, we cannot assume responsibility for things that may break with this approach.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

As you have a stagging website, it would be very helpful if you provide the access for this test website, this way I will be able to give it a further look with no need of a duplicator package. I will enable a private reply field in case you decide to provide this access details.

Please, let me know if you need any additional clarifications from our side. Have a nice day.

February 26, 2019 at 5:21 pm #3246468

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a closer look in your staging website, although it use a recent version of the WPML plugin the issue is not replicable, I tried this page from your website: hidden link and not issue was seen in any of its translations. Does it happen only in a particular page? If so, which page does it happen? How can I replicate the reported issue in your staging website? As regarding your questions regarding on how to downgrade your WPML plugin, here are the answers:

1 - Replacing as you suggest the current plugin files with the files of the older version will not be exact as new and old versions do not have the same number of files. Are you sure that this is safe?

Even if there's a difference in the number of files, the extra files won't be used in the new version or in the old version as there wouldn't have any call for this non used files, if you are not sure about it then you can just replace the entire folder instead of specific files.

2 - You do not agree with deactivating and deleting the last version and then uploading and activating the older version? Is it dangerous?

Deactivating it before downgrading and then activating it after the upload process shouldn't take any adverse effect for your website, so it shouldn't be dangerous. I meant in my previous reply the unistall process which would make you to loose all your translations and language information, so in this case you should never try to uninstall the WPML core plugin (WPML Multilingual CMS).

3 - Do I need to restore also the other WPML plugins to their previous versions –OR– I can just restore ONLY the older version of “WPML Multilingual CMS” which gives the problem?

As in your tests you find WPML Multilingual CMS as the culprit for your issues, then you should restore just it instead of every WPML related plugin.

4 - If I have to restore also the other WPML plugins to their previous versions, do I have to follow a specific process?

You don't need to restore the other WPML related plugins, but if you had to, then the process should be the same as the WPML Multilingual CMS plugin.

NOTE: As the issue is not replicable in your staging website, I recommend you to try another troubleshooting, if you are using the same version in your production website and in your staging website, then the cause of your issue is with another source as it works in staging but not in your production website, maybe it is just a temporary issue, if it only happen in a particular page, instead of all the pages, then the cause of the issue shouldn't be the recent updates for WPML.

Hope it brings some clarifications for you have. Have a nice day.

February 26, 2019 at 5:33 pm #3246552

michaelZ-12

Hi Marcos,

If you look in my message of "FEBRUARY 21, 2019 AT 1:41 PM" I describe exactly the page I found having problem specifically in two languages as well as the problem created in the categories. I repeat it here below:
"The pages I found resulting to 404 are
hidden link (page id: 1524 - page title: Búsqueda de alquiler de barcos disponibles y reservación on line)
hidden link (page id: 1042 - page title: Ricerca di disponibilità noleggio barche e prenotazione online)

Also, categories are not working properly anymore. For example from the below subcategories:
1. hidden link
2. hidden link
3. hidden link
4. hidden link
only the first one returns the listing correct. The#2 and #3 return 404 while the #4 redirects to hidden link"

Related to your previous answer can you please explain to me how can I replace with FTP the entire folder instead of specific files?
Regards,

February 28, 2019 at 12:43 am #3252909

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and your patience. I took a detailed look in the provided staging website and could notice the source of the issue is your Yoast SEO plugin settings. Please, make sure your Yoast settings meets the WPML requirements as explained at:

https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

I noticed for example you are using the option to remove the 'category' base from your URLs, this setting doesn't work when using WPML, doing so, you will be redirected to 404 not fount error pages as explained at:

https://wpml.org/errata/yoast-seo-strip-the-category-base-does-not-work-in-the-second-language/

In short, I recommend you to follow our provided guide in order to make sure your Yoast settings are according our instructions in the resource provided above.

Please, let me know if it helps, have a nice day.

February 28, 2019 at 6:46 pm #3257159

michaelZ-12

Hi Marcos,

If you look further down in the second link you sent me it is obvious that:
1. There are more WPML users facing the same problem with me regarding categories
2. The problem appeared after version 4.2.0
3. You colleague supporters have forwarded this issue to the developers

Until a solution is given by the developers, the following worarround is proposed:
“Our workaround, at the moment, if the 404s on the sub-categories occur, is to disable the WPML plugins, flush the permalinks and then re-enable the WPML plugins. The 404s go away until the permalinks get refreshed once again (e.g. after editing a category).”

But as I have said I have one more issue: If you take a look again in my previous message you will see that after the last update of “WPML Multilingual CMS” I have a problem also with the translation of a particular page in Spanish and Italian: the pages of these languages started returning 404.

I suggest that you forward this issue (together with the issue of removed category base) to your developers.

Regards,

March 1, 2019 at 5:13 pm #3262430

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I am aware about the comments in our errata article from https://wpml.org/errata/yoast-seo-strip-the-category-base-does-not-work-in-the-second-language/. These issues seem to be all related to the mentioned setting in Yoast SEO plugin, if you disable it in the test environment you provided you will notice both the subcategories and the mentioned pages will work as expected, so, untill a solution is provided for this incompatibility you should proceed according the errata instructions.

I disabled the option to remove the subcategory base from the Yoast SEO settings in the provided staging environment and the all the pages and categories translations are working properly.

Please, let me know if you need any other clarifications, have a nice day.

March 3, 2019 at 12:37 pm #3266151

michaelZ-12

Hi Marcos,

I did the workaround which I mention in my previous message and categories are okay for the moment. This has not corrected though the issue I mention in my initial message: the translations of a particular page in Spanish and Italian return 404.
I have tested what you said, that disabling the option to remove the subcategory base from the Yoast SEO settings will resolve the issue but, in the live site, I do not wish to disable this option in Yoast SEO settings neither to install one more plugin. The question remains: why only those 2 translations are affected?
And it seems that you developers are not aware that, besides to the categories issue, there is also a problem with page translations.

So could you please escalate this particular issue to your developers and let me know what their answer is?

Regards,

March 7, 2019 at 6:03 pm #3286291

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

March 12, 2019 at 3:56 pm #3325115

michaelZ-12

Hi Marcos,

I have figured out the reason for getting 404 in the translations of that particular page in Spanish and Italian: these translations have exactly the same slug and URL with the corresponding translations of a category.
After changing the slug in the translations of that category, the translations of the page do not result to 404 anymore.

After this I think there is no reason to investigate further and the only thing needed is that you inform your developers that there is one more site facing the known issue with the categories after version 4.2.0 (removed category base) like your colleague supporters have already done with other similar cases. Let me know if you agree.
Regards,

March 12, 2019 at 5:26 pm #3327021

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I updated our developers with your particular request, for now the only workaround is to proceed with the errata instructions at: https://wpml.org/errata/yoast-seo-strip-the-category-base-does-not-work-in-the-second-language/ as there's no an estimated time for this fix. Thank you for your understanding and collaboration, have a nice day.