This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by emreG-3 1 month, 1 week ago.

Assigned support staff: Radu.

Author Posts
September 6, 2019 at 2:12 pm

emreG-3

Hello there,

I have most likely read the entire support forum to fix the problem. Whenever I update the permalinks, either the source or target language links are causing 404 errors.

I have enabled/disabled plugins, themes, updated the settings, cleared the caches and ghost entries in WPML, uninstalled-reinstalled everything even refunded the WPML.

I am granting you access to log in my website and FTP. Please check it out.

September 8, 2019 at 9:04 am #4530961

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you tell me what's the fix when this happens, please? I just want to try to save again the permalinks but I need to know how this can be fixed too in order to investigate the issue.

Also, is this still happening while deactivating the modules of the SG Optimizer plugin (and the plugin too)? The caching and changes made by this plugin are pretty "brutal" and I've seen similar issues caused by it on some websites. You can check this out and tell me how things work.

Thanks,
Radu

September 8, 2019 at 9:54 am #4531099

emreG-3

Hey Radu,

Thanks. I've disabled the siteground plugin and the issue still persists. Now my german pages are 404 not found.

Time to time, they appear back if I change the language URL format and update the permalinks. Could you help me, please?

September 10, 2019 at 7:14 am #4542373

emreG-3

It has been a very long time I have this problem, can I get some support guys?

September 10, 2019 at 7:32 am #4542537

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Sorry for this delay but we had a bigger load of tickets over the weekend and that's why I replied back a bit slower.

I just checked your website and I could see that there's only one page translated in German (hidden link) and it works very well. Can you send me a link to the page where I can see this 404 issue so I can check it a bit closer, please?

Thanks,
Radu

September 10, 2019 at 7:34 am #4542541

emreG-3

Check it out here please:

hidden link

September 10, 2019 at 8:03 am #4542759

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I just went to Dashboard → Settings → Permalinks and hit the Save Changes button. Now, if I try to access the German version of this review hidden link, everything work fine. Can you check this out, please?

Thanks,
Radu

September 10, 2019 at 8:04 am #4542787

emreG-3

Thanks, and now the English content is gone as I mentioned;

hidden link

September 10, 2019 at 8:48 am #4543289

emreG-3

I need instant assistance on this guys as it has been more than a week I'm busy with this issue and it is damaging my website so much. Could you please faster the process?

September 10, 2019 at 8:51 am #4543305

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I'm checking this right now. As I can see, this 404 issue appears only for the reviews. Can you tell me if it happens for any other elements too? Also, are the reviews still available if you change the theme to Twenty Nineteen, for example? I'm just trying to find the roots of this issue to see what can be done about it.

Thanks,
Radu

September 10, 2019 at 8:54 am #4543325

emreG-3

Hey Radu,

I appreciate your help. It happens in other elements as well, you can add a post or page to check out in the website, I've given you permission for that 🙂 - the theme recommends WPML in their documentation and I've seen many websites built on that so I think that is not the issue. When I change the theme the issue still persist as I've written in the first entry of the request.

Don't you have a live chat where we can go onto this together simultaneously?

September 10, 2019 at 9:49 am #4543687

emreG-3

Next to that, I cannot resign translations. For example, I accidentally added the wrong page when "connecting translations". Now I cannot resign and "connect" a new page.

hidden link

September 10, 2019 at 1:47 pm #4546137

emreG-3

Any update on this?

September 11, 2019 at 7:14 am #4551049

emreG-3

Hi there, the problem is on review elements. The other elements such as page/posts are working smoothly. Can I get some support on that as it has been more than a week I am trying to solve this issue?

September 11, 2019 at 7:20 am #4551059

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Regarding the connection between the original page and translation, you can try to edit the original page (hidden link), use the language switcher from the top of the page to select German, then use the This is a translation of field from the right side and select None to it. Once you hit the Update button, the connection between the original page and translation should be gone. Can you give this a try?

Regarding the 404 issue, I created a new post right here hidden link and if I change the language, the translation works fine too. This is the reason why I was thinking that maybe this is related only to Reviews.

As you can see here https://wpml.org/documentation/theme-compatibility/, the theme that you're using is not a part of our WPML compatible themes list. The theme authors can add WPML in their description or documentation but this theme was never tested for full compatibility by our team. We have a separate team that takes care of testing themes submitted by authors in order to make sure that they work very well with WPML. In this case, there still might be some compatibility issues.

Is there any chance that you could send me a copy of the theme so I can install it on a clean website and see if I can replicate this issue, please?

Thanks,
Radu