This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by erich-alexander-constantinG 3 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
June 26, 2019 at 2:49 pm #4093349

erich-alexander-constantinG

I am trying to:
Duplicate a page including the translations

Link to a page where the issue can be seen:
hidden link

I expected to see:
200 ok

Instead, I got:
410 gone

June 27, 2019 at 10:40 am #4099267

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

Right now we do not offer any duplication feature for pages ( i mean, you can duplicate the page into other languages but not a page with translations, those are 2 different things)

But i believe there are plugins like hidden link that could somewhat help you, although i'm not sure it it would help out with the translations as well (but you can try it out and let us know).

I would have another idea on how to achieve this, though.

You could use a plugin like the one i mentioned you before and duplicate the post in all the languages, and then link them. If you'd like that idea, then i can totally give you more details on how to achieve that.

Let me know what you think.

June 28, 2019 at 6:14 am #4104739

erich-alexander-constantinG

Dear Alejandro

Thank you for your response.

Yes, please be so kind and send me more details for your idea.

Best regards

June 28, 2019 at 9:26 am #4106141

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Version 1:
I just tested the latest version of this plugin:
hidden link

And it seems it does exactly what you want, which is the best option i have in mind, it would just take one click.

I tested it here: hidden link
(just create and translate a page and then go to the default language post and click "clone")

I suggest you make a backup of your site and then give this plugin a try. Remember though that this is just a suggestion and since we're talking about another plugin, we can't take responsibility for any harm it could cause (although i don't think it could create you any).

Version 2:

Install another plugin like hidden link
and duplicate the post in both languages and finally link them together:
https://wpml.org/faq/how-to-link-already-translated-pages/

Those are the 2 ways i know you can use to achieve what you want to achieve.

Regards.

July 1, 2019 at 9:08 am #4116835

erich-alexander-constantinG

Dear Alejandro

Thank you for the duplication hints.
Before I go ahead with this I still get 504 Gateway Time-out errors when sending translations to batch from basket. I increased max_execution_time to 300 and vars to 120,000.

I am not able to send translations to batch.

Best regards

PHP
Version 7.3.6
Memory limit 512M
Memory usage 20.93 MB
Max execution time 300
Max input vars 120000
Utf8mb4 charset Yes
Multibyte String extension Loaded
SimpleXML extension Loaded
WordPress
Version 5.2.2
Multisite No
Memory limit 512M
Max memory limit 512M

July 1, 2019 at 2:53 pm #4120467

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

To continue, I'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

Then, please let me know if this is happening with any page,post or any other post type you're adding to the batch.

I'll proceed to check the situation and know how to continue.

July 2, 2019 at 9:42 am #4125411

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem seemed to have been generated by the fact that the jobs were already added to the translation job queue.

Before you do anything else, can you tell me if you wanted to send it for translation to a translation service (net-translators) or if you wanted to have it translated locally?

Please let me know so i can run the last tests on your site.

Regards.

July 2, 2019 at 10:29 am #4125739

erich-alexander-constantinG

Hi Alejandro

I created 5 new users for translation and added the pages/portfolio items to the basket for submitting. It seems to be ok now.

I will continue with the 410 gone error.

Best regards

July 2, 2019 at 3:11 pm #4128273

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, the portfolio item you added as a reference probably gave you a duplication error for the same reason it didn't work in the translation basket:

The item was already set as translation job so it couldn't be replicated, but since you never actually translated it, it didn't "block" the duplication checkbox.

I created a new test portfolio item (which i left setup as private for you to see) and i couldn't replicate the problem.

Try yourself, but i think there won't be anymore issues. if there are, please check if the items you want to translate or add to the basket are already present and active in WPML > Translation Management > Translation Jobs.

Regards.

July 4, 2019 at 8:27 am #4141205

erich-alexander-constantinG

My issue is resolved now. Thank you for the excellent support!