Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When I try to change the language from the language switcher, I get an error 500 internal server error and this message is shown:

"Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at admin@websupport.sk to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

Solution: Many times, this is caused by an incompatibility issue between one/multiple plugin/s that you use or the theme you are using.

Please try this:

- disable all plugins except WPML and its add-ons - check if the issue is happening again - if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated - switch to a default theme like TwentySeventeen - try to recreate the issue now

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 26, 2019 at 6:45 pm #3892227

antonD-13

Hi, on my site new.spinergo.com when I tried to change the alnguage of site as visitor I get an error 500 internal server error and this messega is shown:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at admin@websupport.sk to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

How can I fix this issue? Thanks.

May 27, 2019 at 9:32 am #3895365

Dennis

Welcome to WPML Support forum.

Internal server errors are usually triggered by php errors. Could you please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

/*enable debugging*/
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Try to reproduce the issue.

Locate the debug log in: /wp-content/debug.log using FTP, then edit/view the content of the file. Can you see php errors related to WPML? It would be great if you can share with me the debug.log content using pastebin.com

Additionally, could you please try to deactivate all non-related WPML plugins, switch theme to TwentySixteen, does the issue still persist or not?

NOTE:
+ Please backup your site completely before doing this test.

Kind regards,
Dennis

June 1, 2019 at 11:22 am #3934953

antonD-13

Hi, I sent you informations on mail, but still did not get any response.
Please check your inbox.

Thanks.

June 3, 2019 at 1:16 pm #3942687

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

My colleague, Dennis, is not available at the moment but I am more than happy to help you. 🙂

Can you please let me know at what email address did you sent your email to?

Our policy doesn't allow support via email, we offer support only via our forum tickets or our live chat, but maybe you are referring to this email that you mentioned above (admin@websupport.sk) and if that's the case, that is not our email; it is probably the email of your hosting provider.

Please let me know.

Kind regards,
Mihai Apetrei

June 3, 2019 at 1:30 pm #3942761

antonD-13

Hi,

I don´t remember the email. Here you can download the debug log: hidden link . Also sent info to your collegue that my hosting provider also check the debug log and send me the info that isuue is caused by these two plugins:
- sitepress-multilingual-cms
- wpml-translation-management

Thanks for your help.

June 3, 2019 at 5:04 pm #3944733

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

Can you also please let me know if you were able to follow the steps recommended by my colleague, Dennis, above ("Additionally, could you please try to deactivate all non-related WPML plugins, switch theme to TwentySixteen, does the issue still persist or not?"), and if the issue is still happening when only WPML plugins are active?

Please let me know.

Kind regards,
Mihai

June 3, 2019 at 5:13 pm #3944763

antonD-13

Hi, yes I tried this and also this way tried my hosting provider and we check the log and as you can see the issu is caused by sitepress-multilingual-cms and wpml-translation-management plugins.

June 4, 2019 at 2:17 pm #3952575

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai

June 5, 2019 at 2:52 pm #3961929

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they work.

So what I did is this:

I disabled all the Non-WPML plugins and I left active just the WPML plugins + WooCommerce and the issue is gone (you can check it now on the site) so this confirms that there is some kind of incompatibility issue between WPML and at least one of the plugins that you are using.

My recommendation is to reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue.

I hope that you will find this information helpful.

Please let me know how that goes.

Kind regards,
Mihai

June 5, 2019 at 7:44 pm #3963743

antonD-13

My issue is resolved now. Thank you!