If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 3 voices.

Last updated by George Botsev 6 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 28, 2017 at 10:00 pm #1307963

julianD-6

When trying to upgrade wordpress and plugins (multisite) at "../wp-admin/network/plugins.php" an "500 Internal Server Error" appears. The Error Log shows the following:

"[28-Jun-2017 21:35:04 UTC] PHP Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 73[28-Jun-2017 21:35:04 UTC] PHP Notice: Undefined property: stdClass::$site_id in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 76[28-Jun-2017 21:35:04 UTC] PHP Notice: Undefined property: stdClass::$site_id in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 80[28-Jun-2017 21:35:04 UTC] PHP Notice: Trying to get property of non-object in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81[28-Jun-2017 21:35:04 UTC] PHP Notice: Trying to get property of non-object in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81[28-Jun-2017 21:35:04 UTC] PHP Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81"

Please help

June 28, 2017 at 10:36 pm #1307975

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

Please go to wp-config.php and let me know what is your current WP_Memory_Limit

https://wpml.org/home/minimum-requirements/

=> To see the WP memory limit you have to login using your FTP and going into the
wp-config.php file , and it will be at the very top.
The Documentation i attached for you goes over details the requirements.

Also , please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

June 29, 2017 at 11:50 am #1308502

julianD-6

define('WP_MEMORY_LIMIT', '128M'); => Hoster Setup is also at 128M

I switched to PHP7 today and now the following error occurs when trying to update the plugins through multisite network at "../wp-admin/network/plugins.php"

"Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 73

Notice: Undefined property: stdClass::$site_id in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 76

Notice: Undefined property: stdClass::$site_id in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 80

Notice: Trying to get property of non-object in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81

Notice: Trying to get property of non-object in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81

Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 262144 bytes) in /usr/www/users/bionic/bionic-neu/wp-includes/load.php on line 826"

No change when switching of any plugins or theme as the error only occurs at "../wp-admin/network/plugins.php" when trying to update. The single sites work without any problems, I can also load the plugins sections within the single sites.

June 29, 2017 at 7:08 pm #1308959

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

This is a memory issue.

I believe 128M might be too low, if possible up that 256M or higher and also ask your Host Provider to increase your memory as well from their side too.

The following errors are not related to WPML

"Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 73

Notice: Undefined property: stdClass::$site_id in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 76

Notice: Undefined property: stdClass::$site_id in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 80

Notice: Trying to get property of non-object in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81

Notice: Trying to get property of non-object in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81

Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 81
June 29, 2017 at 7:15 pm #1308965

julianD-6

I dont think this issue is related to too low memory as 262144 bytes are only 0,26 megabyte.
And I don't agree that the errors are not related to WPML as the "sunrise.php" is reponsible for the domain mapping of WPML.

I still need help, why did I upgrade my license to lifetime support last year?!

June 29, 2017 at 7:20 pm #1308967

julianD-6

Increased to 1024M - no difference !

June 29, 2017 at 7:53 pm #1308985

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Were you able to contact your host provider?

Certain setups require your Host provider to increase the memory from their side aswell.

This is an issue that has been discussed in our forums in the past and resolved by the Host Providers increasing the memory from their side in many cases.

Please contact them and let me know their response.

If you wish i can also test your site locally.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

June 29, 2017 at 11:11 pm #1309075

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

thank you for the access details !

Please provide me with full admin access as i need to install Duplicator Pro to create a package and test your site locally to not interfere with your live site and also check the errors again my local servers.

Please let me know when this is done so i can move forward , thank you !

June 30, 2017 at 11:27 am #1309426

julianD-6

I added you as admin, what else can I do? I don't have access to the wp-admin/network to change any "super admin" settings.

I gave you full ftp access so you can duplicate the website with ftp & mysqldumper e.g.

June 30, 2017 at 11:38 pm #1309844

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

I was not able to replicate this issue.

I realize that you mentioned "the error only occurs at "../wp-admin/network/plugins.php" when trying to update" and as i have tested all the single sites i was not able to replicate it either.

1. Your WPML plugins seem up to date, are you still receiving the error 500 ?

2. or are you just seeing the warnings and notices now?

3. You mentioned " I don't have access to the wp-admin/network to change any "super admin" settings."

- Is this due to the error ? if yes then please use your FTP and deactivate WPML to regain access.

July 2, 2017 at 3:33 pm #1310140

julianD-6

Just login to wp-admin and then click on "my sites --> network admin" and you'll see all the errors. As I already told you it is a multisite.

July 3, 2017 at 5:11 pm #1310989

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

.. But i cannot access network admin, i have tried accessing it by URL aswell nor can i access the plugins tab in order to deactivate/activate WPML.

I have enabled the private field in case you need to give me seperate access details .

If you cannot give me super admin access due to the errors not allowing you to access the area please try to deactivate WPML through the FTP by adding ".deactivate" at the end of the plugin name and you should be able to access it , or share with me your details if possible.

July 3, 2017 at 6:42 pm #1311069

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you.

Deactivating WPML CMS plugin does not resolve this error.

The errors are all pointing towards sunrise.php which is a custom file you have created i believe within your wp-content folder.

Temporary deactivating sunrise.php file removes all the errors but introduces new errors due to having sunrise.php as a path.

Warning: include_once(/usr/www/users/bionic/bionic-neu/wp-content/sunrise.php): failed to open stream: No such file or directory in /usr/www/users/bionic/bionic-neu/wp-includes/ms-settings.php on line 38

Warning: include_once(): Failed opening '/usr/www/users/bionic/bionic-neu/wp-content/sunrise.php' for inclusion (include_path='.:/usr/local/lib/php/') in /usr/www/users/bionic/bionic-neu/wp-includes/ms-settings.php on line 38

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/bionic/bionic-neu/wp-includes/ms-settings.php:38) in /usr/www/users/bionic/bionic-neu/wp-includes/pluggable.php on line 1195

I understand you mentioned " the "sunrise.php" is reponsible for the domain mapping of WPML. " but deactivating WPML should resolve these issues if it was related to WPML.

If you focus on the errors that are logged they are pointing towards Trying to get property of non object as well with an undefined property.

There is something wrong in the code.

Did you code this file your self or did somebody provide you with it. ?

Even more so all these errors are resolved by going to your FTP > wp-config.php file and on line 117 commenting out

define('SUNRISE', 'on'); 

Once this is done the errors are gone.

July 3, 2017 at 7:02 pm #1311093

julianD-6

sunrise.php is part of the the plugin; responsible for the domain mapping you recommend here at wpml.org: https://wpml.org/documentation/support/multisite-support/languages-in-domains-for-wordpress-multisite-mode/

Its not coded by myself ... it has to be some kind of misconfiguration of the plugin/domain mapping or sth. like this.

I previously changed domainnames of the first multisite, but I don't know how this could affect the site anyhow

July 3, 2017 at 7:18 pm #1311104

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

The code within the sunrise.php file was from a beta version, i have gone ahead and added .deactivate next to the file and created a new file named sunrise.php within your wp-contnet for you with an updated version of the code which seems to have fixed the errors.

Please test your site and let me know your results.