Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 3 voices.

Last updated by George Botsev 6 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 3, 2017 at 7:31 pm #1311114

julianD-6

Well the admin network works now but domain mapping is completely deactivated now and all the frontend domains/urls are wrong now.

I have renamed the new sunrise.php to "sunrise.php.new" as the wrong urls could have affected our google ranking

July 3, 2017 at 7:37 pm #1311119

julianD-6

Maybe because of that error "Please edit your /usr/www/users/bionic/bionic-neu/wp-config.php and move the line define( 'SUNRISE', 'on' ); above the last require_once() in that file or make sure you updated sunrise.php."

but if you have a look at the wp-config it is already above the last "require_once" hm?!

July 3, 2017 at 9:54 pm #1311170

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I have involved our second tier in getting their opinion on this issue, once i have news i will be updating you.

July 5, 2017 at 9:25 pm #1313050

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

We are currently still reviewing the issue

You will be notified as soon as new information is available.

July 11, 2017 at 1:03 pm #1316794

julianD-6

Any update on this topic? I am still waiting for your response.

July 11, 2017 at 4:41 pm #1317055

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

At this moment there is no new information , i will be updating you as soon as there are some updates soon !

Thank you !

July 13, 2017 at 5:41 pm #1319102

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Our developers are working on this to find a solution , but the account provided earlier does not have the superadmin privilegies and they cannot test properly the issue.

The page produces error: Sorry, you are not allowed to access this page.

Please provide the superadmin privilegies so they can proceed with testing the issue properly.

Let me know here once done.

Thank you !

July 13, 2017 at 5:59 pm #1319111

julianD-6

Done

July 13, 2017 at 6:27 pm #1319129

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you!

Will update you soon !

July 14, 2017 at 8:47 am #1319454

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello, I am George from second tier support.
I am the one that is in charge in further investigating your issue.
I tried to reproduce the same on a clean install - but I failed.
In my investigation, I found out that your problem is more related to the MU Domain Mapping plugin than to WPML.
You know - MU Domain Mapping comes with bundled sunrise.php inside of it.
I made a simple test - disabling WPML, and using that file.
In my test setup - I can always access the site, however, in your site - doing that results in the same error.
So it is my belief that there is either something wrong with your MU Domain Mapping settings or perhaps there are some conflicting settings in your database that is making the problem.
For now, I can suggest you try and update your WordPress to the latest version - since I can see that it is not. This might resolve the issue, but it might not.
Another thing that you can try is to check older versions of MU Domain Mapping plugin. Perhaps something got changed recently and the issue might be from that time?

In order to use Domain Mapping and WPML - both sunrise.php from MU Domain Mapping and WPML should be combined. Using just our part makes the admin page visible, but deactivates functionality of MU Domain Mapping plugin. This is why you have noticed the message: "Please edit your /usr/www/users/bionic/bionic-neu/wp-config.php and move the line define( 'SUNRISE', 'on' ); above the last require_once() in that file or make sure you updated sunrise.php."

Please let me know how it goes and please be sure to make a complete backup of your site before doing any changes.

July 17, 2017 at 5:39 pm #1321195

julianD-6

I've updated wordpress to the latest version (also all plugins). This did not solve my problem.

This is the current error output:

Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 22

Warning: Creating default object from empty value in /usr/www/users/bionic/bionic-neu/wp-content/sunrise.php on line 30

Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 262144 bytes) in /usr/www/users/bionic/bionic-neu/wp-includes/load.php on line 826

Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 262144 bytes) in Unknown on line 0

All I’ve changed before the error appeared was the “DOMAIN_CURRENT_SITE” in wp-config.php for my admin multisite (not visible for public) as the domainname changed. Of course I changed all the old url information in the database as well, so that I dont see any problem with that.

Do you have any idea how to solve this problem? I still need help.

July 18, 2017 at 9:16 am #1321674

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I think that the change that you made is responsible for the improper behaviour.
You see - the table domain_mapping in your database - has domains and site ids.
Changing the domain does not change the id associated to it and this creates the issues.
I advise you to take a closer look at that table and adjust it appropriately.
The problem right now is that the data is not correct and instead of returning your primary domain value - it returns NULL - because there is no such domain mapped to that site with that ID.
You need to test and make corrections to that table as well so that the ID and the domain match.