This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Carlos Rojas 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 15, 2019 at 10:47 am #3612603

lars-kroghJ

So what im trying to do is to translate our website from danish to sweden.
So what happens now after i have assigned the working jobs (1700) to translation i have the most of them tranlatede i just miss 200 now.
The problem is now that i keep getting 502 errors and our backend is loading insane slow.

So i get this information in my php error log :

WordPress-databasefejl Unknown column 'wrap_tag' in 'field list' for foresp\xc3\xb8rgslen UPDATE `wp_icl_strings` SET `wrap_tag` = 'h3' WHERE `id` = '286288' /* From [www.site.info/wp-admin/post.php?post=10822&action=edit&meta-box-loader=1&_wpnonce=66bbe9acff&_locale=user] in [/nas/content/live/billejedev/wp-content/plugins/wpml-string-translation/classes/class-wpml-st-string.php:273] */ fra shutdown_action_hook, do_action('shutdown'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WPML_PB_Integration->do_shutdown_action, WPML_PB_Integration->register_all_strings_for_translation, WPML_PB_API_Hooks_Strategy->register_strings, do_action('wpml_page_builder_register_strings'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WPML_Gutenberg_Integration->register_strings, WPML_Gutenberg_Strings_Registration->register_strings, WPML_Gutenberg_Strings_Registration->register_blocks, WPML_Gutenberg_Strings_Registration->update_wrap_tag, WPML_ST_String->set_wrap_tag, WPML_ST_String->set_property, referer: hidden link

Can you find any way to fix this ?

April 15, 2019 at 7:48 pm #3616199

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I kindly ask you to visit this link and apply the solution described there: https://wpml.org/forums/topic/wordpress-database-error-after-updating-wpml-unknown-column-wrap_tag-in-fie/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

April 16, 2019 at 6:19 am #3618403

lars-kroghJ

Our site still return 502 and are still slow.

Our memory limit are more then listed. so thats not the problem.

Waiting on a better "fix"

April 16, 2019 at 11:55 am #3621725

lars-kroghJ

So the errors are coming when entering : hidden link and trying to save on this page.
As the load is to big.
I have disabled the string translation but we are still getting errors some time.
But is their a way to fix it ? So that we avoid this erros ?

April 16, 2019 at 2:28 pm #3622931

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

1.- I asked you to increase the memory limit because the server has enough memory however the PHP memory limit in the debug information of the site is only 40Mb. This request is just to make sure that the site meet WPML's minimum requirements. I kindly ask you to apply this steps and check if the issue persists.

2.- If the issue persists then I would like to request temporary access (wp-admin and FTP) to your site to take better look at it. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

3.- Please describe steps by step how to reproduce the issue.

Thank you very much for your understanding!
Regards,
Carlos

April 16, 2019 at 3:07 pm #3623269

lars-kroghJ

Attaches is our PHP settings from your support tab.
We are still getting 502 errors, here is the how to : hidden link

April 16, 2019 at 5:30 pm #3624263

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

April 21, 2019 at 9:44 am #3652035

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Carlos is having holidays and he will be back to work tomorrow & continue with this. Since he is already working on this issue with you, I will keep it open for him.

Thank you for your patience and cooperation.

April 21, 2019 at 9:57 am #3652041

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Please also provide login for WP backend (wp-admin):
hidden link

I cant see WP Admin login in the last reply.

April 22, 2019 at 1:52 pm #3656213

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm back from the holidays.

I visited the site in wpengine but it didin't loaded. Could you double check that the site is working?

Regards,
Carlos