Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 6 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 23, 2019 at 7:45 pm #3667249

Steven Daniels

I am trying to: Add a translated page to the Main Menu

Instead, I got: a 504 ERROR.

The pages work fine when I manually go their URL address. But when I try to add the page to the Main Menu, it goes to a 504 ERROR.

Please help.

April 24, 2019 at 1:26 am #3668073

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look, please, try this basic troubleshooting:

1 - Make sure your server environment meets our minimum requirements as described at: https://wpml.org/home/minimum-requirements/, you can see your current values at your WordPress Dashboard > WPML > Support > Info menu.

2 - Disable all the plugins except the WPML related ones from your WordPress Dashboard > Plugins and see if the issue is gone, if so, activate one plugin at a time untill the culprit one is found.

3 - If the issue persists, temporary change to a default WordPress theme such as the 'TwentySeventeen' theme from your WordPress Dashboard > Appearance > Themes menu.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the steps above help to fix your issue. Have a nice day.

April 24, 2019 at 12:35 pm #3672759

Steven Daniels

This is all pretty boilerplate and tried. Server meets all requirements. WPML works in all cases except for this one issue.

Main site was built in English. I am creating independently-translated French versions of each page. It all works except for a random issue while adding a page to the French version of the Main Menu. When added, it locks out the site and returns a 504 ERROR.

Here is why it seems random ... So far it has happened with only 2 pages, everything else is OK. The first page uses a plugin called "Calculated Fields Form". The English works perfectly ... just adding the French version to the French main menu causes the ERROR. If I call up the page's specific URL, it works. This also occurs with another page that has an iFrame to a simple HTML calculator. Again, works perfectly when typing in the URL, but gives a 504 ERROR when trying to add to the French main menu. Note: Both work perfectly in the English main menu, so it only has to do with this second language.

This all being said, I suspect the problem is between WPML and WordPress, as it seems unrelated to the theme or a plugin, the English works perfectly, and the pages work when I type in their URL directly.

Thanks!

April 24, 2019 at 3:43 pm #3674893

Stéphane

For your information, I'm getting exactly the same issue.

April 25, 2019 at 12:34 am #3677609

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 29, 2019 at 7:36 pm #3706327

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above, thanks!

May 1, 2019 at 4:15 pm #3718867

Steven Daniels

The Plugin didn't have fields for "Database Username" or "Database Password" (see image).

I added the information that I could and the plugin took me to something called "BlogVault", where it started "validating details"

I received no email indicating that it had started.

After a while, it gave me an error: "Unable to execute PHP file on the site. Please check with your hosting provider."

I then got another screen with the following field options on BlogVault:

Destination Site URL
sFTP Host/Server Address
Application Folder Name
sFTP Username
sFTP Password

I filled out what I had information for (you didn't indicate a folder name), then tried migrating again and got the same error.

May 2, 2019 at 12:03 pm #3724309

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I checked your website and also tried the steps, indeed there's an issue in the migration process, something blocking the migration either in your server or even in our cloudways test server. In order to avoid any delays in the resolution of your issue, let's try an alternative method: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

May 2, 2019 at 12:05 pm #3724325

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

@najman,

I will proceed with your issue resolution as soon as I can debug the issue mentioned in the topic owner. Thank you for your patience and understanding, have a nice day.

May 6, 2019 at 1:42 pm #3749145

Stéphane

FYI, I went back to my website today and the problem was gone and I did nothing in between !

Quite strange but good news 😉

May 7, 2019 at 2:40 am #3753437

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Steven Daniels,

Thank you for your continued patience while waiting for a solution. I am jumping here to let you know I am currently working on your issue, I will give you a detailed reply in the next hours. Thank you for your patience and understanding, have a nice day.

@najman Thank you for the follow up.

May 7, 2019 at 6:43 pm #3761305

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Steven Daniels,

Thank you for your patience while waiting for a solution, I am back with more details for you. I installed your website locally using the provided duplicator package and everything works out of the box in my localhost.

In your particular case besides a too old PHP version (5.3.29), I recommend at least the version 5.6 and above, even better if you can upgrade to the version 7.x for performance and security reasons, I noticed your server blocks any call to the admin-ajax.php script, it happens due several reasons, I can mention permission reasons, some server side security script, not enough resources, so in this case I would ask you to make sure the following:

0 - Ask your host provider regarding the blocked calls to admin-ajax.php script.
1 - Upgrate to a more newer PHP version.

2 - Increase your server resources for:

2.1 - Memory Limit (512MB recommended)
2.2 - Max Execution Time (60 at least)
2.3 - Max Input Vars (3000 is desireble here)
2.4 - WordPress Memory Limit (512MB)

See: https://wpml.org/home/minimum-requirements/

If you are not sure how to proceed with the settings above, please ask you host provider support for these upgrades, after that try to add your translated menu items again and let me know if it helps. Please, let me know if any additional details are required, have a nice day.