This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 15 replies, has 3 voices.

Last updated by Jamal 5 months, 3 weeks ago.

Assigned support staff: Jamal.

Author Posts
April 18, 2019 at 12:22 pm #3639079

nickP-25

After installing and activating WPML CMS plugins my site went into an error state with the 508 resource limit reached message. I couldn't access the admin site to deactivate the plugins so had to use FileZilla to rename the plugins. As soon as I did this, my site was back up and running. So, what should I do because I want a multi-lingual site but can't do that if the site doesn't work when using these plugins?

April 18, 2019 at 1:48 pm #3639705

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please take a look over the solution steps of these 2 tickets below and let me know if that solves your issue?

- https://wpml.org/forums/topic/resource-limit-is-reached/ (ticket has 3 pages so please check each of them)
- https://wpml.org/forums/topic/508-resource-limit-reached-after-2-7-1-update/

If that doesn't help, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 23, 2019 at 11:08 am #3662505

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

In that case, to further debug the problem I’d like to replicate your site locally.

I will need your written approval to be able to duplicate your site using a plugin called "Duplicator" and test your site on a testing environment so can you please let me know if this is ok with you?

After we find the solution for this, the duplicated site will be deleted.

Please let me know.

I will be waiting for your response.

Kind regards,
Mihai

April 23, 2019 at 11:27 am #3662881

nickP-25

Hi Mihai - yes please go ahead

April 24, 2019 at 10:26 am #3671511

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

I will continue the debugging process and as soon as I have any new feedback, I will get back to you.

Kind regards,
Mihai

April 25, 2019 at 8:15 pm #3685763

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you very much for your patience.

I duplicated your site here:
hidden link

After that, I enabled WPML and I got no errors whatsoever (I did not even have to disable any other plugins or the theme, the only thing that I saw when I went to the Plugins page in the backend was that the"breeze" plugin was disabled and I am attaching a screenshot - ignore the cloudways message as that was the plugin I used for the migration of the site), everything worked perfectly. (you can even log into the duplicated site with the same credentials that you are using on your live site so that you can see that).

This means that something might not be right on your server or that there might be some incompatibility between the server settings and WPML or between the server settings, WPML and other plugins that you have active.

Can you please try this:

Enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Also, please make sure that your server configuration respects the list of the minimum requirements here:
https://wpml.org/home/minimum-requirements/

Please let me know what you will be able to find.

Kind regards,
Mihai

April 25, 2019 at 9:31 pm #3686035

nickP-25

I cannot access the duplicate site back end but are you sure all the plug-ins are enabled as some were disabled

April 25, 2019 at 9:32 pm #3686039

nickP-25

I cannot access the duplicate site back end but are you sure all the plug-ins are enabled as some were disabled on our site. I will work through the rest of your message and let you know what happens, thanks.

April 26, 2019 at 8:36 am #3688873

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Mihai is currently on vacation. If you don't mind, i would continue with you to solve this issue.

As you can see in the attached image, 44 plugins are activated in the migrated site.
What could help us understand this issue is PHP debugging. As suggested by Mihai in his reply #3685763

Enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please try to install the latest version of WPML Multilingual CMS 4.2.6
Locate the debug log in: /wp-content/debug.log

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Also, please make sure that your server configuration respects the list of the minimum requirements here:
https://wpml.org/home/minimum-requirements/

Looking forward to you reply.

Best regards,
Jamal
WPML Support

April 26, 2019 at 9:12 am #3689101

nickP-25

Hi Jamal - yes will get the debug log to you but my point was that we disabled the 13 plug-ins because of the WPML problem. Have you tried enabling these disabled log-ins on the duplicate site and if yes does it run ok?

April 26, 2019 at 10:05 am #3689527

nickP-25

Hi Jamal, I have edited the wp-config to include the debug info and pasted the debug log here for you to see https://pastebin.com/Nh3brNfN.

Regarding the minimum server requirements, this is from my cPanel:
cpsrvd 11.78.0.21
Database client version: libmysql - 5.1.73
PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
PHP version: 7.2.7

So it appears mySQL version needs to be updated, do you know how I can go about this please?

April 26, 2019 at 10:16 am #3689677

nickP-25

I just wanted to add, on the wordpress requirements it says "MySQL version 5.6 or greater OR MariaDB version 10.0 or greater." and we do have the MariaDB server version 10.2.23 so maybe it is not a mySQL issue...

April 26, 2019 at 12:51 pm #3690825

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback, unfortunately, it does not contains an error or notice that we could use.

I tested again in the migrated site and i was able to activate all plugins except 2 as you can see in the attached image.
I tested with the homepage and the store page.

I think that MySQL or Maria DB are ok. So i logged into your website and found that WPML is now installed.

Please let me know if there is anything i can do.

Best regards,
Jamal

April 26, 2019 at 4:08 pm #3692199

nickP-25

Hi Jamal - it appears to be working ok now but will keep a close eye on it. Many thanks for your help. Can you confirm when you delete the duplicate site please?

April 29, 2019 at 7:10 am #3700427

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thanks for your feedback. My colleague Mihai is not working today either. I will make sure he deleted the migrated site tomorrow when he would be back.

Best regards,
Jamal