Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by yaronK-3 2 years ago.

Assigned support staff: Yvette.

Author Posts
November 19, 2017 at 10:05 am #1434909

yaronK-3

Hello,
i have a few issues with my site: hidden link.
1. i can't seem to translate the body of the about us page: hidden link , i can get a few translation categories but not the body and not the boxes (above the body).
2. i can't seem to have a footer menu, i sync the menus however the footer didn't sync so i tried to do it manually but it does not show on the homepage when i test, any ideas?
3. in my account i have theses widgets and plugins in my theme that i need to translate: hidden link , how do i do that?
thanks,
Yaron

November 20, 2017 at 9:11 am #1435411

yaronK-3

Hello,
in addition to my ticket, i'm trying to create links for locations (hebrew links for the EN locations_, for example: this link: hidden link, which is not working (hidden link) is the translation of this link:www.eatintlv.com/location/hacarmel-market/ which works fine, any idea why it does not work properly?
thanks,
Yaron

November 21, 2017 at 8:27 am #1436582

yaronK-3

Hello?
did you guys see my previous issues?
i would appreciate you taking a look at my site cause i'm kinda lost in some issues
thanks,
Yaron

November 21, 2017 at 10:34 am #1436735

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I will be helping you with some of your issues. Normally we ask that only one issue be handled per ticket, so I might have to ask you to open a new one if it turns out that the topics are of different nature or if they need to be escalated (e.g. a bug, a compatiblity issue..etc)

To begin, please provide more information about your installation.

1. Technical Information on you environment
Could you please provide information about your environment by following thsese steps: http://wpml.org/faq/provide-debug-information-faster-support/

2. Temporary Access to your system
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

3. Please also indicate if your are using the WPML Translation Editor or if you are using the native WordPress Editor for translating your content.

Thanks

November 22, 2017 at 5:46 pm #1438540

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi

1. Translation of About Us
You needed to introduce a small change (extra blank space) into the body of the post in order for it to show up in the Trnaslation Editor (TE)
I did this for you and you can now see that it appears in the TE. Any small change is accepted...I introduced an extra "blank" at the end of a sentence for example.

However, the content-boxes are pagebuilder elements that are custom and not currently recognised by the Translation Editor.

I tried to add them using the WPML -> Trasnlation Management -> Custom XML Configuration tabl according to this documentation:
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/

However it did not work. I also noticed that you are using quite an old copy of Visual Composer, so you might try upgrading it to the most recent version.

In any case, if the shortocde for content-blocks is not supported, then you can translate the page manually following this documentation:
https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

2. The footer menu
It is strange that you are not seeing the translation options for the menu. I think this is a compatilbity issue with one of your plugins or theme. I have seen this behaviour before with the Swift Framework.

Please open another ticket for this issue so we can look more closely at it.

3. To translate Widgets and Plugins you will be needing String Translation module
Have you read this documentation?
https://wpml.org/documentation/getting-started-guide/theme-localization/

Specifically for Widgets, if you have problems, you can always try the 3rd party plugin:
WPML WIdgets
Here is also some documetnation about widgets specficially:
https://wpml.org/documentation/getting-started-guide/translating-widgets/

4. Location URL
If you try changing your URL format from "Language by parameter" to " A different directory per language" in WPMl -> Languages ->Language URL Format

Does it make a difference in the behaviour?

IMportant: be sure to resave your permalinks after changing the URL format by going to Settings-> Permalinks and selecting the "Save changes" button (you don´t have to actually make any changes).

Thanks.

November 26, 2017 at 7:54 am #1441527

yaronK-3

Hi Yvette
thank you for your detailed reply!
let me refer to each of the sections.
1. thank for adding the extra blank space and solving the body issue in the about us page. about the boxes that you couldn't find a way to translate, can i just make them disappear? if so pls tell me how to do so.
2. thank i see the footer menu, however it kinda look strange, missing a 'dot' between menus (hidden link) any idea how to solve this?
3.thanks, i'll look into this
4.i did as you requested and changed the location URL, now it is not going into a blank page but instead going to the english translation. for example, Hacarmel Market location, the hebrew link: hidden link is redirecting to the English location, to this : hidden link , pls assist on this as well.
thanks in advance.
Yaron

November 27, 2017 at 2:20 pm #1442457

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. Content Boxes
You can translate these content boxes if you switch to the native wordpress editor and translate them within the translated page/Visual Composer builder. (see image).

Othewise, if you are asking how to delete the Content Boxes, you need only switch to the Visual Composer editor in your editor view and delete them (see image). You would need to do the same to the translation though....so why not just translate them manually?

2. Menu Dot
You are not "missing" the menu dot, it is being placed to the left of the menu items instead of to the "right".

If you compare with the appearance in the English footer menu, you will see that the logic is to list the first menu item, and then each following menu item is started with a dot (ie.dot to the Left). This gives the effect of placing dots between menu items.

In your RTL styling, this dot placement is not having the same effect. It does follow same logic, however. It prints the first menu item, and then prints each subsequent item with a dot placed to the "Left" (instead of the right) The effect is that the 3 dots are there, but not placed correctly to give same effect.

You need to approach your theme author/support for this styling issue.

3. URL
You are using the wrong URL format.
You wrote the hebrew link as :
hidden link

When it should be
hidden link

November 30, 2017 at 11:13 am #1445689

yaronK-3

hi Yvette,
thank you for your reply,
1. thank a lot, it worked 🙂
2. understood, i will approach my theme authors.
3. this is strange, because the link you have suggested (and works perfectly) is not the link which appears under the Hebrew translation of hacarmel market, this is how it looks: hidden link
so i was actually using the link the system suggested me without the /he folder as you suggested. can you tell me why the translation of the location is different than the actual link and how can we resolve this that the translations will include the /he folder?
thanks,
yaron

November 30, 2017 at 7:31 pm #1446317

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

3. I am confused about your question.
To clarify the way things are working, I have inlucded temporarily a Language Switcher to the footer of your theme. You can remove it if you wish after reading my response.

If you visit the English: hidden link
and hover over the Hebrew language flag, you will see that the translated link is having the language directory added to the permalink base.

This is following the rules that you set for the URL Format in WPML-> Languages

The image you posted is the Hebrew translation of the taxonomy term "HaCarmel Market".
This is a taxonomy label. It does not really have it´s own link apart from the slug associated with it.

The permalink base will use URL format you configured (e.g. with the /he/ added) and append it to the taxonomy term slug. This full URL will open the archive page for any listings that are tagged with this taxonomy term.

I hope by explaining how things work, I might have answered the question you posed which I could not really understand.

December 2, 2017 at 7:11 am #1447557

yaronK-3

hi Yvette,
thank you for taking the time for explaining this issue.
perfectly understood 🙂
regards,
yaron